Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 761
  • Last Modified:

Disable keyboard during boot up Debian Linux computer

Dear Experts,

Question-1:
Since I want to have more servers in my work area and it is not neccessary to have
one keyboard for each sever, I would like to disable or disconnect cable of  keyboard in order to avoid F1 keyboard error during rebooting server for maintenance or other system issue.

Is it possible to achieve this for Debian Linux computer for disconnecting the keyboard cable and run the boot successfully  ?

I tried to disable keyboard on the console-setup file at /etc/default/ on linux terminal
and run "update-grub" cmd, and reboot it , but it fail for what I need, and it just disable the keyboard input on the console only.

In other words,  there is still F1 keyborad error during rebooting when I disconnect the cable of keyboard of the computer.  

I have changed some setting on BIOS setup to avoid F1 keyboard error, but all is failed.
Do you think the F1 keyboard error is caused by  BIOS or linux system when I disconnect the keyboard cable during booting.

Question-2:
Could I reboot all my servers through network or internet ? How to achieve this that
may help me not to solve question-1 above

Duncan
0
duncanb7
Asked:
duncanb7
  • 3
  • 2
2 Solutions
 
Dan CraciunIT ConsultantCommented:
The famous "Keyboard missing. Press F1 to continue" is generated by BIOS.
On some motherboards you can disable it (HALT ON ALL/ALL but KEYBOARD/NONE) on some you cannot.

PS: that message was the first indication I had, years ago, that programmers do have a sense of humor...

HTH,
Dan
0
 
duncanb7Author Commented:
Since those computer is really old(8 year-old ago) and that is why I  just keep it for server or disk space usage, probably they all are Not such mode on BIOSI setup for
avoiding F1 keyboard error.  And I don't want to throw those old computer away
since they are still in really good sharp

How about do rebooting on internet network for question-2 ? How to do achieve that
if question-1 is no way to solve it ?

Please advise

Duncan
0
 
Dan CraciunIT ConsultantCommented:
You can reboot any server after connecting using RDP(Windows) or SSH(*nix). That does not mean it will pass the BIOS error, though.

If you cannot bypass the message from BIOS, buy a $3 keyboard and let it there.

Dan
0
 
duncanb7Author Commented:
Probably that is final solution or buy new computer able to avoid F1 keyboard error
if the number of  server is going up
0
 
Dan CraciunIT ConsultantCommented:
I do believe a new (or used) keyboard is cheaper :)

BTW, if your servers are close to each other you can buy a multiport KVM switch that will allow you to control all of them with a single keyboard/mouse/monitor

For ex: http://www.aten.com/products/KVM-Switches/Rack-KVM-Switches/8-Port-USB-DVI-KVM-Switch~CS1768.html

Glad I could help!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now