Unable to launch VM from browser

I am having an issue where my staff logs into a client portal and they use the citrix receiver to pull a desktop. It worked great up until a few days ago and now it will not open. It is just trying to save the file or open the file like it would a normal file that was just downloaded using the browser. I have tried this in IE as well as Chrome. Here is what I have tried

- Added Site to trusted sites and lowered security level on Zone
- Uninstall and re install of receiver
- add site to compatibility view
- Turned off the pop-up blocker
Kelly-BradyAsked:
Who is Participating?
 
Kelly-BradyConnect With a Mentor Author Commented:
This turns out to a file association issue that occurs because of a bug. I had to go and associate the ICA file extension
0
 
Justin YeungSenior Systems EngineerCommented:
you mean when they click on the application within the browser or when you get to the actual web interface gui?
0
 
bas2754Commented:
Shot in the dark, but have you tried to:

1. Disabled any AV software you have running on the system?  Webroot AV in particular likes to find Citrix components as possible Malware.

2. There is a removal tool to cleanup all Citrix software on a system.  I don't have the quick link to it and cannot find it at the moment, however this would be something to try if the AV route does not correct it.

Those are where I would start.  I don't work a lot with Citrix, however I have seen this problem and in my cases the two things that fixed it are what I have listed.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Kelly-BradyAuthor Commented:
I have Webroot on one that is having the issue but I have not installed it on the other one yet. I will also look around for the cleanup tool
0
 
Kelly-BradyAuthor Commented:
Justin

It is when they are in the browser
0
 
Justin YeungSenior Systems EngineerCommented:
uninstall citrix receiver then

delete the registry key HKLM\Software\Wow6432node\citrix\ICA CLient

restart and reinstall citrix receiver
0
 
Kelly-BradyAuthor Commented:
I did the uninstall bit that reg key was not present on the system

Anything else before I attempt the re-install
0
 
Kelly-BradyAuthor Commented:
Ok I got one working and I had to uninstall the one from the web site and then install the one from the Microsoft Store and it worked. You would think it would be the same reciever, but atlas it is not
0
 
Kelly-BradyAuthor Commented:
Now this one was having an issue and I resolved by installing the Enterprise client from August 2013. Is there a compatibility issue with newer receiver and maybe an not up to date citrix environment?
0
 
Kelly-BradyAuthor Commented:
This is continually being an issue. Is there anyone that can help narrow down why the receiver frequently will not open the ICA file. All I get is the ability to download, but when I go to open nothing happens.
0
 
Dirk KotteSECommented:
if you save the .ica file and try to open ... you are asked which application should open the file?
something happens if you click the file?
is the file existing after double-click it or is it deleted automatically?

if you create a .txt file, rename it to something.ica ... which icon is presented for this file?

are all users affected or only some?
0
 
Kelly-BradyAuthor Commented:
When I go to open it does nothing. The file also does not delete it is still in the downloads folder. I have attached what the renamed text file looks like and it appears correct to me. And this is affecting just about half of my users as of right now. It is very random, one day it will be working fine then all of a sudden it will not work.
0
 
Kelly-BradyAuthor Commented:
Here is the upload.
CitrixShortcut.png
0
 
bas2754Commented:
We are seeing more and more of our clients having problems with the ICA client when the client gets updated to a newer / latest version.  We run Ninite on many of our client's systems to handle Third Party updates and have had to disable any Citrix updates due to the new versions breaking connectivity to older clients.  If you are having to continually reinstall then my guess is you are running into something similar.
0
 
Kelly-BradyAuthor Commented:
Which client do you go back to? So in essence which is the most compatible version of the ICA client?
0
 
Kelly-BradyAuthor Commented:
The other solution's were not what solved it, it is a association issue that seems to be fixed now.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.