Office Docs not launching from Sharepoint 2010 Doc Libraries

Hi Everybody!

I have been having an issue with some users and their ability to open Office Docs (.xls, xlsx, doc, docx, etc) from SharePoint Document Libraries.

When they try to open a document, it launches the application (Excel) and tries to download/open the file but eventually kicks the error:

 'Could not open 'http://sharepointserver/etc/filename.doc'

An added kicker, if I let it sit for a minute, Internet Explorer gives an 'Internet Explorer cannot display this webpage' message. It will also occasionally prompt me for credentials as well to get back into SharePoint (but it fails and just still displays the cannot display this page message).

PDFs open normally.

Details:
We use SharePoint 2010, Office Professional 2010 SP2, IE9, Windows 7 Enterprise.

What have I tried so far?
1) Made sure the site was added to compatibility view (corrects other issues for us)
2) Tried deleting the "C:\Users\username\AppData\Local\Microsoft\Office\14.0\OfficeFileCache" folder (saw this as a solution for a few people).
3) Made sure the user wasn't using IE-64bit.
4) Tried changing Local Intranet security settings (unchecking Auto Detect, adding site to zone manually).
5) Made sure 'Enable Integrated Windows Authentication was set under Internet Options > Advanced.
6) Went into Word and Excel and tried adding the path to Trust Center. Also turned off Protective View settings.
7) I turned off our Web Filter for the user as well (just to confirm that wasn't causing the issue).
8) I recreated the issue on a users machine as myself (Domain Admin).

Does anybody have any suggestions?

Thank you in advance!
SSGITAsked:
Who is Participating?
 
livanescuCommented:
your problem is with webdav... web client

Check this registry key:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WebClient\Parameters]

"AcceptOfficeAndTahoeServers"=dword:00000001
will allow to connect to SharePoint servers

"BasicAuthLevel"=dword:00000002
"UseBasicAuth"=dword:00000001
will allow to enable Basic authentication for both secure and non-secure sites

"InternetServerTimeoutInSec"=dword:00000090
"SendReceiveTimeoutInSec"=dword:00000120
"LocalServerTimeoutInSec"=dword:00000050
"ServerNotFoundCacheLifeTimeInSec"=dword:00000009
- values can be changed - they will increase the timeout for your webclient

create a new key as Multi-String value and call it AuthForwardServerList
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WebClient\Parameters]
"AuthForwardServerList"=hex(7):

here add the sites you want to use Windows Integrated Authentication - this is the place where office apps will look for "integrated authentication".

And this will probably fix your issue.

Almost forgot: IE Internet Options --> Connections--> LAN Settings--> uncheck "Automatically detect settings" (it practically kills webdav connections)
0
 
SSGITAuthor Commented:
Thanks! I will give this a shot and see if it works.
0
 
SSGITAuthor Commented:
It looks like this partially works. It now opens the first time, but then when you close out and try to reopen it does the same thing again. After a reboot, it opens the first file just fine, and then comes back with the same 'could not open' message again.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
livanescuCommented:
after applying all those settings, restart the webclient webservice.
sometimes we needed to restart internet explorer completely.
also try to  increase the timeout values (I did and noticed an improvement)

and check for IE addons that will try to hijack the authentication (any weird adware related)
0
 
SSGITAuthor Commented:
This issue is still somewhat unresolved. I don't have a system currently at my disposal to constantly try fixes on. While this seemed to fix the issue for a bit, it wasn't quite 100% there. I think there is more 'tweaking' we would need to do, but gives us some direction.
0
 
qforlongSenior Manager, ITCommented:
I have the same situation on two Win 7 Pro notebooks. I have tried every suggestion (including the ones marked as an answer in this thread) without any change in the error.  We are well past the point where we would ordinarily just re-image the workstation but I am stubbornly trying to figure it out in case it occurs on other machines.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.