MicroSD reader is no longer available on my DELL laptop XPS L501X

I my laptop doesn't show the MicroSD as a drive any longer.   I have not used this PC for a month or so.  Further, the large external harddisk is not shown either.

I am running Windows 7 Ulimtate.
ComputerManagement-screenshot.JPG
thesurfer31Asked:
Who is Participating?
 
rindiConnect With a Mentor Commented:
Check your devices in device manager. I'd also download the drivers for your PC from the Dell site, particularly the chipset drivers, and reinstall them. Make sure you have applied all windows updates.
0
 
Santosh GuptaCommented:
1. Make sure plug n play services are running.

2. plz check this registry value of START should be 3.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\USBSTOR
0
 
thesurfer31Author Commented:
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
thesurfer31Author Commented:
Ok...there was one update in the list.  It had a problem and I had to go to Microsoft to get the solution.  That fixed the MicroSD problem.....HOWEVER, the 1TB hard disk still doesn't show up.  

I am guessing that is another question?
0
 
Santosh GuptaCommented:
Try this 1

Click on Start --> In search box, type cmd and press Enter.

"Command Prompt" will be opened.

Now enter the below commands

set devmgr_show_nonpresent_devices=1 --> Press Enter

cd\ ---> Press Enter

cd windows\system32 --> Press Enter

start devmgmt.msc --> Press Enter

"Device Manager" window will be opened.

Now in the device manager, click on "View" --> Select "Show hidden devices"

Now expand all the nodes by clicking on "+" symbol. If you find any greyed

entries --> Right click on it --> Select "Uninstall".

Restart your PC --> Now try connecting your external drive.
0
 
rindiCommented:
Does that drive need external Power which you have forgotten to connect to?
0
 
thesurfer31Author Commented:
Santosh  -  there were no greyed out items nor where there any problems with the devices in the DeviceManager

Rindi - No I have NOT forgotten the electrical plug ;-)  however, the working light on the hard disk doesn't come on when I boot the problem PC.  I need to remove the USB cable and re-insert it into the PC to get a light.  But it still doesn't work on this PC, the WD 1TB harddisk does work fine on my other PC.
0
 
Santosh GuptaCommented:
Please check if these file are present.

C:\WINDOWS\inf\usbstor.inf
C:\WINDOWS\inf\usbstor.pnf
C:\WINDOWS\system32\drivers\usbstor.sys
0
 
rindiCommented:
Have you tried it on all the PC's USB ports? Have you at least reinstalled the chipset drivers? Also check your BIOS, sometimes there are different settings in there for USB devices.
0
 
thesurfer31Author Commented:
Santosh,  yes those files are all in those directories.
usbstor-inf-PNF.JPG
USBSTOR.JPG
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.