Exchange 2010 Server unable to relay 550 5.7.1 from external users

Emails sent from external clients to my exchange server 2010 box are getting "unable to relay 550 5.7.1" I have all the proper permissions in the receive connectors. Default receive connector I have anonymous users, Exchange users, Exchange servers etc, if the domain is .local this should not matter correct ?
precisionitAsked:
Who is Participating?
 
precisionitAuthor Commented:
Okay so I figured out a solution, I am posting this so the other guy does not have to spend hours trying to figure this out.
The problem was that the domain was changed from .com to .local, somehow this caused DNS issues and relay to anonymous did not work also.
I was able to fix by PowerShell with the below command.

Get-ReceiveConnector “relay” | Add-ADPermission -User “NT AUTHORITY\ANONYMOUS LOGON” -ExtendedRights “ms-Exch-SMTP-Accept-Any-Recipient”

"relay" should be replaced by the name of your connector.

Tested it and I was able to receive emails from gmail, Hotmail and external Exchange.
0
 
Simon Butler (Sembee)ConsultantCommented:
Are you sure the response is coming from your server?
Anonymous only is all that you need to have enabled on the Receive Connector. The public domain must be listed on the Accepted Domains list.

The WINDOWS domain being .local is fine, Exchange doesn't really care.

Simon.
0
 
Ahmed786Commented:
Below article would be helpful written by Paul Cunningham.

http://exchangeserverpro.com/how-to-configure-a-relay-connector-for-exchange-server-2010/
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
Ahmed786Commented:
Are you able to send email to external users from your exchange organization ?

You mean to say that other external user say hotmail or yahoo mail id are not able to send you email and they get error 550 5.7.1 as an NDR ?
0
 
Ahmed786Commented:
If external users are getting error while sending email to your organization then the problem is from there end, they need to set proper setting in receive connector.
0
 
precisionitAuthor Commented:
Yes I am able to send to external user's but users are getting bounce backs for example if I send from gmail or another exchange organization.
0
 
precisionitAuthor Commented:
This is what external users are getting

Technical details of permanent failure:
 Google tried to deliver your message, but it was rejected by the server for the recipient domain companyname.com by mail.companyname.com. [71.187.215.41].

 The error that the other server returned was:
 550 5.7.1 Unable to relay
0
 
Arjun VyavahareTechnical ConsultantCommented:
Can you please try to verify MX using below URL:
http://www.zmailer.org/mxverify.html

If you get error message then it seems that there is issue with your MX Record.

Request you to share us the output.

Regards,
Arjun
0
 
precisionitAuthor Commented:
I forgot to mention that I can receive internally if I email from inside the domain, I can only send to external domains.
0
 
Ahmed786Commented:
Are you using any firewall in your network which is faced to the internet, that might be causing the problem.

You may refer microsoft article on how to Configure Internet Mail Flow Directly Through a Hub Transport Server

http://technet.microsoft.com/en-us/library/bb738138.aspx
0
 
thomasdavisCommented:
Test inbound SMTP https://testconnectivity.microsoft.com/ and post results.

You can also test your email server here http://mxtoolbox.com/SuperTool.aspx?action=smtp%3a&run=networktools

Do you have a receive connector in the server config hub transport to accept traffic from port 25.
Do you have receive mail from remote servers 0.0.0.0-255.255.255.255?
Then check your permission groups. Who has permission to connect to this receive connector? Anonymous users?
0
 
Ahmed786Commented:
The above command was present in my first link provide above in the

If you scroll down to that article you can find below as

Scott Granado says:
October 8, 2013 at 2:36 pm
no no no… just because this works, its not the right way to do it… Please see: http://technet.microsoft.com/en-us/library/bb232021(v=exchg.141).aspx

Make the change in the Exchange Shell to allow relay for anon user:
Get-ReceiveConnector “Anonymous Relay” | Add-ADPermission -User “NT AUTHORITY\ANONYMOUS LOGON” -ExtendedRights “Ms-Exch-SMTP-Accept-Any-Recipient”

The issue could be due to numerous things but we have to go step wise just to make sure it works and doesn't harm anything in future.
0
 
precisionitAuthor Commented:
Because It requires powershell.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.