Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17


Windows 8.1 upgrade IE11 and socket errors

Posted on 2014-03-10
Medium Priority
Last Modified: 2016-11-23
Windows 8.1 woes

New Dell Inspiron 7737 laptop came with windows 8
installed all my apps and docs - working a treat.
Ghosted the drive to a new SSD using Faststone DriveClone and worked a treat (and lots faster).
Used the laptop for several weeks without issue, developing code and using MySQL, MS SQL etc.

Upgraded to 8.1 and now I have a number of problems.
IE11 desktop version does not work.
It displays a "This page can't be displayed" error
The Metro IE11 works fine and displays any page without errors.
However this is not the only problem I have.
None of my remote support programs now work (Teamviewer, Netviewer).
They all ask for Proxy settings even though I have never had to use a proxy before.
Even if I add a valid proxy server they still do not work.
In addition my MySQL database will not start at all.
I get a "cannot create socket error"
The MS SQL database server runs (and I can see it from Management Studio) but if I try and connect to it from code I get an ODBC error.
I'm guessing that it's a TCP stack problem but not sure what to do next.

I've tried restarting with a clean boot (disabled all services except Microsoft and disabled all startup items) but this had no effect.

I've used Internet Options, Advanced, Security and enabled Enhanced Protected Mode and this lets IE11 Desktop open some websites but only a few (I think it's only the ones that I've already opened in Metro version but don't quote me on that).

I've Used Turn Windows features on and off to untick IE11 restart, re-enable, Reset Advanced Settings to clear any settings and restarted and still have the same problem.

I've downloaded the latest network drivers using IE11 Metro (in case the install trampled these) and re-installed these (I had the latest already so it does a repair install). I've updated the Bios to the latest from Dell website (A06).

Not sure what to try next - this is a development laptop and it took me 3 days to install all my stuff (MS SQL, MySQL, VS2014, VS6.0, Drivers, Source Code, USB DIO cards and so on).

I still have the original hard drive before clone so I'll use that for now (means re-installing
some stuff) but I would like to find a solution to this if possible.
Question by:CNC-Guy
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 3

Author Comment

ID: 39918774
PS - should have said - of course I've disabled the firewall in case that was the problem.
LVL 22

Expert Comment

ID: 39918843
Can you ping a site by name (e.g. ping or by number (e.g. ping successfully?  If so, that says that basic networking is not the issue, but something that has to do with web browsing is the problem.

Have you tried Chrome or Firefox to see if this is an IE problem?  That would help pinpoint where to look.

Have you created a new user to see if this is related to your specific account?

I've seen similar problems (able to ping the internet but not use a browser) that end up being virus related.  I've no good idea why this would have come up during an upgrade to 8.1 but I would still be looking in that direction.

Author Comment

ID: 39918999
I'll try that in a couple of days (I've put the original drive in as I've a presentation tomorrow).
The problem is present if I log in as local user or through my Microsoft account.
I'm going to scan the drive for viruses in an external caddy on another machine.
Then I'll put it back and try creating a new user and run other tests.
I've noticed on the MS forums that quite a few users have experienced a similar problem when upgrading from 8 to 8.1 (One IE works and the other does not) so I don't think it's a virus.
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.


Author Comment

ID: 39924423
I have scanned the drive with AV and MalWare Bytes in a caddy (booted from a separate known clean disk) and there are no viruses on it.
Next I'll put it back in the laptop and run the other ping tests etc.

Author Comment

ID: 39927124
I've put the Win 8.1 drive back in the laptop and installed Firefox
I've also installed all the latest Win 8.1 updates just in case.

I CAN ping IPV4 addresses (not tried IPV6 but don't use them).
I CAN ping or any other domain.
Firefox DOES NOT work.
IE desktop DOES NOT work
IE metro DOES work
MySQL DOES NOT work (create socket error).

Created a new local user
Results exactly the same as above.

Used Process Explorer highlight IE desktop or FireFox, Properties, click TCP/IP tab - nothing in the list (it's empty).
Highlight IE Metro, Properties, TCP/IP and I get a long list of connections.
Got the PID of both IED and IEM and then ran TCPView and sorted by PID
IEM is there with a list of connections - IED does not appear in the list (no connections so it wouldn't).

What next?

Author Comment

ID: 39927154
I've just fired up TcpSpy, clicked start (Spy next created process) and then ran IED and it does not spy anything.
I then tried running MySQL and TcpSpy gave me:
Process attached, command line = 'mysql'
a socket could not be created (family=AF_INET, type=SOCK_STREA, ....... WSASYSCALLFAILURE (A system call that should never fail has failed)
process detached

Looks like a TCP socket layer problem - so how do I solve it?
LVL 22

Accepted Solution

CompProbSolv earned 1500 total points
ID: 39927252
I believe that you are correct that it is a socket layer problem.

Run the following from an elevated command prompt:
netsh int ip reset C:\resetlog.txt
netsh interface ipv4 reset
netsh winsock reset catalog
netsh int ip reset reset.log hit

Reboot and test again.

If you get failures when resetting, take a look at this link:

Author Comment

ID: 39927955
Will do and let you know.

Author Comment

ID: 39929113
That has cured the problem and everything also seems a lot faster (DB access is instantaneous).

But I did get some failures :-
netsh int ip reset
Interface OK
Unicast Address OK
Neighbour OK
, failed
Access is denied

netsh interface ipv4 reset
Resetting , failed
Access is denied

netsh winsock reset catalog
Successfully reset the winsock catalog

Do I need to worry about any of these.

Author Closing Comment

ID: 39943304
This worked despite some failures.
So in the end it's a success.
Would still like to know what the failures meant.
LVL 22

Expert Comment

ID: 39943884
Did you run those commands from an elevated prompt?

Author Comment

ID: 39944819

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction Ever had certain email messages or responses that you find yourself using over and over again? Do you use Google's Gmail system? If so, then this article is here to help you save time by teaching you how to create email templates from …
It’s a strangely common occurrence that when you send someone their login details for a system, they can’t get in. This article will help you understand why it happens, and what you can do about it.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
In this Experts Exchange video Micro Tutorial, I'm going to show how small business owners who use Google Apps can save money by setting up what is called a catch-all email address in their Gmail accounts. By using the catch-all feature, small busin…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question