Solved

Server 2012R2 - online backup of 2008R2 guest but guest is put in saved state

Posted on 2014-03-10
1
1,263 Views
Last Modified: 2014-03-11
I have a backup problem.
The Backup application is BackupAssist. I am using latest version which supports 2012 R2.

BackupAssist can be considered as wbadmin with advanced scheduling.

I have a few Guest VMs on the host. All are fine and do their online backups without being "saved". The most important machine is this SBS2011 Guest OS which seems to need to be put into saved state as shown below:
Log Name:      Microsoft-Windows-Hyper-V-Worker-Admin
Source:        Microsoft-Windows-Hyper-V-Worker
Date:          10/03/2014 11:26:09 PM
Event ID:      18510
Task Category: None
Level:         Information
Keywords:      
User:          NT VIRTUAL MACHINE\7D2F24F7-45F8-4F20-90F4-CCFA1E582CA8
Computer:      PRIVACY
Description:
'PRIVACY' saved successfully. (Virtual machine ID 7D2F24F7-45F8-4F20-90F4-CCFA1E582CA8)


Log Name:      Microsoft-Windows-Hyper-V-Worker-Admin
Source:        Microsoft-Windows-Hyper-V-Worker
Date:          10/03/2014 11:27:11 PM
Event ID:      18596
Task Category: None
Level:         Information
Keywords:      
User:          NT VIRTUAL MACHINE\7D2F24F7-45F8-4F20-90F4-CCFA1E582CA8
Computer:      PRIVACY
Description:
'PRIVACY' was restored successfully. (Virtual machine ID 7D2F24F7-45F8-4F20-90F4-CCFA1E582CA8)


At another site I have what looks to be the EXACT same config and it works fine.
At that site the SBS2011 Guest was built on Server 2008R2 Hyper-V and later we upgraded the Host OS and installed the newer Integration Services and all was just great.

In this case the SBS2011 Guest was deployed on 2012 R2 Hyper-V under SBS Migration scenario (from SBS2008), W2008R2 SP1 was installed and then installed Integration Services.

For this troublesome Guest OS:
Hyper-V Integration services are installed
Guest Services are enabled, the only integration service not enabled is "Time synchronisation"
All Guest Disks are BASIC
Free Space on GUEST is fine
Guest Machine is SBS2011 (aka Windows Server 2008 R2) and supports VSS required services started and running
Other Windows Server 2008R2 and Win7 guests are fine and do live online backup without using saved state.
Host 2012 R2 Hyper-V Manager reports the Integration Services for this machine are "Up to date"
There's no backup configured within the guest.
The Guest os is SBS2011, it was a migration install and once in I was able to update it to Windows Server 2008 R2 Service Pack 1 and then install 2012R2 Hyper-V integration services.

I am considering reinstalling Hyper-V Integration services but when I last tried that it simply said that the latest version is already installed...


Does anyone have a suggestion ?

Thanks
0
Comment
Question by:Dave_Nicholls
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 

Accepted Solution

by:
Dave_Nicholls earned 0 total points
ID: 39922606
Thanks to all those who took the time to even consider this crazy situation. For those interested this is now sorted.

Here’s what was don’t to sort it…
Last night I did these and the backups are now sorted:
•         I tried to remove and reinstall the Hyper-V integration services:
o   when doing so it complained I was already running current version of them but I shutdown anyhow
o   while shutdown:
¿  I removed one of the two virtual DVD drives in the Guest – unlikely to have had an impact on the backup
¿  I ticked off the “Guest Services” and “Data Exchange” and “Backup” services and applied and then put them back and applied
•         May have helped but probably not
•         After booting the Guest up and seeing all was well in its world I deleted the “WindowsImageBackup” folder from the backup destination (a USB disk)
o   I suspect this was the catalyst to getting backups back on track!

When the backup to the USB disk commenced the SBS2011 Guest remained online and available.

I then removed the “WindowsImageBackup” folder from the other backup destination (an iSCSI target on a QNAP) and let that one run to schedule and it too worked.

I have checked the Microsoft-Windows-Hyper-V-Worker-Admin Log on the 2012-R2 Host and there was no message about the guest being saved or restored.
0

Featured Post

Why You Need a DevOps Toolchain

IT needs to deliver services with more agility and velocity. IT must roll out application features and innovations faster to keep up with customer demands, which is where a DevOps toolchain steps in. View the infographic to see why you need a DevOps toolchain.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
SBS 2008 to Server 2012 6 37
ntp server 15 74
How to install MDT 2013 on Windows Server 2012 R2 3 34
Firewall support--by the month? 10 54
A Bare Metal Image backup allows for the restore of an entire system to a similar or dissimilar hardware. They are highly useful for migrations and disaster recovery. Bare Metal Image backups support Full and Incremental backups. Differential backup…
OfficeMate Freezes on login or does not load after login credentials are input.
In this Micro Tutorial viewers will learn how they can get their files copied out from their unbootable system without need to use recovery services. As an example non-bootable Windows 2012R2 installation is used which has boot problems.
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question