Terminal Services Printer Management

We have 2 terminal servers. 1 is running Windows 2008 R2 and the other is Windows 2008. When users login on the R2 server they can see the "Devices and Printers" folder. When they login on the 2008 server they do not, which means they cannot manage their own printers. Both servers are attached to the same GPO and gpresult output is the same on both. Any suggestions?
medxAsked:
Who is Participating?
 
Joe JenkinsCommented:
Check that same GPO that is applied to those terminal servers and see what the status of this setting is:

User Configuration\Administrative Templates\Start Menu and Taskbar | Remove Programs on Settings Menu

Maybe explicitly define that setting, gpupdate /force and see if that makes a difference.  I had a similar issue and that was it for me.
0
 
Manjunath SulladTechnical ConsultantCommented:
There will be a issue with Antivirus / Firewall rules in Windows Server 2008,

1. Disable temporary Windows Firewall and Antivirus on server and check.

2. If issue persists Boot the server in Clean Boot mode.



Please go through below link for more reference.

http://social.technet.microsoft.com/Forums/windows/ar-SA/1584cd60-b06b-4550-a5dd-62eea5754947/devices-and-printers-page-takes-forever-to-load-doesnt-show-my-devices-or-printers?forum=w7itproinstall

- Manjunath Sullad
0
 
medxAuthor Commented:
It's not an antivirus problem. Devices and Printers is not visible to users from the Start Menu on that server.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Manjunath SulladTechnical ConsultantCommented:
Check the all Bluetooth services are started or not, If not started, Start the bluetooth services.
0
 
medxAuthor Commented:
Thanks Joe. That setting was applied in the GPO. I set it to "not configured" for now to see if it changes anything. I will update you.
0
 
Joe JenkinsCommented:
Excellent.  I will look for your comment!
0
 
medxAuthor Commented:
That worked! Thanks Joe.
0
 
Joe JenkinsCommented:
Glad to help!  Have a great week!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.