• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 135
  • Last Modified:

CAS Array

Hi,

I have recently made a CAS array to our Exchange environment.  Since them we are getting an issue with Outlook.  It hangs for few seconds few times a day.  Users are getting a message on screen that Outlook is trying to retrieve data form the CAS box?  After few seconds it works.  I am not sure I need more memory or what on the CAS servers but I have 4GB on each box.

Any suggestion is really appreciated.

Thanks
0
FundFire
Asked:
FundFire
1 Solution
 
Gareth GudgerCommented:
How are you currently load balancing the CAS array?
0
 
FundFireAuthor Commented:
Using Windows Load Balancer.
0
 
Simon Butler (Sembee)ConsultantCommented:
If you bypass the Windows NLB address, so point it directly at the CAS role server, what happens then?

You are aware the Exchange product team does NOT recommend the use of WNLB?

Simon.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
jimmithakkarCommented:
I thought your CASArray and OWA url is same,
ex CASArray: abc.mylab.local
and OWA url: https://abc.mylab.local/owa 
and both are internet facing in this case  i had observe this issue, need to create new CASArray and configure outlook base on new casarray.

it will work.
0
 
FundFireAuthor Commented:
The CAS array and OWA is not the same.  I created the array because of the Outlook users so we have some redundancy but OWA is still pointing to original server.

Please note I installed WLB on both servers, I had to.  But it does not make a difference if I  point users directly to the server and not the WLB same thing happens, users getting a time out either way.  So, it had to do with the WLB installation I did last week on server that users where pointing to.
0
 
Simon Butler (Sembee)ConsultantCommented:
The CAS Array address should not be used for anything else - it should be unique to that service and MUST NOT resolve on the internet.

Was it working before the CAS Array was introduced?

You didn't have to install WNLB on to the servers at all. There is no requirement to use WNLB to use a CAS Array.

Simon.
0
 
FundFireAuthor Commented:
I increased the memory and I have no issues.
0
 
FundFireAuthor Commented:
Because the memory was the main issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now