Solved

IIS 7 - HTTP Error 500.19 (web server migration)

Posted on 2014-03-11
16
631 Views
Last Modified: 2014-03-25
I have an old Server 2003 web server running IIS 6.  I need to move this server and all of its applications to a new web server running Server 2008 R2 with IIS 7.  I've already got the new server up and running with IIS 7 installed as well as all required features.  I made the same drive (Letter E:) that the old server had for the actual storage housing the web server folders and literally copied and pasted all of the data onto this drive so the structure and web.configs as well as the configuration.asp pages are the same.  However, I get the attached error (see screenshot) when I try to browse to this website from IIS 7 by name or by IP on the new server.  Can anyone help me decipher this?

IIS7HTTPError500.19
0
Comment
Question by:Brad Bouchard
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 6
16 Comments
 
LVL 8

Expert Comment

by:N-W
ID: 39922380
You just need to remove line 17 from the config file in the above screenshot. Most likely that line is already inherited from a parent config file, so it's being flagged as a duplicate.

Remove the line or comment it out and it should fix the issue.
0
 
LVL 17

Author Comment

by:Brad Bouchard
ID: 39924227
I took that line out and what I get is a directory listing for the actual web page rather than the website.  See screenshot.

IIS error after taking out the line to add an entry in default documents for login.asp
Next steps?  Things I'm overlooking or doing wrong?
0
 
LVL 8

Expert Comment

by:N-W
ID: 39924945
Ok, so you may need to modify the default document for the website.

1) Open IIS manager and click on the site you're trying to fix
2) In Features View, double-click Default Document.
3) In the Actions pane, click Add. Here you need to specify the first page that should be loaded when browsing your website (i.e. index.html, index.asp, etc.). Click OK when done.

Now try to browse the website again and hopefully it will load the correct webpage.
0
Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

 
LVL 17

Author Comment

by:Brad Bouchard
ID: 39927253
I had already tried that, and while it does load a page similar to my last screenshot, it still isn't working correctly.

I used the Microsoft IIS Web Deploy 3.5 tool to migrate the site from II6/Server 2003 to IIS7/Server 2008R2 and the site is in tact and all the files are in the same tree structure on the new hard drive as they were in the old server but still getting the same error.

I've enabled parent paths and still can't access it.
0
 
LVL 8

Expert Comment

by:N-W
ID: 39933159
Do you see your default page in the list in the screenshot above? If so, click on it and does the page load correctly?

How is this particular website nested? Is it a virtual directory or application?

Where is the applicable default document referenced? (i.e. in your default parent config located at "%windir%\System32\inetsrv\config\applicationHost.config" or a child config)

If possible, try removing the reference to your default document from parent levels and specify it locally at the child site.
0
 
LVL 17

Author Comment

by:Brad Bouchard
ID: 39943810
I will get back to you with answers to your questions tomorrow or next week.  Thanks for the help, and sorry for the delay.
0
 
LVL 17

Author Comment

by:Brad Bouchard
ID: 39945442
After working out the previous error, I think I have the issue narrowed down to what is actually wrong.  I'll post a screenshot and see if you have any idea on this one now.

providernotfound?
0
 
LVL 8

Expert Comment

by:N-W
ID: 39946655
Looks like it's throwing an exception when trying to connect to a database.

You may need to enable 32-bit applications in IIS:
In IIS Manager, select the IIS Server
Actions -> View Application Pools
Select the application pool for your web site
Under Edit Application Pool, click Advanced Settings
Set Enable 32-bit Applications to True (default is False)

If that doesn't work, you'll need to post the lines of code that attempt to connect to the database.
0
 
LVL 17

Author Comment

by:Brad Bouchard
ID: 39950635
Enabling 32-bit applications was already set before I made the original post; I verified this again though just to make sure and it is set right.

Here are the lines of code that are attempting to connect to the database.

constConnectionString = "Provider=SQLNCLI10;Server=SERVERNAME.TEST.LOCAL;User Id=sa;Password=password;Database=correctdatabasename"

Server 2008 R2 Standard for the OS
0
 
LVL 8

Expert Comment

by:N-W
ID: 39951782
Have you installed the SQL Server Native Client on your web server? You'll need to have that installed before you can use the provider "SQLNCLI10".

Here's the download page for it: http://msdn.microsoft.com/en-us/sqlserver/ff658533
0
 
LVL 17

Author Comment

by:Brad Bouchard
ID: 39951866
I don't think I've done that... your link takes me to a page that allows me to download the Native Client but it's bunched in with a lot of other downloads.  Which one exactly am I looking for?
0
 
LVL 17

Author Comment

by:Brad Bouchard
ID: 39951868
Also, do I still need the Native Client if the SQL server is a separate server from my web server?
0
 
LVL 8

Accepted Solution

by:
N-W earned 500 total points
ID: 39951996
Go to this link: http://www.microsoft.com/en-us/download/details.aspx?id=27596

Click Download and select "ENU\x64\sqlncli.msi". Install that version.

You need the Native Client because you don't have SQL Server installed on your web server (the Native Client is automatically installed when installing SQL Server on a machine).
0
 
LVL 17

Author Comment

by:Brad Bouchard
ID: 39953463
I'll give it a try right now.
0
 
LVL 17

Author Comment

by:Brad Bouchard
ID: 39953512
That did the trick.  Thank you for persevering with me through this.
0
 
LVL 17

Author Closing Comment

by:Brad Bouchard
ID: 39953517
Installed SQL Server Native Client (64 bit) and was able to browse to my website.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
robocopy question 3 49
Boolean 13 46
isNaN issue on the Table input text 2 38
my mother board doesn't support windows server 2008 11 59
New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question