Solved

Exchange ActiveSync Multiple Exchange Servers on One domain

Posted on 2014-03-11
8
1,394 Views
Last Modified: 2014-04-13
Hi All,

I have a small issue that i have run into during an upgrade.

Client has SBS 2003 with Exchange 2003.  I have installed a new Windows Server 2012 with Exchange 2010.

I have moved 2 test users mailboxes to the new server.  All good, and it all works via outlook in the office.

The 2 exchange servers are communicating with each other and passing mail correctly.

I can't however get exchange active sync to work for both servers at the same time.

If i forward port 443 to the new server, then exchange activesync to mobile works for the moved mailboxes but not the old non moved mailboxes.  If i leave port 443 pointing to the old server then the users on that server can use active sync.

Is there a way to allow users on either server to have phone access to their respective mailbox.

ie.  Can you run activesync on 2 servers and have the old server re-direct traffic to the new server for the moved mailboxes?

As a side note.  Outlook web access also doesn't work remotely for users on the new server unless i redirect traffic which of course breaks connectivity to the old server.

Internally OWA works as i can point to either server from within the network.

Any advise would be appreciated.

Thanks
0
Comment
Question by:DKajfes
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 34

Expert Comment

by:Shreedhar Ette
ID: 39922623
For both exchange server work they need configure in coexists mode.

Please refer below articles to configure coexists:
http://technet.microsoft.com/en-us/library/dd638130(v=exchg.141).aspx

http://technet.microsoft.com/en-us/library/ee332348(v=exchg.141).aspx
0
 
LVL 8

Expert Comment

by:N-W
ID: 39922729
Here's a simpler article on how to configure Exchange for your requirements: http://exchangeserverpro.com/exchange-2003-2010-coexistence/

In short, unless you are running ISA2007 or similar, you will need multiple public IPs to differentiate between the two servers for OWA/ActiveSync connections.
0
 

Author Comment

by:DKajfes
ID: 39922802
Thanks for the links, however I really only need activesync to work.  OWA is not an issue as they have not been shown how to use it yet.

At this stage the public IP points to Exchange 2003 server, not the new 2010.

Should I redirect traffic to 2010 then link back to 2003?

Can I somehow make activesync work with 2010 via 2003?

Thanks
0
Comparison of Amazon Drive, Google Drive, OneDrive

What is Best for Backup: Amazon Drive, Google Drive or MS OneDrive? In this free whitepaper we look at their performance, pricing, and platform availability to help you decide which cloud drive is right for your situation. Download and read the results of our testing for free!

 
LVL 8

Expert Comment

by:N-W
ID: 39922837
Unfortunately you can't unless your running ISA 2006 or another similar reverse proxy engine.

If you don't have a reverse proxy, you'll need two public IPs (one to point to Exchange 2003 and the other to Exchange 2010).
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39923090
ActiveSync should proxy to the Exchange 2003 server. It is only OWA that requires separate IP addresses.
This is outlined in the Proxy and Redirection article on TechNet.
http://technet.microsoft.com/en-us/library/bb310763(v=exchg.141).aspx

What can happen, particularly with SBS 2003 servers, is that the configuration of the server isn't correct, usually around authentication settings and the proxy fails.

Running the Exchange 2003 BPA (Download from Microsoft), the Exchange 2010 BPA (in the toolbox) and also the external testing tool at http://exrca.com/ can often pinpoint where the configuration is wrong.

Simon.
0
 

Author Comment

by:DKajfes
ID: 39928666
Thanks Simon, I read the article you linked above, and modified the authentication settings.  Still no Joy.  BPA doesn't reveal anything wrong.

So I modified authentication settings as per the article, I opened port 443 for active sync to the new server.

I have a SSL certificate for our mail domain, and assigned the services to it.

Users on the new server can now login via mobile devices - its really slow however. But works. takes over 60 seconds to sync, while old server does it in 2 or 3 seconds.

Users on the old server now get an invalid certificate error.  and I can't connect.

If I set the port redirection back to the old 2003 server, users on the old server can't login due to certificate error until I go back to the new server and un assign services to the SSL cert.  

I can't understand what is going on with the SSL.  

The old server was setup years ago with eg "mail.domain1.com.au"  its not their primary address anymore - they use "mail.domain2.com.au" now.

The new server was setup with "mail.domain2.com.au" as the primary domain when I setup exchange 2010.   I did get a certificate which included both domain1 and domain2 on it.

Exchange 2010 server is on the same local domain as exchange 2003 and the DC.  Internally on the network all users are able to use outlook irrespective of which server their mailbox is on.

Could the ssl have something to do with it?

Thanks.
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 300 total points
ID: 39928867
ActiveSync is very sensitive to SSL errors.
How long is the Exchange 2003 server going to be hanging around for? In cases like this I will often reset the virtual directories.
http://support.microsoft.com/kb/883380

In their default state they should allow the proxying to occur.

Otherwise accelerate the migration and troubleshoot it once everyone is on Exchange 2010. That is much easier, the Exchange 2003 version of ActiveSync is a horrible kludge (it was a bolt on) so breaks easily and is a pig to troubleshoot.

Simon.
0
 

Author Closing Comment

by:DKajfes
ID: 39998063
Thanks Simon,  Was not able to get a solution to this so i have decided to accelerate the migration. Thanks.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
Having trouble getting your hands on Dynamics 365 Field Service or Project Service trial? Worry No More!!!
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
The viewer will learn how to use a discrete random variable to simulate the return on an investment over a period of years, create a Monte Carlo simulation using the discrete random variable, and create a graph to represent the possible returns over…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question