Solved

Internet Explorer 10 freezes when opening SharePoint docs

Posted on 2014-03-12
7
1,118 Views
Last Modified: 2014-03-20
I have a user whose browser will freeze when he tries to open an Excel spreadsheet held in our hosted SharePoint site.  If he waits for approx. five mins it may open and once open, it appears to open without problem thereafter.

Previously he has had installed Project 2007, Office 2010 and proofing tools 2013.  The proofing tools have now been removed.  The OS is Windows 7 Pro.  I mention this as I’ve read articles explaining the mix of versions may cause this behaviour.

If I disable SharePoint related add-on in IE the files opens straight away, but after I reboot I loose functionality, e.g., he will check the file out, but then can’t edit it.

I need to stop IE freezing up and for him to be able to checkout files and open them.
0
Comment
Question by:grsg
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
7 Comments
 
LVL 35

Expert Comment

by:Bembi
ID: 39927581
Yes, mixing versions can have the effect, that the browser plugins are upgraded and do not fit to the office version you are using.

Check the blowser add ins, if you find 2013 versions there, possibly remove them (via registry) and then try to repair (or reinstall) the Office 2010 version, so that the 2010 browser plugins are installed.
0
 
LVL 6

Expert Comment

by:livanescu
ID: 39927911
is the user being asked about username and password?
does he have to login everytime?
how is the authentication done?
0
 

Author Comment

by:grsg
ID: 39928848
Hi livanescu, the user logs in to the site in the morning and won't be asked for a password until he logs out and back in again.  He isn't challenged when he checks out docs if that's what you mean.  I don't know the authentication protocols, it's a hosted site that we login to, sorry, do you need more specifics?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 6

Accepted Solution

by:
livanescu earned 500 total points
ID: 39929060
Try these (but make sure you restart the browser each time, after any of these changes)

First:
IE Internet Options --> Connections--> LAN Settings--> uncheck "Automatically detect settings"
Add the site you try to connect to in Trusted Sites list (IE Internet Options --> Security --> Trusted Sites -->Sites)

Then: (if not enough)

Check this registry key:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WebClient\Parameters]

check if
"AcceptOfficeAndTahoeServers"=dword:00000001
---will allow to connect to SharePoint servers

change first and add the second
"BasicAuthLevel"=dword:00000002
"UseBasicAuth"=dword:00000001
---will allow to enable Basic authentication for both secure and non-secure sites

modify based on your user's experience
"InternetServerTimeoutInSec"=dword:00000090
"SendReceiveTimeoutInSec"=dword:00000120
"LocalServerTimeoutInSec"=dword:00000050
"ServerNotFoundCacheLifeTimeInSec"=dword:00000009
- values can be changed - they will increase the timeout for your webclient

Also...
And monitor in Task Manager the  behavior of the computer...
Maybe too little RAM? Win7 is pretty demanding...

It's hard to guess... but please let me kow if any had any effect
0
 

Author Comment

by:grsg
ID: 39937505
Hi Bembi, sorry I've only just seen your post.  There aren't any 2003 add ins listed, only 2010 which is correct.  The problem is now cured with a combination of adding it to Trusted sites as detailed by livanescu and disabling SharePoint OpenDocuments Class.  It seems if I want to open docs in a client app I need SharePoint OpenDocuments Class ENABLED, but if I want to open docs in the browser, I need it DISABLED. Is that correct???
0
 
LVL 35

Expert Comment

by:Bembi
ID: 39940545
What I can confirm or is....
OpenDocuments Class ENABLED
Basic authentication depends on the environment.

But as it is a hosted environment, may be necessary.
If you have more than one client on the same location, at least you can compare the settings with working systems. If only one user has this problem, check the settings and hints above with working clients. If all clients in a location make trouble, than even network issues (or just the speed) may be a reason. Check with small Excel files if they work better.

Also a possible reason may be, that the Sharepoint browser plugins interference with some others, also a point to compare with working client.

And last but not least, windows firewall (or any other) and virus scanners should put into scope.
0
 

Author Closing Comment

by:grsg
ID: 39942386
Thanks for your numerous pointers, I think we're finally sorted.
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

These days socially coordinated efforts have turned into a critical requirement for enterprises.
In case you ever have to remove a faulty web part from a page , add the following to the end of the page url ?contents=1
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question