Solved

Emails not getting delivered

Posted on 2014-03-12
26
171 Views
Last Modified: 2014-11-12
Hi

I have 2 different domains, www. xyz.com and www.abc.com

when i send email from www.xyz.com to gmail i receive the email but when i send email to www.abc.com address it says that email is send but nothing get received.

mail client is outlook 2007 -2012

where should i start the troubleshooting it.
I have created a new profile but nothing happens.

Thank you for help in advance.

A
0
Comment
Question by:ammartahir1978
  • 13
  • 13
26 Comments
 

Author Comment

by:ammartahir1978
ID: 39923735
hi Just an addition to above question, when i sent email from Blackberry which have xyz.com configures i receive email on abc.com. very wiered can someone shed some light on it
0
 
LVL 8

Expert Comment

by:jpgobert
ID: 39923747
I'm assuming that you run the exchange servers for both domains you listed?  What version of Exchange?  Is there a firewall between your Exchange servers and the internet?  Does that firewall have any spam filtering functionality turned on?

Are any messages coming in to abc?  

I'm assuming that xyz is ok, right?
0
 

Author Comment

by:ammartahir1978
ID: 39923784
The domain xyz.com is a pop account and abc.com is a exchange account.

regards,

Ammar
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 
LVL 8

Expert Comment

by:jpgobert
ID: 39923795
Ok... what about the rest of my questions?  Are you the exchange admin for abc.com?  Firewalls with possible SPAM filtering?

My understanding so far is that GMail messages aren't getting to abc.com but you were able to use a Blackberry to send an email successfully to abc.com, correct?  What email account is the Blackberry using?

I'm trying to help you narrow this down but I need more information.
0
 

Author Comment

by:ammartahir1978
ID: 39923808
okay here is the situation:

i have a domain which is www,ammar.com the emails are pop3, when i send email to any email address i receive them, so if i send email to gmail hotmail or any other domain i receive the emails.

When i send email from www.ammar.com to www.ammartahir.com the email doesnt get delivered to ammartahir.com, but in ammar.com it says its sent.

ammartahir.com is Microsoft exchange, its hosted exchange.
0
 
LVL 8

Expert Comment

by:jpgobert
ID: 39923882
I just ran an MX lookup for ammartahir.com and can't find any MX records.  If that actually is the domain name then I don't know how anyone is sending mail to it because there are no MX records deployed for it.

Is that the correct domain name?
0
 
LVL 8

Expert Comment

by:jpgobert
ID: 39923886
I do find MX records for ammar.com though which I would expect to... it tests out fine.

Just nothing for the other domain...
0
 
LVL 8

Expert Comment

by:jpgobert
ID: 39923901
I take it back... I ran a second check and the records resolved.  Sorry about that.  The SMTP test comes back ok as well.

Curious why my first lookup came back with nothing...
0
 
LVL 8

Expert Comment

by:jpgobert
ID: 39923912
If I were you I'd contact the hosting company and ask them to check their logs for the messages you're sending but aren't arriving in your mailbox.  

Obviously if you send a message and you don't get any reply with an SMTP error of some sort then something is receiving your email.  The fact that it isn't going into your box suggests that something on the Exchange side is holding or filtering the messages for some reason.  

Ultimately the only people who can tell you what is happening is those who are running the exchange server.  They should be able to use message tracking in exchange to see when the messages arrived, how they routed and where they ended up.

Make sense?
0
 

Author Comment

by:ammartahir1978
ID: 39923940
great let me check that.

Regards,

A
0
 

Author Comment

by:ammartahir1978
ID: 39924001
okay i have just found out a new thing, if i use web mail for domain and send an email to ammartahir.com the email get delivered.

so i am narrowing it down to the machine i think or antivirus on machine, because all the users when sending mail from mail client have same issue.

So what you suggest now, i will try to disable antivirus and email scanning and see if that get through but please suggest if you have any ideas.

Thanks
0
 
LVL 8

Expert Comment

by:jpgobert
ID: 39924041
Didn't you say earlier that you don't receive emails to ammartahir.com from gmail either?

If so then that rules out the machine specific issue, doesn't it?

If all of this is correct then whatever the problem is it isn't consistent and I am still thinking it is on the exchange side... but if I got the gmail part incorrect then let me know so we can think on a different track.
0
 

Author Comment

by:ammartahir1978
ID: 39924065
I am receiving emails from ammar.com to all other mail accounts apart from ammartahir.com

so i can receive on gamil hotmail and other email address the only problem is ammar.com emails are not received on ammartahir.com.

but when i send email from webmail of ammar.com i receive email on ammartahir.com.

i hope that explains
0
 
LVL 8

Expert Comment

by:jpgobert
ID: 39924079
It does.

What I would normally do at this point is track the messages through the email server but I don't know how much access you have to the server for ammar.com.  I would send one email with a subject of "Test from client" then log on to the email server and check the message tracking logs.  I'd look to see if the email was accepted by ammar.com and then whether it was properly routed out to ammartahir.com.  I'd then repeat the same test from your webmail login with a different subject, "Test from webmail".  Do the same tracking analysis.

If both messages show that they are received by ammar.com and then properly handed off to ammartahir.com then we know that the issue is on ammartahir.com's side.  If not then we will know where to troubleshoot on the ammar.com side.

Is it possible for you to do this?
0
 

Author Comment

by:ammartahir1978
ID: 39924095
i am calling hosted exchange guys to have a look at it for me as we speak
0
 
LVL 8

Expert Comment

by:jpgobert
ID: 39924114
Awesome... and don't let them BS you about it... make sure they know that you have done testing, you know that messages are being sent and you want detailed tracking info.

Too many times the guys on the other end of the phone will try to blow you off if they think you don't know much...

Let me know what they say.
0
 

Author Comment

by:ammartahir1978
ID: 39924209
okay here are the details.

He could see the messages only where sent via web mail or blackberry but couldnt trace the emails which are sent via outlook client. so he suggested to rebuild the profile which i told him that i have already done.

he thinks its the machine itself. so so roll that out i will disable antivirus on the machine and see if that resolve the issue.
0
 
LVL 8

Expert Comment

by:jpgobert
ID: 39924249
Ok... that definitely narrows it down then.  You're right about removing antivirus as the next logical step now.

What are you using for antivirus?  Is it one of those total security packages that includes firewall, anti-spam, etc.?

Once we rule that out, if the problem still presents, we can reset Outlook's settings back to default.  I'll wait on this part until I hear back about the security software.
0
 

Author Comment

by:ammartahir1978
ID: 39924265
i am using AVG bussiness edition. and i have disable it for 15 mins and sent an email still no luck
0
 
LVL 8

Expert Comment

by:jpgobert
ID: 39924280
Can you uninstall it instead of just disabling?  You can always just reinstall it later.
0
 
LVL 8

Expert Comment

by:jpgobert
ID: 39924293
Looking at AVG's site there are two editions, one which includes email protection... which one do you have?

AVG Antivirus Business Edition or AVG Internet Security Business Edition?
0
 

Author Comment

by:ammartahir1978
ID: 39924308
i have AVG ANTI VIRUS BUSINESS EDITION 2011
0
 
LVL 8

Accepted Solution

by:
jpgobert earned 500 total points
ID: 39924345
Ok... let's step through this one step at a time given everything we know so far...

Email being sent using Outlook, through ammir.com via SMTP, are not arriving at ammirtahir.com

Email being sent using webmail, through ammir.com, are arriving at ammirtahir.com

The ammir.com email server is not on your local network

The ammirtahir.com email is hosted exchange and they have confirmed that the emails from Outlook are never reaching their servers

 - am I correct so far?

You are currently removing AVG Antivirus Business Edition from one of the affected PC's so that we can rule out whether or not it has any part in creating this problem.

**********

If all of that is correct, and if removing AVG does not help, then we are left with the following:

What does the message tracking show on the ammir.com email server?  Does it show that your email from Outlook is being accepted by the server?  If so, does it show that the email is being handed off to the email server for ammirtahir.com?

We already know that the admins for ammirtahir.com say that they're not getting the messages.  That means that the problem now must exist between Outlook on your PC and the first email server ammir.com.

Since we can send email using webmail from ammir.com then we know that it is able to communicate with ammirtahir.com.  Only SMTP emails sent from Outlook on your PC are not making it.

I'm starting to believe that the SMTP emails from Outlook are not actually being received and processed by ammir.com.

Is this making sense so far?
0
 

Author Comment

by:ammartahir1978
ID: 39924370
you are correct so far i am going to remove AVG from the laptop and test the email again.
0
 

Author Comment

by:ammartahir1978
ID: 39929286
hi JP,

Sorry no update yet i will let you know by monday once i get this uninstall i was away from the site and dont have access to laptop.
0
 

Author Comment

by:ammartahir1978
ID: 40027105
hi Guys,.

Nothing still same issue.

I have done all the above which was recommended.

Regards,

Ammar
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Large Outlook files lead to various unwanted errors and corruption issues. Furthermore, large outlook files can also make Outlook take longer to start-up, search, navigate, and shut-down. So, In this article, i will discuss a method to make your Out…
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
This video discusses moving either the default database or any database to a new volume.
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question