Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Time on VM IIS server

Posted on 2014-03-12
13
Medium Priority
?
265 Views
Last Modified: 2014-08-11
I've created an IIS server in VMWare I've set the time on the server for the correct time zone and for the correct time.  I then went into the VMWare Client and set the time on the configuration page in the options for the time configuration.  I also gave it the correct time zone and the correct time.  In addition I even added my NTP server to it so it would sync with the time on my domain.  In addition, I went into the properties of the virtual machine on the options tab and in the VMWare tools I checked the box synchrnize guest time with host but I didn't reboot the guest login.  Not sure if that will even have an effect.  My FTP site updates ever hour and ever 1/2 hour (2 seperate files) both files are still 3 hours behind on the server they are being copied to. The time on the server that the FTP files are copied to is correct.  How in the world can I fix this time issue? It was fine on the old server which wasn't a VMWare box... What am I missing?
0
Comment
Question by:WellingtonIS
13 Comments
 
LVL 37

Expert Comment

by:bbao
ID: 39925671
try the steps given below.

FYI

Timekeeping best practices for Windows, including NTP
http://kb.vmware.com/kb/1318
0
 
LVL 26

Expert Comment

by:Leon Fester
ID: 39925888
Best practice for Windows servers on VMWare is to let the guest sync time with the domain.

You must not configured the guest to sync time with host.
When using w32time or NTP in the guest, disable VMware Tools periodic time synchronization.

•Deselect Time synchronization between the virtual machine and the host operating system in the VMware Tools toolbox GUI of the guest operating system.
See details from the link posted by bbao

If you a using Active Directory then the time sync from the guest OS will suffice and should update from your PDC.

If you are running a stand-alone IIS server then point Windows time to sync from the NTP server only.

Instructions for configuring time sync on Windows Server:
http://support.microsoft.com/kb/816042
0
 

Author Comment

by:WellingtonIS
ID: 39926074
My IIS server is on the domain and there is a policy to sync the time.  The time is correct on the box.  The time is correct on the server that the files are copied to.

I ran the following command:
VMtoolsd.exe timesync {enable}

The instuctions are different but hopefully this works.
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 

Author Comment

by:WellingtonIS
ID: 39926140
that did not work. As the file start to copy from FTP the time is correct as soon as it loads the complete file (you see the KBs) the time changes. So for example the file loaded at 8:30 it read 8:30 with 0KBs as soon as that changed to 5560 KB the time changed to 4:06 a.m?  The time on all the server are correct and syncing to the PDC.  I KNOW it's this box because before I switched to this VMWare the origional box was fine.
0
 
LVL 26

Expert Comment

by:Leon Fester
ID: 39926166
My bad! Looks like we both read the question wrong.

Those instructions that you're trying are for setting the time on your server.

Regarding the time difference between files and the server...
Did you look at the original files directly as they are output by the source?

That is where the file will get it's original timestamp from.
When it's Ftp'd to the server it should update the "last modified" timestamp with the time on the Server but that appears not to be happening from what you've described earlier.

Did you check that the time zones on the source server and the FTP server are set to the same zone? And are the daylight savings options the same?

There was a known issue with timestamp's in previous versions of Windows specifically relating to the FTP client.
http://support.microsoft.com/kb/173054/EN-US

Also check the help documentation for your FTP client as there could be issues related to the client.

See help example for WinSCP:
http://winscp.net/eng/docs/timestamp

Many FTP clients can also preserve the original timestamp:
Also note that for WinSCP to try to convert file timestamp at all, you need to have transfer option Preserve timestamp enabled.

Did you perhaps have a SFTP server before as this protocol does not support preserving timestamps.
0
 
LVL 20

Expert Comment

by:compdigit44
ID: 39926197
I did find article on the internet which other users have reported incorrect timestamps in IIS logs..

http://support.microsoft.com/kb/271196
0
 

Author Comment

by:WellingtonIS
ID: 39926333
That is where the file will get it's original timestamp from.
When it's Ftp'd to the server it should update the "last modified" timestamp with the time on the Server but that appears not to be happening from what you've described earlier

As I said when I had t his on a Hardware Box it was fine.  THis didn't start happening until I switched to the Virtual Box.  We use Beyond FTP.  When I look at the files in Beyond FTP the time is incorrect.

I tried to add a txt file and the time came out as 7:20 a.m. from my own PC.  My PC is synced with time.
I will look at the other information
0
 
LVL 26

Expert Comment

by:Leon Fester
ID: 39926354
Check this help for the transfer settings on Beyond Compare:
Transfer settings:

Preserve timestamps on upload

Mark to force the remote timestamp to match the source timestamp.  Only unmark if it causes problems with the server.

http://www.scootersoftware.com/help/index.html?ftp_profile_transfer.html
0
 

Accepted Solution

by:
WellingtonIS earned 0 total points
ID: 39926381
OK perhaps I'm not explaining this correcly. So let me try this again.  When a file saves to FTP - Not the logs, the time stamp is off.  when I copy a file it's fine.  I'm going to attach screen shots so you can see what I mean and maybe someone can make some sense of this...  It has to be a setting somewhere.
before.png
after.png
0
 

Author Comment

by:WellingtonIS
ID: 39929674
OK experts I have an answer to my issue - it's what to do about it that is the question.  If anyone is wondering this is a Beyond FTP issue.  If you push the same file to the same place with Filazilla or BFTP server the time is correct...
0
 

Author Closing Comment

by:WellingtonIS
ID: 40250421
this was the issue - it was a beyond FTP issue and not my server.  I'm not sure what was done to correct this but it was done on the FTP side where the file origionates.
0
 
LVL 26

Expert Comment

by:Leon Fester
ID: 40252601
Dear Admins,
Please review my answer and re-allocate the points accordingly.
Leon Fester 2014-03-13 at 15:54:48 ID: 39926354
which recommends that he checks the Beyond Compare settings.
0
 

Author Comment

by:WellingtonIS
ID: 40252868
I'm sorry this is correct Leon Fester did help me.  I think I must be hitting the wrong link when I accept solutions.  This is the 2nd time I've done this...
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
After seeing many questions for JRNL_WRAP_ERROR for replication failure, I thought it would be useful to write this article.
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

926 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question