Solved

Outlook 2013 connecting to Exchange 2013 server only via HTTPS not TCP/IP in internal LAN

Posted on 2014-03-12
17
2,577 Views
Last Modified: 2014-03-13
Hi experts,
I've completed a migration from Exchange 2007 to Exchange 2013. The new server run on a Windows 2008 R2 VM . The old one was dismissed. The server works fine but client connectivity on the internal LAN is very slow.
When I look at the Outlook connection status the connection status is HTTPS and not TCP/IP (as it should be).
This problem was not resolved by unchecking the option "on fast network, connect using HTTP first ...".
Obviously Outlook users and Exchange 2013 are on the same subnet and connected via gigabit lan.
Any ideas?
many thanks
0
Comment
Question by:johnabbruzzi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
  • 4
17 Comments
 
LVL 6

Expert Comment

by:chlebi
ID: 39924725
As far as I am aware Exchange does not offer MPI connections to Outlook anymore and only uses RPC over HTTP. See http://technet.microsoft.com/en-us/library/jj619283(v=exchg.150).aspx secion Client Access.
0
 
LVL 41

Expert Comment

by:Adam Brown
ID: 39924727
Exchange 2013 defaults to RPC over HTTPS (Outlook Anywhere) rather than full RPC. You are actually a bit better off using this method, since it doesn't require numerous ports like full RPC does (RPC utilizes about 20,000+ Virtual ports for communication, which makes it difficult to allow clients to traverse a firewall). I'll do some quick research to see how to turn that off at the server level, but I think it involves completely disabling Outlook Anywhere configuration in Autodiscover (which would be a pain for your remote users if you have them).
0
 
LVL 6

Expert Comment

by:chlebi
ID: 39924742
Above I meant Exchange 2013 does not offer MAPI anymore, sorry for typos... Outlook anywhere is also required.
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:johnabbruzzi
ID: 39924803
Yes i Well know that exchange do not use mapi and use rpc over http but in the connection status you have to see also connected via TCP/IP and not HTTPS.
Now i'm connected via mobile phone but tomorrow i'll attach (if is possible) a print screen
0
 
LVL 41

Assisted Solution

by:Adam Brown
Adam Brown earned 250 total points
ID: 39924851
Okay, it appears that TCP/IP RPC connections are no longer a supported method of connecting to Exchange 2013. It's probably still possible to set it up so you don't have to do RPC over HTTPS, but you would be out of scope for any MS support. You would ultimately have to completely disable Outlook Anywhere on your exchange server, which is not supported and not recommended in any case, since external Outlook clients wouldn't be able to connect without opening about 20,000 ports to the internet.
0
 

Author Comment

by:johnabbruzzi
ID: 39924990
Sorry acbrown2010 but i think your analisys is incorrect. Here you can read a post of a user that have issue similar and resolved. This means that connection via tcp/ip is possible and is right via LAN in exchange 2013 without disabling outlook anywhere. http://social.technet.microsoft.com/Forums/en-US/4de1de75-7e2d-42a0-a1e6-f29b581bcc4f/some-outlook-2010-clients-connecting-to-exchange-2010-sp3-ru1-cas-server-via-https-not-tcpip
0
 
LVL 41

Expert Comment

by:Adam Brown
ID: 39925004
They are using Exchange 2010, not 2013. It was possible in 2010, not supported in 2013.

In 2010, you could disable Outlook Anywhere internally by removing the Internal URL for it on each server. 2013 will not allow you to configure the Outlook Anywhere service with no internal URL.
0
 

Author Comment

by:johnabbruzzi
ID: 39925051
I can't believe it... So if it is as you wrote i've to to say to our internal users that it is normal to have response time double than with the previous exchange 2007... This is my esperience... Incredibile!!!
Could you please let me know how to disable outlook anywhere even if it is non supported? In other way i've to rollback and reinstall 2007 or 2010 instead
0
 
LVL 41

Expert Comment

by:Adam Brown
ID: 39925057
Response time should be equal with HTTPS. What you may be dealing with is the difference in function with Cached mode on vs. off. Earlier versions of Outlook didn't use cached mode by default. New ones do. In the user's account settings, remove the check mark by Cached mode and you should see much better performance.
0
 

Author Comment

by:johnabbruzzi
ID: 39925135
I've tried it but i note a great increased time for example in moving posts from a mailbox to another (f.e. in a public folder). What i do before in a few seconds with 2007 needs minutes with 2013.
0
 

Author Comment

by:johnabbruzzi
ID: 39925144
Please let me know how i can disable outlook anywhere...
0
 
LVL 6

Expert Comment

by:chlebi
ID: 39925583
One question: what exactly you feel is slower than before? As stated above, with Exchange 2013 you will always have HTTPS connections as this is the only method of connection for Outlook. Maybe you are just dealing with some performance problem somewhere.
0
 

Author Comment

by:johnabbruzzi
ID: 39925915
So it's normal this view in connection status even if i'm on LAN?
Outlook connection status
0
 
LVL 6

Expert Comment

by:chlebi
ID: 39925960
Yes, this is correct... But you are looking at the wrong column in fact. With Exchange 2013 all connections are made through HTTP/HTTPS. You should focus on column showing Protocol used. In your case this is RPC/HTTP and that is also correct in fact.
There might also be MAPI/HTTP possible somehow but it is not default (note that it is still HTTP connection). Which version of Outlook you are using?
Still I am not sure that if we manage to switch to MAPI/HTTP we solve your problem as it looks more like a performance or bottleneck issue. RPC/HTTP has typically same performance as MAPI/HTTP. It is just a different protocoll doing the same job at the end.
0
 
LVL 6

Expert Comment

by:chlebi
ID: 39925966
To make the reason clear: all Outlook connectivity is via HTTP/HTTPS even for internal clients due to architectural changes in Exchange 2013.
0
 

Author Comment

by:johnabbruzzi
ID: 39926379
Yes i understand that RPC/HTTP is correct with exch 2013 but the other column i thought it should have been TCP/IP and not HTTPS.
I was hoping that it ws the cause of my performance issues.
in particular moving elements from a mailbox to another is very very slow... consider that for about 50 elements (total 20Mb) i've to wait about 5 minutes!!! With the "old" exch 2007 this operation finished in a few seconds...
What I can check for?
0
 
LVL 6

Accepted Solution

by:
chlebi earned 250 total points
ID: 39926460
This is out of scope for this topic and can be almost anything. What we can say for sure is that based on the numbers you mention this is definitely not related to the protocol used as the perfomance difference should not be really noticeable.
I suggest to have a look at CPU usage on the CAS servers, network connection and storage performance.
Also I suggest to check whether you are not connecting somehow over any WAN link (i.e. from outside). As Exchange 2013 uses the same entry point (via Autodiscover) for both external and internal users it might be that you are connecting over your external connection by mistake and have lower line throughput (firewall monitoring of open connections might give you some hint).
If you don't see anything specific at first sight I would propose you open a new thread with different name for this to attract also other experts and we can go trhough that...
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question