Solved

Mailbox Restore: Recurring Calendar Meeting Update: You do not have permission to send the message on behalf of specified user

Posted on 2014-03-12
10
917 Views
Last Modified: 2014-05-05
We had one of our Exchange mailbox databases become corrupt and it was in a "dirty shutdown" state. We worked with Microsoft however it ended up that we had to restore the mailboxes on that database from backup from the night before.

After the restoration of the mailbox database, whenever users on this database try to send and update to a calendar invite they are receiving an error message that states "You do not have permission to send the message on behalf of specified user".

I have tried setting the "NT AUTHORITY\USER" permission for Full Access and Send As permissions to ensure that the user has full access on their mailbox and items.

Thanks for your assistance!
0
Comment
Question by:leeii15
  • 6
  • 3
10 Comments
 
LVL 40

Expert Comment

by:Adam Brown
ID: 39925071
NT AUTHORITY\SELF is the permission you would need to have on there. That said, make sure that the users have their reply address set to be the same as the address that those invites are being sent to.
0
 

Author Comment

by:leeii15
ID: 39926217
Thanks for the reply. In conjunction with this mailbox crash, we did change our email domain due to a name change (lets calls the new email "user@domain2.com"). We kept the old email address (user@domain1.com) attached to each recipient mailbox as an alias and set the "user@domain2.com" as the primary SMTP. So prior to opening this question, I thought that this could have been a cause so I did go into one of the mailboxes affected, and unchecked the "Automatically update email addresses based on email address policy" option and set the "user@domain1.com" as the Primary SMTP address which I believe makes this the Reply To address.

This morning, I did verify that the "user@domain1.com" was still set as the primary email address however, when I ran the test it still failed with the same error.

I did verify that one of the mailboxes in question still contained the "NT AUTHORITY\SELF" for both "Send-As" and "FullAccess" permissions.

The add these permissions, I ran the following in Powershell and then verified in Exchange Management Console

get-Mailbox -server {ServerName} -ResultSize Unlimited | Add-ADPermission -User 'NT AUTHORITY\SELF' -ExtendedRights 'Send-as'
get-Mailbox -server {ServerName} -ResultSize Unlimited | Add-MailboxPermission -User 'NT AUTHORITY\SELF' -AccessRights FullAccess

Open in new window

Also, I should have mentioned that this is Exchange 2007.

Thanks
0
 

Author Comment

by:leeii15
ID: 39926293
I just wanted to give an update. It appears that we have a problem with permissions sticking. I just went back into the same mailbox and checked the "Manage Send As Permission" option and now the "NT AUTHORITY\USER" is missing again.

It seems that when I add the permission within about 30 minutes it is removed.
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39927644
Try moving an affected user to a new database.

Simon
0
 

Author Comment

by:leeii15
ID: 39927773
I tried moving one of the mailboxes to a temporary mailbox DB and it has the same issue.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39928896
Does the problem occur with a NEW calendar entry?

Simon.
0
 

Author Comment

by:leeii15
ID: 39928945
No it doesn't. New appointments are not affected.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39933983
In that case I would have to put it down as a side effect of the recovery operation and the items needs to be recreated. It may well have been a corruption that existing at the point of the backup being taken which wasn't seen.

Simon.
0
 

Accepted Solution

by:
leeii15 earned 0 total points
ID: 40032597
It was an issue with the items and their permission level after restoring. Unfortuantly I did not find a fix for this and the items had to be deleted using MFCMAPI and then recreated by the user.
0
 

Author Closing Comment

by:leeii15
ID: 40041615
There was no solution provided except what we already knew.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Is your Office 365 signature not working the way you want it to? Are signature updates taking up too much of your time? Let's run through the most common problems that an IT administrator can encounter when dealing with Office 365 email signatures.
Large Outlook files lead to various unwanted errors and corruption issues. Furthermore, large outlook files can also make Outlook take longer to start-up, search, navigate, and shut-down. So, In this article, i will discuss a method to make your Out…
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question