Solved

cannot connect oracle database to developer

Posted on 2014-03-13
7
4,942 Views
Last Modified: 2014-03-16
Hello,

I installed oracle database 12c and installed oracle developer 6i
on windows 8 operating system.
When I try to connect developer to database the following error appeared

ora-28040: no matching authentication protocol

how to solve this error and connect developer to database?
0
Comment
Question by:abuabdallah
  • 4
  • 2
7 Comments
 
LVL 23

Accepted Solution

by:
David earned 500 total points
ID: 39927478
You may may an issue requiring the use of a thick JDBC driver, but a number of sources suggest adding this string to sqlnet.ora on both the client and server:

SQLNET.ALLOWED_LOGON_VERSION = 10
0
 
LVL 37

Expert Comment

by:Gerwin Jansen
ID: 39927593
But Oracle Developer 6i is very old, right? Considered upgrading?
0
 
LVL 23

Expert Comment

by:David
ID: 39929178
Author, any update to my comment please.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:abuabdallah
ID: 39930235
sorry for delay but i tried this option and i added this line

SQLNET.ALLOWED_LOGON_VERSION = 10

to sqlnet in server and client but same error appeared again

and i using developer 6 from long time i will upgrade as soon as possible.
0
 

Author Comment

by:abuabdallah
ID: 39930240
just  i want to know some body connect developer 6i to oracle database under windows 8 or it is not compatible with windows 8 and cannot connect it to oracle 12c under windows 8
0
 

Author Comment

by:abuabdallah
ID: 39932411
The problem solved

the parameter value must be 8
SQLNET.ALLOWED_LOGON_VERSION=8

on server only



Bug 14575666

In 12.1, the default value for the SQLNET.ALLOWED_LOGON_VERSION parameter has been updated to 11. This means that database clients using pre-11g JDBC thin drivers cannot authenticate to 12.1 database servers unless theSQLNET.ALLOWED_LOGON_VERSION parameter is set to the old default of 8.

This will cause a 10.2.0.5 Oracle RAC database creation using DBCA to fail with the ORA-28040: No matching authentication protocol error in 12.1 Oracle ASM and Oracle Grid Infrastructure environments.

Workaround:  Set SQLNET.ALLOWED_LOGON_VERSION=8 in the $crs_home/network/admin/sqlnet.ora file.
0
 

Author Closing Comment

by:abuabdallah
ID: 39932413
thank you for your help
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Note: this article covers simple compression. Oracle introduced in version 11g release 2 a new feature called Advanced Compression which is not covered here. General principle of Oracle compression Oracle compression is a way of reducing the d…
This post first appeared at Oracleinaction  (http://oracleinaction.com/undo-and-redo-in-oracle/)by Anju Garg (Myself). I  will demonstrate that undo for DML’s is stored both in undo tablespace and online redo logs. Then, we will analyze the reaso…
This video shows setup options and the basic steps and syntax for duplicating (cloning) a database from one instance to another. Examples are given for duplicating to the same machine and to different machines
This video shows how to Export data from an Oracle database using the Datapump Export Utility.  The corresponding Datapump Import utility is also discussed and demonstrated.

786 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question