Exchange 2010 Remote Connectivity Analyzer Error

Remote Connectivity Analyzer Error

I get this error when trying to do the web services test



Creating a temporary folder to perform synchronization tests. 
  Failed to create temporary folder for performing tests. 
  
 Additional Details 
  
Exception details:
Message: The request failed. The remote name could not be resolved: 'mail.nhmelab.com'
Type: Microsoft.Exchange.WebServices.Data.ServiceRequestException
Stack trace:
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.BuildEwsHttpWebRequest()
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ValidateAndEmitRequest(IEwsHttpWebRequest& request)
 at Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest`1.Execute()
 at Microsoft.Exchange.WebServices.Data.ExchangeService.BindToFolder[TFolder](FolderId folderId, PropertySet propertySet)
 at Microsoft.Exchange.Tools.ExRca.Tests.GetOrCreateSyncFolderTest.PerformTestReally()
Exception details:
Message: The remote name could not be resolved: 'mail.nhmelab.com'
Type: System.Net.WebException
Stack trace:
 at System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult, TransportContext& context)
 at System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult)
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.TraceAndEmitRequest(IEwsHttpWebRequest request, Boolean needSignature, Boolean needTrace)
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.BuildEwsHttpWebRequest() 
 

Open in new window


The problem is that my domain is NHMELAB.NET  It shows ".com"
ShiftAltNumlockAsked:
Who is Participating?
 
Simon Butler (Sembee)Connect With a Mentor ConsultantCommented:
You have to change it with the shell, it isn't a GUI option.
If you only have one Exchange server then this command will work.

Get-WebServicesVirtualDirectory | Set-WebServicesVirtualDirectory -InternalUrl https://mail.example.net/ews/exchange.asmx -ExternalUrl https://mail.example.net/ews/exchange.asmx

Although I would check that all of your URLs are valid.
http://semb.ee/hostnames

Simon.
0
 
Simon Butler (Sembee)ConsultantCommented:
You must have made an error when you configured the host names in Exchange - as that is returned by Autodiscover from your server. You need to check your internal and external URL configuration on all of the virtual directory.

As it is web services throwing the error, start with

get-webservicesvirtualdirectory | select identity, internalurl, externalurl

Simon.
0
 
ShiftAltNumlockAuthor Commented:
It showed this, but I cant find where to change it

Identity                                InternalUrl                             ExternalUrl
--------                                -----------                             -----------
EXCH-A\EWS (Default Web Site)           https://exch-a.nhmelab.net/EWS/Excha... https://mail.nhmelab.com/ews/exchang...

Open in new window

0
 
ShiftAltNumlockAuthor Commented:
Once again, you hit it right on the nose. Thanks again Simon.
0
All Courses

From novice to tech pro — start learning today.