Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Exchange 2010 public folder content not visible in Outlook 2010

Posted on 2014-03-14
4
Medium Priority
?
2,904 Views
Last Modified: 2014-04-15
Environment:
Exchange 2010 SP3, Exchange 2003 mailbox server in environment with no user mailboxes.
Outlook 2010
Public folders on Exchange 2010 servers only

Scenario:
4 users use a set of public folders to maintain conference room scheduling. All 4 have identical permissions on all conference room calendars, they are all "editors". 2 users are new, 2 have been here for years.

The 2 experienced users can see all items in the calendars, almost immediately after they are made. This is only true for items created by people other than the 2 new hires.

The 2 new hires can only see their own items. They cannot see others appointments, and other people cannot see their entries.

Using OWA, the new hires can see appointments made by all other (non-new) users. However, nobody can see the appointments the 2 new users make.

I've tried:
1. Adjusting the new user rights, no effect. I elevated their rights, and also set them back to "editor".
2. Took user off cached mode. No effect.
3. Made a meeting on the calendar using my credentials. I am an "owner" of the public folder. Existing users can see it, 2 new users cannot.

Any suggestions? I cannot convert it to a room mailbox currently.

Dan
0
Comment
Question by:drothbart
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 35

Expert Comment

by:Joseph Daly
ID: 39929574
This is just kind of a long shot but if you look at the DBs that these users are in are they in the same DB? If they are not could they be moved into the same DB?

Also once you find whichever DBs these users are in in the EMC under Organization/Mailbox check the default public folder database under the properties.

In situations like this where I have people working on the same public folder I try to have them all in the same DB or at least in DBs that share the same public folder database.
0
 
LVL 5

Author Comment

by:drothbart
ID: 39929729
Thanks Joe for the suggestions.

1. Two users are on the same DB, but cannot see each others entries. It is one new user and a long-time user.

2. All DB's (I have 10) point to the same PF database instance, on one of my 2 2010 mailbox servers.
0
 
LVL 5

Accepted Solution

by:
drothbart earned 0 total points
ID: 39992219
I ended up doing these steps:

1. Rename existing folder to Archive_<Foldername>
2. Created new folder called same name as old one.
3. Exported contents of old one to PST
4. Imported into new folder
5. Set proper permissions

When done, the user who could not see all items then could see newly created items. However, all of the entries that she had made in the old folder did not carry over to the new folder and had to be recreated. In hindsight, I would try creating the PST from her client that showed the appointments she created.

Dan
0
 
LVL 5

Author Closing Comment

by:drothbart
ID: 40001109
Other suggestions did not help with this situation, although they were appreciated.
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The main intent of this article is to make you aware of ‘Exchange fail to mount’ error, its effects, causes, and solution.
This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
This video discusses moving either the default database or any database to a new volume.
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question