Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 358
  • Last Modified:

Netgear Firewall and RDP

I have netgear firewall and I want to do two things.

1. Be able to allow RDP to all pcs, and I read below link and it tells me each pc must have static IP. Is it truth?

http://www.buildeasypc.com/category/software/port-forwarding-for-windows-remote-desktop-on-netgear-dg834ggtn-router.htm


2. Set up static IP to each PC

I did check the firewall and have the following information.

IP: 72.54.249.50
IP Subnet Mask: 255.255.255.252

Primary DNS: 66.180.85.111
Secondary DNS: 64.239.55.222

In the each pc that I am going to set up the IP. What should i fill in below:

IP Address:
Subnet Mask:
Default gateway:

Preferred DNS
Alternative DNS

Thanks
0
CoolDev2014
Asked:
CoolDev2014
  • 4
  • 3
  • 3
  • +1
1 Solution
 
pgm554Commented:
If you are trying to RDP from outside of you LAN (internet) ,you will need a static IP from your ISP or a dynamic dns account as most ISP's will give you a dynamic IP address that can change after a while of use.
0
 
JohnBusiness Consultant (Owner)Commented:
I agree with the above in principle.

I have a Cisco RV042G VPN router in my home office. The ISP gives me a dynamic IP that changes but rarely. I set up tunnels to clients who have static IP addresses (businesses) and the tunnels stay up for a year or more before having to change the my home office IP in the client setups.

You can also use DYNDNS and that will do what you want on the dynamic end.

At least one end in your arrangement above must have a static IP address for workable results.

http://dyn.com/dns/
0
 
CoolDev2014Author Commented:
actually, I am trying to RDP INSIDE of the LAN.
0
Prepare for an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program curriculum features two internationally recognized certifications from the EC-Council at no additional time or cost.

 
JohnBusiness Consultant (Owner)Commented:
See if your LAN firewall is in the way. Also make sure the target machine allows RDP connections (Computer, right click, Properties, Advanced System Properties, Remote Tab and make sure you have allowed Remote Desktop Connections to this computer.

You might try connecting to the IP address of the target computer (in case there is a firewall restrictions).

The two things (connect by IP; and enabling RDP connections) should work.
0
 
CoolDev2014Author Commented:
I try to RDP PC name, and static IP. Both ways are not working.
I already enable ALLOW remote in the target pc. The target pc is window 7 Starter.
0
 
KimputerCommented:
Check internal lan config, probably something like
IP:192.168.1.x (check netgear lan config)
Subnet:255.255.255.0
Gateway: netgear internal lan ip
Dns: netgear internal lan ip

All pc's must have a unique ip. Better make sure it's not in the dhcp range.

Now add rules in the netgear:
Firewall allow traffic to these ip's
Nat/virtual servers:
Assign every pc's ip to a different public port:
For example pc1 ip is 192.168.1.100 assign outside port 5001 to internal port 3389
Pc 2 ip outside port 5002 to inside 3389
Etc.

When you're outside, use:
72.54.249.50:5001
 to connect to the pc 1
72.54.249.50:5002
for pc 2 etc.
0
 
CoolDev2014Author Commented:
1. IP:192.168.1.x (check netgear lan config) ? where you want me to check?
0
 
KimputerCommented:
To know that, I have to know the exact model/type of your netgear device.
0
 
CoolDev2014Author Commented:
NETGEAR ProSafe™ Gigabit 8 Port VPN Firewall FVS318G
0
 
JohnBusiness Consultant (Owner)Commented:
Also make sure you are using Windows Pro and not Home.

All computers should be on the same subnet. None should be connected to DMZ.

Can you easily PING any computer from any other computer?
0
 
KimputerCommented:
Follow this guide: http://www.downloads.netgear.com/files/products/FVS318G/Documentation/RM/FVS318G_RM_27Aug10.pdf

Page 3-3. Here you can see your DHCP settings. Set the PC's you want to control to IP's outside this range. If you have a default setup, you can start with PC as IP 192.168.1.101, and PC2 as 192.168.1.102

Now go to page 4-24 to add a few customised services, like the previous example, 5001 for RDP1, 5002 for RDP2 etc.
Now page 4-5, add inbound rules for PC1 with IP 192.168.1.101, with the rule RDP1 (incoming port 5001), and make sure you use the Translate to Port number option and fill in 3389.
Add inbound rules for PC2 with IP 192.168.1.102, with the rule RDP2 (incoming port 5002), and make sure you use the Translate to Port number option and fill in 3389.
Continue for all other PC's.
You will now be able to connect to them all from outside with
public_ip_nr:5001 through 50xx (xx is how many PC's you've set up)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get Cisco Certified in IT Security

There’s a high demand for IT security experts and network administrators who can safeguard the data that individuals, corporations, and governments rely on every day. Pursue your B.S. in Network Operations and Security and gain the credentials you need for this high-growth field.

  • 4
  • 3
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now