Solved

Windows Update Error 80072EFD

Posted on 2014-03-14
26
3,510 Views
Last Modified: 2014-03-15
This system is in a 2003 SBS domain, WSUS is not deployed. Unable to update manually or automatically. I have already run malwarebytes which found no problems. I verified that BITS and windows update  and cryptographic services were all running and set to automatic. I tried the system update readiness tool and I tried to do a clean boot. I have attached the update log and minitooblox report. In windows update settings there is a message that "some settings are managed by your system administrator" but to my knowledge no GPOs have been configured.
WindowsUpdate.log
minitoolbox.txt
0
Comment
Question by:rettif9
  • 15
  • 11
26 Comments
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39931124
Hi,

1. Make sure that your are able to access the internet. if you are using proxy then see the http://support.microsoft.com/kb/836941


2.  if still not updating then remove the file C:\windows\winsxs\pending.xml

3. if still not updating then run below command in elevated command prompt.

 @echo on

 net stop wuauserv /y
 net stop bits /y

 rmdir c:\windows\SoftwareDistribution /S /Q
 del C:\Windows\WindowsUpdate.log /S /Q

 REG DELETE "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v AccountDomainSid /f
 REG DELETE "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v PingID /f
 Reg Delete "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v SusClientId /f

 Reg Delete "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v SusClientValidation /f

 REG DELETE "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v LastWaitTimeout /f
 REG DELETE "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v DetectionstartTime /f
 Reg Delete "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v NextDetectionTime /f


 echo re-resistering Windows Update cpmponents..

 regsvr32.exe c:\windows\system32\wuapi.dll /s
 regsvr32.exe c:\windows\system32\wups.dll /s
 regsvr32.exe c:\windows\system32\wuaueng.dll /s
 regsvr32.exe c:\windows\system32\wucltui.dll /s
 regsvr32.exe c:\windows\system32\msxml3.dll /s
 regsvr32.exe c:\windows\system32\wuaueng1.dll /s
 regsvr32.exe c:\windows\system32\wups2.dll /s
 regsvr32.exe c:\windows\system32\wuweb.dll /s


 net start wuauserv /y
 net start bits /y

 echo Initiating Windows Updates detection cycle... 

 wuauclt.exe /resetauthorization 
 wuauclt.exe /detectnow 
 wuauclt.exe /reportnow

 @echo off

Open in new window

0
 
LVL 7

Author Comment

by:rettif9
ID: 39931343
@ Santosh Kr. Gupta;

Thanks for your response. The system has access to the Internet and can open other web pages normally. I'm also working remotely.

I looked for C:\windows\winsxs\pending.xml the file doesn't exist in this folder

This is a Win 7 Pro 32 bit system.

I opened an elevated command prompt and pasted the commands above. The resultant output is attached. as "results.txt"

After running commands Update still fails with 80072EFD error
I rebooted and tried again but it still failed.
results.txt
0
 
LVL 7

Author Comment

by:rettif9
ID: 39931356
I had noticed previously that the BITS service wasn't running. I had changed it to automatic and restarted it. I noticed in the output that it was stopped again. This isn't something I did but I don't know what stopped it.
0
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39931357
Hi,

as per logs, wuauserv is not running. pls check.

if still not working, although you are able to access the internet, pls try number 1 point.
0
 
LVL 7

Author Comment

by:rettif9
ID: 39931384
The automatic diagnostic tool in the link above found no errors

in services.msc BITS, Cryptographic services, and Windows update all appeared to be running although BITS was set to manual and Windows update was set to delayed start. I reset both to automatic again.

at elevated command prompt C:\net start wuauserv
The requested service has already been started


Update still fails.
please advise
0
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39931419
1. go RUN and type gpedit.msc, explore (Configuration\Administrative Templates\Windows Components\Windows Update\ ) and open & check "Specify intranet Microsoft Update service location" value. if it is configured and pointing to your SBS that mean it trying to update from SBS. if you are good to disable it. then it will take the update from Microsoft.


2. check the internet explorer "options" -->connections --> LAN setting and change it to automatic. (if not).
0
 
LVL 7

Author Comment

by:rettif9
ID: 39931451
I had already checked this but I checked again. In computer config and in user config all of the GPOs in this folder are listed as not configured.

LAN setting was already set to automatic

checked host and lmhost nothing in either one except 127.0.0.1
0
 
LVL 7

Author Comment

by:rettif9
ID: 39931455
I opened the referenced GPO to verify that it had no values entered for server names. It did not.
0
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39931457
1. Open an Elevated Command Prompt ( Click the Start orb, type in cmd , under Programs right   click cmd.exe and choose
 'Run as administrator', follow the UAC prompts to allow the Command Prompt to run Elevated )
 2. Now type in the following and press Enter

 netsh winhttp show proxy

 3. The above will display the current proxy settings of Windows Update. If the following shows, there is no proxy issue occurring
Current WinHttp Proxy settings: Direct access <no proxy settings>
 4. If a proxy or proxies are showing, reset Windows Update to Direct access by typing in the following and then press Enter

 netsh winhttp reset proxy

 5. Close the Command Prompt window by typing exit , press Enter
 6. See if the system can update now


if still there is issue, then run client diagnostic tool. http://download.microsoft.com/download/9/7/6/976d1084-d2fd-45a1-8c27-a467c768d8ef/WSUS%20Client%20Diagnostic%20Tool.EXE
0
 
LVL 7

Author Comment

by:rettif9
ID: 39931461
C:\Users\administrator>net start wuauserv
The requested service has already been started.

More help is available by typing NET HELPMSG 2182.


C:\Users\administrator>netsh winhttp show proxy

Current WinHTTP proxy settings:

    Direct access (no proxy server).


C:\Users\administrator>

Update failed with same error
0
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39931470
now try to reset Windows Update components.

http://support.microsoft.com/kb/971058
0
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39931472
beetween pls share windowsupdate.log
0
 
LVL 7

Author Comment

by:rettif9
ID: 39931498
Thank You for running an automated troubleshooter from Microsoft.
We did not detect any problems and therefore no fixes were applied.

There is a view report details link @ lower left on this message which I opened.

here is says; Windows Update encountered an error searching for updates online. A diagnostic file is attached It's *.etl I renamed it to *.txt for upload
CA669F5C-E003-4A69-99BF-D6384F5A.txt
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 7

Author Comment

by:rettif9
ID: 39931502
New update log attached
WindowsUpdate2.txt
0
 
LVL 13

Accepted Solution

by:
Santosh Gupta earned 500 total points
ID: 39931520
Gotcha....

your win 7 is still trying to connect to "SERVER01:8530" server for update. seems its due to your Group Policy,

move your windows 7 to othrer OS where windows update GPO is not applied.

you can check it by running RSOP.MSC. if still its applying.

pls configure the below policy incase.

go RUN and type gpedit.msc, explore (Configuration\Administrative Templates\Windows Components\Windows Update\ ) and open & check "Specify intranet Microsoft Update service location" value and disable it.

close it

run gpupdate /force and try to update.
0
 
LVL 7

Author Comment

by:rettif9
ID: 39931540
C:\Users\administrator>gpupdate /force
Updating Policy...

User policy could not be updated successfully. The following errors were encount
ered:

The processing of Group Policy failed. Windows could not determine if the user a
nd computer accounts are in the same forest. Ensure the user domain name matches
 the name of a trusted domain that resides in the same forest as the computer ac
count.
Computer Policy update has completed successfully.

To diagnose the failure, review the event log or run GPRESULT /H GPReport.html f
rom the command line to access information about Group Policy results.

C:\Users\administrator>gpresult /H GPResult.html
INFO: The user does not have RSOP data.

C:\Users\administrator>hostname
Tony01

C:\Users\administrator>nslookup Tony01
Server:  server01.scs.local
Address:  192.168.1.9

Name:    Tony01.scs.local
Address:  192.168.1.100


C:\Users\administrator>

update failed again the workstation is joined to the local domain
0
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39931555
Did you changed the local group policy.  "Specify intranet Microsoft Update service location" value and disabled it ??


1. make sure NetLogon service is running. to run gpupdate /force
2. Disjoin and join the computer to the domain.
0
 
LVL 7

Author Comment

by:rettif9
ID: 39931556
Just to verify;

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\administrator>ECHO %userdomain%
SCS

C:\Users\administrator>
0
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39931557
login with local administrator account.
0
 
LVL 7

Author Comment

by:rettif9
ID: 39931562
yes I disabled the GPO
netlogon was off

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\administrator>ECHO %userdomain%
SCS

C:\Users\administrator>gpupdate /force
Updating Policy...

User Policy update has completed successfully.
Computer Policy update has completed successfully.


C:\Users\administrator>

update failed again

:( I thought you had it...
0
 
LVL 7

Author Comment

by:rettif9
ID: 39931573
Still want me to logon as local admin?
0
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39931576
1 reboot the system, try to update if not then
2. run RSOP.MSC and check if still GPO is applied ?
0
 
LVL 7

Author Comment

by:rettif9
ID: 39931578
already ran rsop.msc while waiting GPO is still applied. rebooting workstation now will look for GPO on server.
0
 
LVL 7

Author Closing Comment

by:rettif9
ID: 39931623
found a GPO for client updates on the server that was enabled but not configured. I disabled it, gpupdate /force on server. then log on to client gpupdate /force, rsop.msc  "Specify intranet Microsoft Update service location" was fixed. Ran MS update and it is working. Thank you for being persistent, and teaching me a few things.
0
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39931657
Hi, glad to hear that your issue has been fixed. it could be fixed earlier, but you said "you had disabled the policy".

Anyways... your welcome.
0
 
LVL 7

Author Comment

by:rettif9
ID: 39931688
I disabled the policy on the workstation when I made that comment. The GPO I found was on the server in users and computers << group policy.
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

Suggested Solutions

By now, it is common knowledge that Windows 7 has been successfully been able to live up to the hype of being touted as Microsoft’s most anticipated O.S. ever. This latest 2010 Windows release builds up on its predecessor’s positives, adding new…
So many times I have seen the words written in a question "if only I could show you" or " I know how hard it is for you since you can't see it" in any zone. That has inspired me to write about this tool in windows 7 called "Problem Steps Recorder…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now