Exchange 2013 SP1

I just installed Exchange 2013 SP1 and now the transport service is not starting.

Pls help
zubby1977Asked:
Who is Participating?
 
Simon Butler (Sembee)ConsultantCommented:
Do you have any third party software on the machine?
If so, be aware that there is a bug in the transport service.

http://support.microsoft.com/kb/2938053

Simon.
0
 
s3e3Commented:
Post some event log errors
0
 
zubby1977Author Commented:
Log Name:      Application
Source:        MSExchange Common
Date:          3/15/2014 10:49:40 AM
Event ID:      106
Task Category: General
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Servername.local
Description:
Performance counter updating error. Counter name is Number of items in Malware Fingerprint cache, category name is MSExchange Anti-Malware Datacenter Perfcounters. Optional code: 3. Exception: The exception thrown is : System.InvalidOperationException: The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly.
   at System.Diagnostics.PerformanceCounter.InitializeImpl()
   at System.Diagnostics.PerformanceCounter.set_RawValue(Int64 value)
   at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.set_RawValue(Int64 value)
Last worker process info : System.ArgumentException: Process with an Id of 17696 is not running.
   at System.Diagnostics.Process.GetProcessById(Int32 processId)
   at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.GetLastWorkerProcessInfo()
Processes running while Performance counter failed to update:

Performance Counters Layout information: FileMappingNotFoundException for category MSExchange Anti-Malware Datacenter Perfcounters : Microsoft.Exchange.Diagnostics.FileMappingNotFoundException: Cound not open File mapping for name Global\netfxcustomperfcounters.1.0msexchange anti-malware datacenter perfcounters. Error Details: 2
   at Microsoft.Exchange.Diagnostics.FileMapping.OpenFileMapping(String name, Boolean writable)
   at Microsoft.Exchange.Diagnostics.PerformanceCounterMemoryMappedFile.Initialize(String fileMappingName, Boolean writable)
   at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.GetAllInstancesLayout(String categoryName)


Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="MSExchange Common" />
    <EventID Qualifiers="49156">106</EventID>
    <Level>2</Level>
    <Task>1</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-03-15T14:49:40.000000000Z" />
    <EventRecordID>102217</EventRecordID>
    <Channel>Application</Channel>
    <Computer>********.servername.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>3</Data>
    <Data>Number of items in Malware Fingerprint cache</Data>
    <Data>MSExchange Anti-Malware Datacenter Perfcounters</Data>
    <Data>The exception thrown is : System.InvalidOperationException: The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly.
   at System.Diagnostics.PerformanceCounter.InitializeImpl()
   at System.Diagnostics.PerformanceCounter.set_RawValue(Int64 value)
   at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.set_RawValue(Int64 value)
Last worker process info : System.ArgumentException: Process with an Id of 17696 is not running.
   at System.Diagnostics.Process.GetProcessById(Int32 processId)
   at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.GetLastWorkerProcessInfo()
Processes running while Performance counter failed to update:



and


Log Name:      Application
Source:        MSExchangeFrontEndTransport
Date:          3/15/2014 8:07:37 AM
Event ID:      1036
Task Category: SmtpReceive
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Servername
Description:
Inbound direct trust authentication failed for certificate %1. The source IP address of the server that tried to authenticate to Microsoft Exchange is [%2]. Make sure EdgeSync is running properly.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Schuyler DorseyCommented:
0
 
zubby1977Author Commented:
I found a fix.  It's a know issue with installing SP1.
See fix below

http://exchangemaster.wordpress.com/2014/02/28/exchange-2013-sp1-breaks-hub-transport-service/
0
 
Simon Butler (Sembee)ConsultantCommented:
That is the interim fix that was found when the problem first emerged. The supported fix is the link I have provided. It will also be resolved in the next cumulative update.

Simon.
0
 
zubby1977Author Commented:
Thanks Simon
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.