Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

W2012 R2 IIS cannot access website

Posted on 2014-03-15
14
Medium Priority
?
956 Views
Last Modified: 2014-03-20
I just migrated my first website to IIS 8 on a W 2012 R2 server.
When I attempt to access the website I get this message:

HTTP Error 404.3 - Not Found

The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

Is there a component I am missing that needs to be installed back in Server Manager? What settings can I check in IIS 8? This is not working while I try to access the website directly on the W2012 server.
0
Comment
Question by:rwheeler23
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 7
14 Comments
 
LVL 12

Expert Comment

by:Imtiaz Hasham
ID: 39932481
What extension is the website on, index.htm?
0
 
LVL 12

Expert Comment

by:Imtiaz Hasham
ID: 39932482
And check ASP Registration using aspnet_regiis.exe -i on the command line
0
 

Author Comment

by:rwheeler23
ID: 39932528
Well there was a clue. Running aspnet_regiis.exe did not work as it did not recognize that command. I am installing ASP 4.5 right now. I assume you do not need to also install ASP? I also looked in the web site folder and there is no index.* file of any kind.
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 

Author Comment

by:rwheeler23
ID: 39932535
After installing ASP 4.5 the error message is now:

HTTP Error 404.17 - Not Found

The requested content appears to be script and will not be served by the static file handler.
0
 
LVL 12

Expert Comment

by:Imtiaz Hasham
ID: 39932604
Can you tell me what's the first page?  if it's index.htm or index.php, try browsing the site with the subfolder.
0
 

Author Comment

by:rwheeler23
ID: 39932657
I beleive there is something not correct about their installation program. Here is a screenshot of the subfolder and there is no index file.
Xpede.png
0
 
LVL 12

Expert Comment

by:Imtiaz Hasham
ID: 39933287
On IIS, go to the website, double click default document and add login.aspx.

See if that helps.
0
 
LVL 12

Accepted Solution

by:
Imtiaz Hasham earned 2000 total points
ID: 39933289
Usually, web developers call their software index.htm, index.html, index.aspx or index.php (Depending on the type of application).

In your case, IIS cannot see any of the default documents to load because the aspx page is called login.aspx. (Without the full stop).

Adding this should fix it as advised above.

If it doesn't let me know and i will be glad to look into it further.
0
 

Author Comment

by:rwheeler23
ID: 39934027
if I attempt to browse to this website on the IIS server I get "HTTP Error 404.17 - Not Found
The requested content appears to be script and will not be served by the static file handler." If I attempt to browse to it from any other machine I get "404 - File or directory not found."

The call to this site is http://myserver:8080/mysite.net

I have something else on port 80 so I had to move it to 8080.
0
 

Author Comment

by:rwheeler23
ID: 39934038
By the way, that was after adding Login.aspx to the Default Documents.
I appreciate your help. Thanks.
0
 
LVL 12

Expert Comment

by:Imtiaz Hasham
ID: 39934152
You can run multiple Websites on port 80 as long as they have separate bindings.

Under Bindings, ensure each website has different bindings to resolve this matter.
0
 

Author Comment

by:rwheeler23
ID: 39934252
I have turned off the other application service that uses port 80. It is not a website, just  service. Even doing that and then binding this website back to port 80 I still get the same message when I attempt to hit the site.
0
 
LVL 12

Expert Comment

by:Imtiaz Hasham
ID: 39941962
And the bindings are correct?
0
 

Author Closing Comment

by:rwheeler23
ID: 39942154
I had to install ASP.NET in addition to ASP.NET 4.5
Thanks for the help.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
Windows Server 2003 introduced persistent Volume Shadow Copies and made 2003 a must-do upgrade.  Since then, it's been a must-implement feature for all servers doing any kind of file sharing.
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question