• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7785
  • Last Modified:

screen saver doesn't start in Windows 8.1

I recently reinstalled Windows 8.1 Pro on my computer and now the screen saver does not kick in after 1 minute (as per the setting). I tried a different screen saver with the same result.
The preview of all the screen savers works properly.

What could be running in the background that is preventing this from turning on?
0
Lev Seltzer
Asked:
Lev Seltzer
  • 14
  • 12
  • 5
  • +1
19 Solutions
 
McKnifeCommented:
First, let it run for let's say 10 minutes and see whether it comes at all.
0
 
Santosh GuptaCommented:
Hi,

pls check below.

Please goto RUN and Type REGEDIT and explore HKEY_CURRENT_USER\Control Panel\Desktop and see if registry value are reflecting properly.

http://www.windows-commandline.com/disable-screensaver-registry-settings/
http://www.wikihow.com/Disable-Windows-Login-Screensaver
0
 
John HurstBusiness Consultant (Owner)Commented:
Laptop or Desktop? Was it working correctly prior to reinstalling Windows 8.

If laptop, it may be set just to turn the screen off. My laptop does that.

Also check your power management for the screen (which is separate from Screen Saver). Make sure the power management for the screen reflects what you want. It may be conflicting with screen saver.
0
Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

 
John HurstBusiness Consultant (Owner)Commented:
@WEBuilder - Another thing to consider is that screen savers are not necessary or even recommended for LCD/LED screens. So you might try turning Screen Saver off and using Screen power management (which is part of Windows power management). I do that for my laptop and for my desktop. Works great.
0
 
Lev SeltzerAuthor Commented:
Thank you for your responses.
I am working on a desktop.
I want the screen saver for two reasons:
1. To lock the screen so no one will use the computer if I leave
2. To display a slide show of pictures, which I like seeing.
I do not mind if it uses the LCD or electricity.
Power management is set to "balanced". Screen will turn off after 10 minutes. and computer will sleep after 30 minutes. This NEVER has happened - even in previous versions of Windows.
Current problem started when I REINSTALLED 8.1 from scratch (Windows had stopped functioning and I had to do a complete reinstalled. Before this, I was running 8.1 and the screen saver worked).

I am not sure what to see in the regedit. The current entries look fine. ScreenSaveTimeOut was 60 - I set it to 3 and it did not go into screen saver mode after 3 seconds.

I have left on the computer for several hours, and it does not go into screen saver.  

Thank you.
0
 
John HurstBusiness Consultant (Owner)Commented:
Try setting the LCD screen shut off for a longer time than screen saver. So here, set the power interval to 60 minutes and see then if screen saver will kick in.
0
 
Lev SeltzerAuthor Commented:
I set the screen saver to NO SCREENSAVER and turned the power settings to shut off the monitor after 1 minute.
I waited.
Nothing.
We are not having earthquakes, so the mouse is not moving when I am not touching it. I am not sure what is happening to cause this situation.

Thank you .
0
 
John HurstBusiness Consultant (Owner)Commented:
Power management is unit into Windows 8.1, so try running System File Checker to see if it corrects power management. Run SFC /SCANNOW and allow to complete. Restart the computer after this.

If you have Vendor power management installed, uninstall it and restart again.

Now test again.

This was a recent reinstall of Windows 8.1. Make sure you have installed all the latest drivers for your computer. In particular, upgrade Chipset and Video as both of those could affect the screen. Make sure all Windows updates have been done including recommended updates. After all this, see if there is a vendor power management application to install. This is different than the system power manager which you should install or upgrade for sure.
0
 
McKnifeCommented:
The screen saver uses an "idle timer" - if some components that are running in the background won't let it idle, that could also be the reason. So you should try in safe mode as well. To reach safe mode, simply press Shift while clicking on restart and the option will appear on reboot ->troubleshooting.
0
 
John HurstBusiness Consultant (Owner)Commented:
I normally have over a 100 processes running on my laptop and screen off always kicks in. Let us know if you have any special processes running.

Also please report back on chipset, video, and system power management drivers.
0
 
Lev SeltzerAuthor Commented:
I am not sure how to respond with your request for information. Below is an image from the computer's properties.
 SystemI am sure there are many services and processes running, but am not sure how to give you a list form task manager (which reports 14 apps, 42 background apps and 22 windows apps).

I did not try SAFEMODE yet. I am still trying to get some work done, and can't reboot right now.
0
 
John HurstBusiness Consultant (Owner)Commented:
The screenshot has nothing to do with screen saver or drivers.

Find out what drivers are being used via Device Manager (Computer, right click, Manage, Device Manager).

Then go to the vendor (manufacturer's) support site for driver upgrades.
0
 
Lev SeltzerAuthor Commented:
I have an Intel(R) HD Graphics display driver dated  1/22/2014. I clicked on UPDATE DRIVER and no newer driver was found.
0
 
John HurstBusiness Consultant (Owner)Commented:
So then look for Chipset (did you even install that on Windows 8.1 Reinstall?) and for System Power Management (Try Windows Update for that).

Ultimately, something may have gone wrong in reinstalling Windows, so it may be necessary to try reinstalling again.
0
 
Lev SeltzerAuthor Commented:
There is no apparent option for "chipset" under "Device Manager." I did not "install" it when I did the windows 8.1 reinstall; instead the 8.1 install was automatic, and whatever the installation program decided to install was installed.

System Power Management is not in device manager either. I ran WIndows Update, and while there are 2 minor windows updates available, they do not relate to this (I am installing the updates in any case).
0
 
John HurstBusiness Consultant (Owner)Commented:
Windows Power Manager is under Device Manager down under System Devices. It is on my machines.

Chipset is a driver that should show up on the Manufacturer's update support site for your model. Again that is how I do it.

My concern for you here is that important drivers that you may need are either not installed or old.

If you cannot find anything, you may have to consider trying again with a fresh install.
0
 
Lev SeltzerAuthor Commented:
I looked for "windows power manager" in "Device manager" under the "system devices" tab, and did not find it.
I am running Windows Update, and it is not finding any new programs or drivers at this time.
I reinstalled windows 8.1 from scratch within the past month, and do not want to do it again, as I do not believe it will solve the problem (also, considering how it took many hours to complete the installation, I do not want to waste the time when it is only a possibility that it will help).

Any other ideas?
0
 
John HurstBusiness Consultant (Owner)Commented:
If the power management driver is not in Device Manager, it may not be needed. I have the Lenovo PM device on my ThinkPad but I do not have such a device on my Lenovo Desktop.

So then short of finding Chipset at the manufacturer's site, I do not know what else to suggest. Your most recent installation of Windows has failed somewhere and it is probably a driver that is missing.
0
 
Lev SeltzerAuthor Commented:
I have made a search of this problem, and it seems that there are a good number of other people with the same problem. On the threads I found, sometimes there is a solution - but one that does not work for everyone - and sometimes there is no solution offered.
0
 
John HurstBusiness Consultant (Owner)Commented:
You may just have to live without screen saver on this system.  While Windows 8 is not widespread yet, I do have a few Windows 8 machines at clients and one of my own. Screen saver and/or screen turn off works properly.

So I do not think it is a Windows 8 issue, but much more likely a driver issue. On a desktop: video and chipset; and on a laptop: video, chipset and PM driver.

You might also see if there is a BIOS upgrade for your computer. We have not mentioned that previously in this thread.
0
 
McKnifeCommented:
I would try one morer thing: invoke the screen saver using task scheduler.
Create a new task and trigger it to run on idle. Action:
rundll32.exe user32.dll, LockWorkStation

If that task works, you can setup your lock screen to show a slideshow.

The on idle trigger works as follows: http://technet.microsoft.com/en-us/library/cc721902.aspx
If a screen saver is not running, then the computer is considered to be in an idle state if there is 0% CPU usage and 0% disk input or output for 90% of the past fifteen minutes and if there is no keyboard or mouse input during this period of time. Once the Task Scheduler service detects that the computer is in an idle state, the service only waits for user input to mark the end of the idle state.
0
 
Lev SeltzerAuthor Commented:
McKnife: I created the task as directed, but it did not start - not even after more than 15 minutes of inactivity.
0
 
John HurstBusiness Consultant (Owner)Commented:
You still need to comment on whether you found and upgraded Chipset and BIOS.
0
 
McKnifeCommented:
You haven't forgotten about my earlier request to try safe mode, have you?
0
 
Lev SeltzerAuthor Commented:
I didn't try safe mode. I did find an update for the screen and network drivers from Intel and installed those. No change in performance.
The task scheduler IDLE trigger still does not work.
0
 
McKnifeCommented:
Yes, using task scheduler we made out that definitely the idle state is incorrectly determined or never reached (quite sure it's being incorrectly determined).
Please try safe mode as described.
0
 
Lev SeltzerAuthor Commented:
I went to safe mode (with network) and waited 3 minutes (the screen saver was set to 1 minute).
Nothing happened.
0
 
John HurstBusiness Consultant (Owner)Commented:
Have you tried Chipset and BIOS updates. You reimaged the machine, so it is very likely the root issue here is a driver problem.
0
 
Lev SeltzerAuthor Commented:
I have an intel board. The intel website has a program that checks my computer and recommends drivers. I downloaded and installed the driver for the network and the one for the video. I haven't a clue where to go for "chipset" and "Bios" updates.
0
 
John HurstBusiness Consultant (Owner)Commented:
Go to the website for the board and search for Chipset and search for BIOS. If the CPU is Intel, BIOS should be available. If the CPU is not Intel you would have to go to that vendor.

You do need all the drivers I speak of (Video, Power, Chipset and BIOS) to make sure screen saver works.
0
 
Lev SeltzerAuthor Commented:
I think I am going to just resign myself to the fact that this is not going to work, and perhaps when Microsoft comes out with the next update to Windows it will work. Thank you for all your help.
0
 
John HurstBusiness Consultant (Owner)Commented:
@WEBuilder - Thank you for the update. Windows 8.1 Update 1 will be out next week and that may help you.
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 14
  • 12
  • 5
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now