• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1067
  • Last Modified:

Sonicwall 2040 firmware download

Hi I have a sonicwall pro 2040 and have had to set it to factory defaults. I made a backup of setings prior to doing this and when trying to upload the setting it just says no changes have been made.  I am assumming it is due to the fact that I may need to upgrade the firmware to the version it was on previously to upload the settings back in?

I have tried to register the device in mysonicwall but it says "To register this UPGRADE unit, you do not have a TRADE-IN unit registered"  when trying to register it so am unable to download the firmware from the site to try this.

If anyone knows how I can upload my settings again to the device that would great or has a download of the firmware for the device I would be grateful for your help.

Thanks
0
DATA99
Asked:
DATA99
  • 4
  • 4
  • 2
1 Solution
 
MiftaulCommented:
I assume, you previously registered your device.

Logon to the mysonicwall.com website with your account and download the firmware. Then on the sonicwall, go to system- settings and upload the firmware. After the firmware is updated, boot the device with the updated firmware. Once rebooted, go to settings again and import the previously saved setting.

This time it should work.
0
 
DATA99Author Commented:
No that's the issue it doesn't seem like the device was previously registered so unable to login and access firmware and when i try to register it I get the above message about trade in unit.
0
 
carlmdCommented:
Where did you get this unit? It seems that is was used as a trade in (Secure Upgrade Plus) to obtain a newer Sonicwall. When this is done the trade in unit is disabled at the Sonicwall site, so you won't be able to do anything with it there.

A PRO 2040 is a pretty old device.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
DATA99Author Commented:
This unit was purchased years ago before my time joining and never registered from what I can see.  Another one was purchased as a back up but they bought it off ebay and it says it is already registered, I'm assuming with the previous owner and yeh they are quite old devices now but have to still them use them if I can.

Is there a chance the backup of the device is corrupt which is why it won't load or does the same firmware have to be loaded that it was on previously for this backup to load?
0
 
MiftaulCommented:
I usually create backup setting in the SonicWALL(not the export setting). Then update the firmware and select boot from the new firmware with settings.

I haven't tried exporting the settings, then update firmware and importing the setting. But believe it should work.
0
 
carlmdCommented:
Do either of these Sonicwalls have current subscriptions? If not, then what are you using them for? Without the update subscriptions for anti virus, ips and spyware, the device does not do much for you.

You might consider replacing these with a TZ215, which should offer a significant performance improvement. You can get these for about $825 with a one year CGSS subscription.
0
 
DATA99Author Commented:
No subscriptions from what I can gather.  They are being used for a VPN connection between two sites and DMZ as well as internet firewall etc for the site they are currently in.
0
 
carlmdCommented:
Given that at least one of these devices is a site firewall I would recomment you consider the upgrade to a new Sonicwall.

With that said, there is no reason why you should not be able to export the setting from one of your current devices and import them on the other. This does not require a Sonicwall account to so do. The only issue might be if the SonicOS is vastly difference between the two and the export has features not found on the import device.

FYI, resetting the Sonicwall to factory default should not change the version of the installed OS.
0
 
DATA99Author Commented:
Yeh i understand that the backup should just import straight in but it looks as though the firmware has changed and that is why I am thinking that that is the reason for not importing.

It has just been a factory reset but for the life of me can't remember the firmware that was on it prior to this being done on the device.
0
 
carlmdCommented:
If you look under System -> Settings it will show you the firmware versions. A reset will not change what was installed.
0

Featured Post

Managing Security Policy in a Changing Environment

The enterprise network environment is evolving rapidly as companies extend their physical data centers to embrace cloud computing and software-defined networking. This new reality means that the challenge of managing the security policy is much more dynamic and complex.

  • 4
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now