Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Unable to browse server by hostname

Posted on 2014-03-17
14
Medium Priority
?
229 Views
Last Modified: 2014-04-06
Good morning Experts,

I have one server running Windows Server 2008 R2 that is unable to connect to another server responsible for file and print sharing. The server running this is running server 2012. I am unable to browse via hostname to the server but can browse by FQDN as well as IP address. I have verified when pinging the server by hostname it is correctly resolving the IP address. I have tried disabling the windows firewall and 3rd party antivirus on the 2012 file server but am still seeing the same results. I have researched the issue but am having a hard time turning up any possible solutions. Any suggestions would be much appreciated!
0
Comment
Question by:PCNS_Tech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
  • 3
  • +1
14 Comments
 
LVL 4

Expert Comment

by:Kent Fichtner
ID: 39934620
I would try flushing the DNS on the computer.  Have you also tried rebooting?  Do any other computers have this same issue?
0
 

Author Comment

by:PCNS_Tech
ID: 39934627
I have flushed and registered DNS and the issue persisted. I have been hesitant to reboot as the server is running our TimeMatters database but am thinking I am going to have to give it a try. I have tried on another Server 2008 R2 box and 2012 box but none of them see these issues.
0
 
LVL 26

Expert Comment

by:pony10us
ID: 39934630
I know it may sound odd but check the time on the server against the time on the network.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:PCNS_Tech
ID: 39934637
They are both properly syncing with the domain controller.
0
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39934659
Please try to as shown below.

LAN
0
 
LVL 26

Expert Comment

by:pony10us
ID: 39934672
That was the next step I was going to recommend.  If you are not using WINS/NetBIOS (most people don't now) then appending the suffix this way should work.
0
 

Author Comment

by:PCNS_Tech
ID: 39934674
I have never done that before. I am assuming this is on the server experiencing the issue so it will make it use the FQDN for the connection. I am hesitant to put that in without more information. Will that append to all DNS queries?
0
 

Author Comment

by:PCNS_Tech
ID: 39934685
I added it just to see if it alleviated the issue but still no dice. Even after enabling it to append the DNS suffixes and adding the local domain I am still getting the windows cannot access servername.
0
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39934695
it is just to add suffix to your host name.

for example... if you will ping or access by hostname it will add suffix.

like, requested host name SERVER1 then it will add suffix and change to SERVER1.ABC.COM

MS reference: http://technet.microsoft.com/en-us/library/cc959611.aspx
0
 
LVL 26

Expert Comment

by:pony10us
ID: 39934702
Try changing it to the first option:  Append primary connection... and the sub option: Append parent suffix... should also be checked. Then look at the WINS tab and under the Netbios section the Default option should be selected.
0
 

Author Comment

by:PCNS_Tech
ID: 39934795
I have changed it back to the first option to append primary connection specific DNS suffixes and enabled the sub options. I have confirmed WINS has the default option selected. Same error message when attempting to browse the server.
0
 
LVL 13

Expert Comment

by:Santosh Gupta
ID: 39934814
Try this...

Go to C:\Windows\System32\drivers\etc and edit the host file.

and make a new entry. (example)

198.168.1.3                hostname
0
 

Accepted Solution

by:
PCNS_Tech earned 0 total points
ID: 39934829
I actually just got it. Since the workstation service is responsible for browsing I restarted it and voila I can now browse it. Thank you all for your suggestions!
0
 

Author Closing Comment

by:PCNS_Tech
ID: 39981017
Found the issue whilst continuing troubleshooting
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

OfficeMate Freezes on login or does not load after login credentials are input.
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question