Solved

L3 Inter-VLAN Routing

Posted on 2014-03-17
5
951 Views
Last Modified: 2014-03-27
This should be a simple one.  I have a 3750 setup as a L3 switch. I have two VLANs.

VLAN 20 and 132.

While logged into the switch I can ping devices on VLAN 20 and VLAN 132.  From a computer on VLAN 132, I cannot ping a computer on VLAN 20 and vice versa.

A computer on VLAN 132 can ping the VLAN 20 gateway 192.168.90.254.  
A computer on VLAN 20 can ping the VLAN 132 gateway 172.16.132.9.

What am I missing here?

no aaa new-model
switch 1 provision ws-c3750g-48ts
system mtu routing 1500
vtp mode transparent
authentication mac-move permit
ip subnet-zero
ip routing
no ip domain-lookup
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 10
 name CX_SPCI
!
vlan 20
 name CX_WEBDMZ
!
vlan 30
 name CX_UTILITY
!
vlan 40
 name CX_ROUTER_DMZ
!
vlan 50
 name CX_APPLICATION
!
vlan 60
 name CX_DEV
!
vlan 70
 name CX_CORPORATE
!
vlan 105
 name CX_ISCSI
!
vlan 124
 name M_DMZ
!
vlan 125
 name M_TRUST
!
vlan 131
 name VMOTION
!
vlan 132
 name MGMT
!
vlan 330,332,334,336,338,340,342,344,346,348,350,352,354,356
!
vlan 358
 name Tehama
!
ip ssh time-out 60
ip ssh version 2
!
!
interface Port-channel1
 description "LACP (E) Trunk to VRTX"
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel2
 description "LACP (M) Trunk to VRTX"
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel3
 description "LACP (CX) Trunk to VRTX"
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel4
 description "LACP (E) Uplink"
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel5
 description "LACP (M) Uplink"
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel6
 description "LACP (CX) Uplink"
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/1
 description "VRTX (E) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet1/0/2
 description "VRTX (E) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet1/0/3
 description "VRTX (E) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet1/0/4
 description "VRTX (E) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet1/0/5
 description "LACP (E) Uplink"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 4 mode active
!
interface GigabitEthernet1/0/6
 description "LACP (E) Uplink"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 4 mode active
!
interface GigabitEthernet1/0/7
 description "LACP (E) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 4 mode active
!
interface GigabitEthernet1/0/8
 description "LACP (E) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 4 mode active
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
 description "CMC (E)"
 switchport access vlan 132
 switchport mode access
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
 description "VRTX (M) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode active
!
interface GigabitEthernet1/0/18
 description "VRTX (M) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode active
!
interface GigabitEthernet1/0/19
 description "VRTX (M) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode active
!
interface GigabitEthernet1/0/20
 description "VRTX (M) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode active
!
interface GigabitEthernet1/0/21
 description "LACP (M) Uplink"
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/22
 description "LACP (M) Uplink"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 5 mode active
!
interface GigabitEthernet1/0/23
 description "LACP (M) Uplink"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 5 mode active
!
interface GigabitEthernet1/0/24
 description "LACP (M) Uplink"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 5 mode active
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface GigabitEthernet1/0/29
!
interface GigabitEthernet1/0/30
!
interface GigabitEthernet1/0/31
 description "CMC (MPAY)"
 switchport access vlan 132
 switchport mode access
!
interface GigabitEthernet1/0/32
!
interface GigabitEthernet1/0/33
 description "VRTX (CX) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 3 mode active
!
interface GigabitEthernet1/0/34
 description "VRTX (CX) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 3 mode active
!
interface GigabitEthernet1/0/35
 description "VRTX (CX) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 3 mode active
!
interface GigabitEthernet1/0/36
 description "VRTX (CX) Trunk"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 3 mode active
!
interface GigabitEthernet1/0/37
 description "LACP (CX) Uplink"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 6 mode active
!
interface GigabitEthernet1/0/38
 description "LACP (CX) Uplink"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 6 mode active
!
interface GigabitEthernet1/0/39
 description "LACP (CX) Uplink"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 6 mode active
!
interface GigabitEthernet1/0/40
 description "LACP (CX) Uplink"
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 6 mode active
!
interface GigabitEthernet1/0/41
!
interface GigabitEthernet1/0/42
!
interface GigabitEthernet1/0/43
!
interface GigabitEthernet1/0/44
!
interface GigabitEthernet1/0/45
!
interface GigabitEthernet1/0/46
!
interface GigabitEthernet1/0/47
 description "CMC (CX)"
 switchport access vlan 132
 switchport mode access
!
interface GigabitEthernet1/0/48
 switchport access vlan 132
 switchport mode access
!
interface GigabitEthernet1/0/49
!
interface GigabitEthernet1/0/50
!
interface GigabitEthernet1/0/51
!
interface GigabitEthernet1/0/52
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 192.168.116.190 255.255.255.0
!
interface Vlan20
 ip address 192.168.90.254 255.255.255.0
!
interface Vlan132
 ip address 172.16.132.9 255.255.255.0
!
interface Vlan358
 ip address 10.2.58.253 255.255.255.0
!
ip default-gateway 172.16.132.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.132.1
ip route 10.2.58.0 255.255.255.0 172.16.1.254
ip route 192.168.116.0 255.255.255.0 192.168.116.129
ip http server
ip http secure-server
!
ip sla enable reaction-alerts
0
Comment
Question by:lconnell
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 46

Accepted Solution

by:
Craig Beck earned 500 total points
ID: 39936644
Each PC needs to use the switch as its default gateway, so a PC using 192.168.90.100 needs to use 192.168.90.254 as its default gateway, and the PC using 172.16.132.100 needs to use 172.16.132.9 as its default gateway.

Machines on each VLAN need to use a gateway or they won't be able to send or receive traffic from other VLANs.

For example, if you configure a default gateway on a PC on VLAN20, and try to ping a device on VLAN132 which doesn't have a default gateway configured, the ping will fail.
0
 

Author Comment

by:lconnell
ID: 39936856
Doh!! I knew that.  I had the 172.16.132.0 network using a different gateway!! 172.16.132.1 instead of .9.

Thank you!
0
 
LVL 46

Expert Comment

by:Craig Beck
ID: 39937607
:-)
0
 

Author Comment

by:lconnell
ID: 39960725
Can I tag you in my new questions so you always know when I post? lol
0
 

Author Comment

by:lconnell
ID: 39960750
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question