Solved

Remote Desktop problem on server

Posted on 2014-03-18
9
303 Views
Last Modified: 2014-03-19
Good day,

I've got an issue with RPD on server 2008. The RDP function has never worked since the server was installed. Up untill recently we normally logged in through logmein. The RDP licensing is configured properly and everything shows that it must be working when I compare it to other servers. It's not just from external networks but also when I RDP from a computer on the local network. I get the following error message:

Remote desktop can't connect to the remote computer for one of these reasons:

1) remote access to the server is not enabled.
2) the remote computer is turned off.
3) the remote computer is not available on the network.

Is there anything specific I can look at that may be causing this?
0
Comment
Question by:Lourensvd
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 2

Expert Comment

by:IMGIDC
ID: 39936293
Hi,

- can you check your windows firewall for RDP specific instructions.
- did you check RDP setting, to make sure you are not restricted RDP.

(what is the client machine OS) RDP settings
0
 
LVL 10

Expert Comment

by:Mohammed Rahman
ID: 39936382
Are you able to ping  from the computer through which you are trying to remote into server 2008?
0
 
LVL 2

Expert Comment

by:CTCRM
ID: 39936395
Is the 2008 server on the same subnet as the clients trying to RDP from?
How many clients on your network?
And the error message you're receiving, is that the same for all client PCs on the network?
When launching RDP from a client run as Administrator just in case the account you are using isn't in the an RDP Security Group (AD), if there is such a group apparent in your AD?
When launching RDP are you trying to connect via server IP address, or Hostname?
If hostname make sure that there is a DNS entry for the 2008 server you're trying to connect to>
0
Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

 
LVL 11

Expert Comment

by:Manjunath Sullad
ID: 39936404
Are you able to ping to the server ?

Check the PING - ping Server name

Check the RDP port is open on server.
telnet servername or IP Address 3389

Try disableing the Windows Firewall also disable antivirus to check.

Make sure your ID is added to Remote desktop users group.


- Manjunath Sullad
0
 

Author Comment

by:Lourensvd
ID: 39938931
Hi, thanks for the replies. I disabled antivirus and firewall to test. I also removed and reinstalled the terminal services role. I can't telnet to the server through port 3389 like you mentioned. I can ping the server computer from the other computers.
0
 
LVL 11

Accepted Solution

by:
Manjunath Sullad earned 500 total points
ID: 39939052
If you are unable to telnet to port means, You can't take RDP.

make sure that you have enabled Telnet, If you are using Win 7.

Else refer below link to enable telnet in Win7 and server side.

http://technet.microsoft.com/en-us/library/cc771275(v=ws.10).aspx


Check any firewall is blocking RDP session,

Also check below registry path, and make sure that RDP port is correctly configured.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber

Also refer : http://support.microsoft.com/kb/187628/en-us 


- Manjunath Sullad
0
 

Author Comment

by:Lourensvd
ID: 39939208
Hi thanks, I checked that telnet is installed on both.
I did however check the RDP port in registry and it is configured as 3390.
So when I telnet to the server using the port 3390 it works, but when I remote dekstop to the server it still gives the same message(See first message). I also put the port number 3390 at the back but it still won't connect.
0
 
LVL 11

Expert Comment

by:Manjunath Sullad
ID: 39939262
Start --> Run -->

mstsc /v Servername:3390


- Manjunath Sullad
0
 

Author Closing Comment

by:Lourensvd
ID: 39939382
Thank you very much, I can now RDP to the server from local and external network.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

FIPS stands for the Federal Information Processing Standardisation and FIPS 140-2 is a collection of standards that are generically associated with hardware and software cryptography. In most cases, people can refer to this as the method of encrypti…
Resolve DNS query failed errors for Exchange

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question