Solved

Exchange wont send email to particular domains

Posted on 2014-03-18
6
568 Views
Last Modified: 2014-03-20
For the most part, our email works great.  However we are getting some failed emails to some (two) outside organizations.  The error in the Exchange Queue Viewer is Error: 450 4.7.1 Client host rejected: cannot find your hostname, [IPADDRESS].  The issue I see is the IP address it lists is the ip address we use to browse the internet, not the SMTP address.  There are reverse DNS and pointer records for both our primary and secondary MX records.
0
Comment
Question by:SidwellIT
6 Comments
 
LVL 8

Expert Comment

by:s3e3
ID: 39936926
It sounds like your firewall issue.
Are you sure your firewall is passing outbound SMTP traffic using the the IP address of the SMTP server ?

You can double check by sending yourself an email and looking at the headers.
0
 
LVL 19

Expert Comment

by:R--R
ID: 39937176
It should be the outside IP of the firewall.  Please try to telnet to the recipient mx from your network using telnet and check what output u get.
0
 

Author Comment

by:SidwellIT
ID: 39937209
When I view the header of an email I sent to my gmail, it is from the outside IP address of the firewall,

Received: from smtp-gateway.domain.edu ([OutsideIPofthFirewall])
        by mx.google.com with ESMTPS id 4si2386828qat.114.2014.03.05.19.36.39

I would have thought that it would use the public DNS entry for smtp-gateway.domain.edu instead of the IP address of the firewall.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 8

Assisted Solution

by:s3e3
s3e3 earned 250 total points
ID: 39937225
no, the dns entry and firewall are interdependent.
you can either fix this from the firewall or adjust the dns servers and ensure the outbound ip has a reverse dns entry for sending mail. Maybe option 1 is easier depending on the firewall make and model .
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 250 total points
ID: 39937301
Sounds like you haven't got your outbound NAT configured correctly on the firewall.
You need to check there so the traffic is going out the same way as it is coming in.

I would do that rather than trying to get the traffic accepted on your default IP address, that way you reduce the risk of getting blacklisted.

Simon.
0
 

Author Closing Comment

by:SidwellIT
ID: 39942161
Thanks guys!  Changing the Source IP for outgoing SMTP traffic solved our problem.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question