• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5061
  • Last Modified:

SQL Developer database connection keeps closing

I use SQL Developer connected to my companies database over vpn.  It seems like a database connection must be reconnected if there is no activity in 30 minutes, it drives me crazy!  I can leave Toad for SQL Server connections open for hours without having to reconnect.

Are there any settings I can change in SQL Developer to extent the connection time?

Also I use connection type 'Basic' and do not have the Oracle Client installed on my desktop.

Thanks!
0
gantone1
Asked:
gantone1
  • 3
  • 2
  • 2
  • +2
1 Solution
 
Gerwin Jansen, EE MVETopic Advisor Commented:
You could turning DBMS output on and setting the polling frequency to once every minute or so.
0
 
MikeOM_DBACommented:
1) Check out if the database is using resource manager and "disconnecting" you.
2) Check out if listener is disconnecting you, check SQLNET.EXPIRE_TIME in the sqlnet.ora file at the server.
0
 
Geert GruwezOracle dbaCommented:
check if the firewall disconnects idle connections after 30 minutes
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Praveen Kumar ChandrashekatrDatabase Analysist Senior Commented:
As MikeOM mentioned check if you any resource manager configured in which ideal timeout as set which is logging you off or the Firewall is enabled.
0
 
gantone1Author Commented:
Per our IT staff I have Windows Firewall turned off and we use Mcaffee VirusScan Enterprise + AntiSpyware Enterprise 8.8.

Is there a firewall within MCaffee and if so how is that configured?
0
 
Praveen Kumar ChandrashekatrDatabase Analysist Senior Commented:
I think McAfee may be blocking the port which you are trying to access or it would have set some timeout , can you check with your IT team the same.  

Also you can crosscheck the same by disabling the McAfee software and connecting to database.
0
 
gantone1Author Commented:
I disabled MCaffee and am still getting database timeout.  Maybe this is within our VPN?
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
@gantone1 - You've only replied to the firewall comments give, not the other ones. Did you try the other suggestions as well?
0
 
gantone1Author Commented:
Could not get it to work, switched to Toad and it does much better job re-connecting so I can live with disconnect.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 3
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now