• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1153
  • Last Modified:

Windows7 administrator cannot open folders/files

I have recently installed windows7 on a PC

Quite often when I try to open a folder I will get a message as per image attached

and I can go no further.
In Security> Permissions I am listed as Administrators

Access denied
0
johnhardy
Asked:
johnhardy
  • 7
  • 5
  • 3
  • +3
5 Solutions
 
JohnBusiness Consultant (Owner)Commented:
What folder?

You get this message with Program Folders and usually you have to OK yourself in. That is UAC (User Account Control) kicking in.

If you are trying to access another user's folders, you will have to take ownership of them.

I often use a neutral folder (C:\temp with permission to "Everyone") to hold files that more than one user might wish to access.
0
 
helpfinderIT ConsultantCommented:
are these files/folders from some backup, or another user profile?
when you right click it and go to Properties>Security>Advanced>Effective permission and type your user name into box? Do you have permissions liste there?

If you in the same Properties>Security>Edit>Add try to add your user name with Full control permissions and apply?
0
 
Dan CraciunIT ConsultantCommented:
If you transferred data from another computer, those folders have another owner.

One quick and dirty way to solve this is to run in an elevated command prompt:
TAKEOWN /f C:\your\dir /r /d y
ICACLS C:\your\dir /grant administrators:F /t

Open in new window

Replace C:\your\dir with the actual path.

HTH,
Dan
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
johnhardyAuthor Commented:
Thanks for the answers.
The drive is a backup of a C; drive

If I right click on the folder which fails, I can see the administrators with full permissions.

In the cmd view I entered as the image attached but it seems to have the error "and"

Image
0
 
Dan CraciunIT ConsultantCommented:
Use "" if you have spaces in your path.

TAKEOWN /f "J:\Documents and Settings\John" /r /d y
ICACLS "J:\Documents and Settings\John" /grant administrators:F /t

Open in new window

0
 
johnhardyAuthor Commented:
I received another error as per image attached.

image CMD2
0
 
Dan CraciunIT ConsultantCommented:
By any chance you're using Windows Home edition?
0
 
johnhardyAuthor Commented:
When I try to change permissions on the drive it states
The media is write protected
0
 
Dan CraciunIT ConsultantCommented:
That message usually means the partition is something else than NTFS. Since it's Windows, most probably FAT32.

Is that a HDD or an USB stick?

Anyway, if it's FAT32, you don't really have any security descriptors on it, so the files should be accessible. They might be read only or hidden, but that's about it.
0
 
johnhardyAuthor Commented:
Its a HDD and the file is created by a backup program.
I will ask at the seller of the software.
Thanks
John
0
 
McKnifeCommented:
This "problem" is as old as vista (nearly 8 years).
docs and settings is not present in vista/7/8/... it's only a symbolic link. That's no folder (although it looks as one). Read something at https://www.google.com/search?q=%22documents+and+settings%22+access+denied+symbolic&sourceid=ie7&rls=com.microsoft:en-US:IE-Address&ie=&oe=#q=%22documents+and+settings%22+%22access+denied%22+symbolic
0
 
JohnBusiness Consultant (Owner)Commented:
It's a HDD and the file is created by a backup program.

Let us know what the vendor support people say. I have done what you have done many time and can access the files just fine if the hard drive is mechanically ok.
0
 
johnhardyAuthor Commented:
Thanks very much for the extra information.
As soon as I hear more I will come back with this.

The system backed up was from WinXP not Vista.
0
 
McKnifeCommented:
Ok, xp, then it's no symbolic link.
Your command lines show, that you don't act elevated. Without elevation, admins=users and users may not take ownership. Via explorer, move to the security tab and take ownership.  Close the dialogues, reopen it, move to the sec. tab and give your account full access. This works as I have done that myself with "xp drives" on win7.
0
 
gheistCommented:
run chkdsk /f to delete bad security descriptors restored by backup program
0
 
johnhardyAuthor Commented:
Thanks
I am still having problems running as administrator I think....

message says
Access Denied as you do not have sufficient privileges.
You have to invoke this utility running in elevated mode
0
 
gheistCommented:
So you have to invoke cmd.exe in elevated mode and then run commands from that cmd.exe
0
 
Dan CraciunIT ConsultantCommented:
Right click cmd and select "Run as administrator"
0
 
johnhardyAuthor Commented:
Many thanks to you all for helping me so much.
I found an interesting article at http://searchenterprisedesktop.techtarget.com/tip/How-to-run-the-chkdsk-utility-in-Windows-7 
The files are opening correctly now.
Regards

John
0
 
JohnBusiness Consultant (Owner)Commented:
@johnhardy - Thanks for the update and glad you got it working.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

  • 7
  • 5
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now