?
Solved

MS SQL server consumes more memory and does not release the memory

Posted on 2014-03-19
4
Medium Priority
?
250 Views
Last Modified: 2014-03-20
Hi,
     I am running the database server with the following configuration.
The SQL Server consumes the hole memory(14 GB) and does not release the memory.
As a result the performance of the database server is reduced.

Please help me to resolve the issue.

 IBM System x3650
Windows 2008 server standard 64 bit
HDD:148 GB (RAID 5)
RAM :14 GB
MS SQL Server 2012 64 bit
Current Database Size: 7 GB
0
Comment
Question by:NARANTHIRAN
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 35

Assisted Solution

by:Dan Craciun
Dan Craciun earned 600 total points
ID: 39938963
Use this page to configure max server memory: http://technet.microsoft.com/en-us/library/ms178067.aspx

The easiest way is to use the Management Studio.

HTH,
Dan
0
 
LVL 52

Accepted Solution

by:
Carl Tawn earned 900 total points
ID: 39939159
You need to configure the MAX MEMORY to be at least a couple of GB less that the available system memory - you need to leave some for the OS to use.

Try running the following to bring the MAX MEMORY down to 12GB:
sp_configure 'show advanced options','1'
go

reconfigure with override
go

sp_configure 'max server memory (MB)','12288'
go

reconfigure with override
go

sp_configure 'show advanced options','0'
go

reconfigure with override
go

Open in new window

0
 
LVL 1

Expert Comment

by:SrinivasanITPro
ID: 39939318
Hi

I would check / change the following;

- Increase the Virtual Memory (Swap) to 1.5 times to RAM
- If any unused SQL Instances are available, I would STOP that.

Please check the above and feedback.

KS
0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 39944116
The SQL Server consumes the hole memory(14 GB) and does not release the memory.
As a result the performance of the database server is reduced.

You have it back to front.  SQL Server by design will use all memory made available and not release it.  So if your performance is lousy it is not because SQL Server is using all the memory, quite the opposite, it just means that you either don't have enough memory or more likely you need to optimize the query or queries running.

Yes, you can set the max memory and provided you are not running anything else on that box i would recommend 11 or 12GB (see here)
0

Featured Post

Moving data to the cloud? Find out if you’re ready

Before moving to the cloud, it is important to carefully define your db needs, plan for the migration & understand prod. environment. This wp explains how to define what you need from a cloud provider, plan for the migration & what putting a cloud solution into practice entails.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

International Data Corporation (IDC) prognosticates that before the current the year gets over disbursing on IT framework products to be sent in cloud environs will be $37.1B.
The Delta outage: 650 cancelled flights, more than 1200 delayed flights, thousands of frustrated customers, tens of millions of dollars in damages – plus untold reputational damage to one of the world’s most trusted airlines. All due to a catastroph…
This video shows, step by step, how to configure Oracle Heterogeneous Services via the Generic Gateway Agent in order to make a connection from an Oracle session and access a remote SQL Server database table.
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question