Solved

Update AcrobatReader 11.0.06 by SCCM 2012

Posted on 2014-03-19
7
1,615 Views
Last Modified: 2014-03-21
I try to update AcrobatReader using SCCm 2012.
My base image has AdobeReader 11.0.00, I want to update to version 11.0.06.
When I sent the package to a test computer without AcrobatReader, it is installed without problem.  But when I sent to  PCs with AdobeReader 11.0.00 installed, I got a error 0x87D00324 (-2016410844) for some computers and others stay "in progress" content Downloaded.

For detection rule, I use the default MSI Product Code and MSI Property Version Equals 11.0.06
Command-to-install-application.PNG
Detection-Rule.PNG
In-Progress.PNG
0
Comment
Question by:uxtico
  • 5
  • 2
7 Comments
 
LVL 38

Accepted Solution

by:
Adam Brown earned 500 total points
ID: 39940661
It sounds like the file you're using is the full install rather than an update package. If you run the full install to install acrobat reader you would need to first uninstall the earlier version from the machines that have it, so create a check that will look for AcrobatReader 11.0.0 and uninstall it.
0
 
LVL 1

Author Comment

by:uxtico
ID: 39940709
How can I apply only the AcrobatReader update?
0
 
LVL 38

Expert Comment

by:Adam Brown
ID: 39940896
You should be able to download a package that contains only the update from Adobe if they make it available. If there is no update package for it, you could potentially create an Update MSI by snapshotting a system before and after the update and packaging the changes in an MSI, then setting up a package that pushes that out. Not sure how well that would go, though. I'm not 100% sure about this, but I think Adobe's updater actually uninstalls the old version and installs the new version when it does its work. I haven't dug that deep into it.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 1

Author Comment

by:uxtico
ID: 39941938
When I did the transforms, I check the option for uninstall the previous version.  I need to test if this is working.
0
 
LVL 1

Author Comment

by:uxtico
ID: 39943531
Yes, the application don't uninstall the previous version, but if you go to Programs and features you can see the Adobe Reader XI(11.0.06), but the actual software is in 11.0.0.
When I try to run the command manually I got a error that needs to close Adobe Reader, but nothing is running.  I add a file with the error
Adobe-Reader-is-in-use.PNG
Adobe-version-11.0.0.PNG
control-panel.PNG
0
 
LVL 1

Author Comment

by:uxtico
ID: 39944213
You are right, the solution is uninstall the previous version. How can I do a check that will look for Acrobat Reader 11.0.0 and uninstall it?
0
 
LVL 1

Author Comment

by:uxtico
ID: 39946347
We need to uninstall the previous version, to install a new updated full version.
To avoid it I create a package in SCCM with the update only.
the command line you will be  msiexec.exe /p patchname.msp /qn
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Have you ever had a hard drive that you can't boot into, but need to change the registry? Here is the solution! This article guides you through accessing and editing a registry of a non-primary drive. To read registry information on a non-prim…
When you upgrade from Windows 8 to 8.1 or to Windows 10 or if you are like me you are on the Insider Program you may find yourself with many 450MB recovery partitions.  With a traditional disk that may not be a problem but with relatively smaller SS…
This tutorial covers a step-by-step guide to install VisualVM launcher in eclipse.
The viewer will learn how to synchronize PHP projects with a remote server in NetBeans IDE 8.0 for Windows.

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now