Solved

Exchange 2010 send connector being ignored

Posted on 2014-03-19
4
576 Views
Last Modified: 2014-04-01
We created a send connector for a sharepoint 2013 farm for the requirement of supporting incoming email for a sharepoint 2013 farm and for some reason all emails sent by the sharepoint server are being relayed through exchange server rather than the sharepoint farm. I have found numerous articles on building a send connector and have created the connector many times but still with no success. I have even followed this article using the send connector for exchange ONLY and still no success http://digitalmacgyver.wordpress.com/2013/04/22/step-by-step-guide-in-configuring-incoming-email-in-sharepoint-2010-with-exchange/

What I found strange was in creating send connectors in the past at least a queue would be appear in the toolbox section of the exchange queue viewer. This apparently does not show up but understand that email queues are persistent and close if not used. Logging directly into the sharepoint server where smtp is installed when trying to send via command line powershell we receive an unable to mail relay 5.7.1 error message using a fake user. I understand that sharepoint can send email two ways. One by AD/EXCHANGE and the other without a mailbox but pointed to a document library. Please help if you can thanks
0
Comment
Question by:techdrive
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 19

Assisted Solution

by:Peter Hutchison
Peter Hutchison earned 100 total points
ID: 39941722
Do you have any details of how you setup the send connector?
Address space, source servers, network addresses etc.
0
 

Author Comment

by:techdrive
ID: 39941739
Yes I do the address space would reveal the company so lets use the following

address space=servername.contoso.com
source servers= exchange servers in our environment
network addreses= sharepoint smart host ip address
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 400 total points
ID: 39941998
Ensure that the Cost for all other connectors are set to 2, and the cost of this specific one is set to 1. Then restart the transport service.

Simon.
0
 

Author Comment

by:techdrive
ID: 39969158
It was two things. I ended up creating a MX record pointing toward the host and making a fake domain something.something.com and that worked with the send connector to sharepoint, thanks
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question