Windows PPTP VPN can connect, but not communicate.

Hello,

I have a Server 2012 that I set up RRAS PPTP VPN access on. On any client/platform I can authenticate and connect without issue. I can also ping the router of the remote network and get response. However, I can not ping or access any computers on the remote network by either name or IP. I currently have RRAS configured fro DHCP passthrough from the DHCP server located on the same box. I pull an address from the pool, but it lacks subnet and gateway. I've looked through the RRAS options and see nothing. The DHCP server is configured correctly as the settings (subnet, router, etc) are all correct and this is the same pool the computers on the remote network obtain addressing from without issue. Did some searching on Google, but found nothing to point me in the right direction.
Mandr1chAsked:
Who is Participating?
 
Mike RoeConnect With a Mentor Commented:
Do you have a DHCP relay agent setup in RRAS?  This will use your current DHCP addresses and gateway like your other clients.  VPN thinks it is another network when you connect to it from a client.  This is by default.

Here is also a good link to set this up

http://myhosting.com/kb/index.php?/article/AA-01167/0/Create-a-VPN-on-Windows-Server-2012-VPS.html
0
 
Mike RoeCommented:
On your client side make sure your router if you are using one allows VPN passthru and is enabled.

Also do you a firewall turned on?  you need to allow tcp port 1723 and protocol port 47 GRE
0
 
Mandr1chAuthor Commented:
Using a Netgear WNR1000V3 behind a Comcast SMB. Ports 1723 and 47 are open on the Netgear. The SMB is configured in bridge mode and a static public IP is applied to the WAN side of the router. I've tried specifying the server IP as DMZ on the Netgear and had the same issue.

I have to go back and check, but now that I'm thinking of it, I had a hub connected up in between the Netgear and SMB to capture traffic. If I recall correctly, I could connect and browse when I tested the VPN. Might be the SMB interfering though it is in passthrough mode. Hrm...
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Mandr1chAuthor Commented:
I was incorrect. I was getting responses because I also had a wireless connection to the local network while testing on site. I currently am connecting through a hub connected to the WAN side of the router. Like before, I can authenticate, but can not browse. The only device I can access is the router via internal IP.  I have the router set to DMZ mode for the server IP.

As before, I am getting an IP from the DHCP pool. No subnet mask. For some reason the gateway IP is the server itself. Though it's an IP created in RRAS and not the actual IP assigned to the NIC.
0
 
Mike RoeCommented:
Try to turn off the DMZ mode.  With firewall you need to have icmp open to get replies from ping.  You should also get the same default gateway as your internal network is getting.  I would check and make sure that the RRAS is not giving out different IP addresses
0
 
Mandr1chAuthor Commented:
I get the same results with DMZ enabled and disabled. Currently switched it back to disabled.  I believe it's an addressing related issue. After removing and re-adding RRAS I did get things somewhat working. However, I'm still getting odd addressing. So I would expect to see something like this.

IP: 192.168.0.220
Sub: 255.255.255.0
Gate: 192.168.0.1

However, while I do get an address from the DHCP pool assigned, it looks more like this:

IP: 192.168.0.220
Gate 192.168.0.201

I can't ping  or connect to the server by it's normal IP. But if I put in that incorrect gateway, I get ping and connectivity as that IP is also the server.
0
 
Mike RoeCommented:
is your RRAS running in a virtual?
0
 
Mike RoeCommented:
Did you setup the relay agent?
0
All Courses

From novice to tech pro — start learning today.