Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Configuring SonicPoints on SonicWall NSA with Netgear switches

Posted on 2014-03-20
9
887 Views
Last Modified: 2014-03-29
My goal is to plug multiple SonicPoints into my network of Netgear ProSafe switches and allow access to the LAN for employees and then access to the Internet for guests. I believe I am close to getting this working since when I plug a SonicPoint directly into X2 of the SonicWall, the SonicPoint comes up, offers the two SSIDs, and allows me to connect and surf.

My issue is placing the Netgear switches into the equation. It seems that I lose DHCP on one of the networks when I try different VLAN options. The SonicWall is configured with X0 and X2 bridged together. X0 is the LAN, X2 WLAN, and I have a VLAN 10 on X2:V10.  Right now I have DHCP coming from the SonicWall for both virtual access points.

Can somebody tell me the correct way to set the VLAN settings to make this work? Do I need to have X0 plugged into the switch since the SonicPoint seems to work fine plugged directly into X2? If I plug X0 and X2 into the switch, won't it create a loop?

Thanks for any assistance.
0
Comment
Question by:neothink
  • 5
  • 4
9 Comments
 
LVL 39

Expert Comment

by:Aaron Tomosky
ID: 39945356
Are these smart switches you can log into?
0
 

Author Comment

by:neothink
ID: 39945365
Yes, FSM726. I currently have a console cable on them but they have a web gui as well.
0
 
LVL 39

Expert Comment

by:Aaron Tomosky
ID: 39945408
Good, so you need to add vlan10 to the switch, and allow it "tagged" out the sonicwall port and whatever ports the sonicpoint are plugged into.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 

Author Comment

by:neothink
ID: 39945455
I did that but I couldn't get everything to work correctly. What PVID do I use for each port?
0
 
LVL 39

Expert Comment

by:Aaron Tomosky
ID: 39945471
Pvid is what vlan gets assigned to untagged packets, so the default vlan. You normally want this vlan to leave the switch untagged as well.
0
 

Author Comment

by:neothink
ID: 39945478
I have removed the bridge and have configured a Cisco Catalyst 3500 and everything works as it should. The problem is I need to use the Netgear switches.  The Cisco config is pretty basic I think.

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
aaa new-model
aaa authentication login default local
enable secret 5 $1$zekz$B5Y2vR/bfrsHV8KIR6dC/.
!
!
!
!
!
!
no spanning-tree vlan 1
ip subnet-zero
no ip domain-lookup
!
!
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
.
.
.
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 192.168.2.11 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 192.168.2.1
!
line con 0
 transport input none
 stopbits 1
line vty 5 15
!
end
0
 
LVL 39

Assisted Solution

by:Aaron Tomosky
Aaron Tomosky earned 250 total points
ID: 39945728
Ive only done netgear through the gui
http://www.manualowl.com/m/Netgear/FSM726/Manual/4290
page 81 (page 41 has some cli info)

by default all ports are untagged vlan1 pvid vlan1
All you should have to do is add vlan10, then set the ports you want vlan10 tagged out (access vlan10) as "T" on this screen. I believe that trunk mode and encapsulation dot1q are default
0
 

Accepted Solution

by:
neothink earned 0 total points
ID: 39950095
It turns out the SonicWall & SonicPoints don't play nice out of the box. You would think you could plug each of them into your LAN switches and have it supply wireless to your LAN but you would be mistaken. Here is the article I found that pointed me in the correct direction.

http://briandagan.com/fix-configuring-sonicpoint-aps-on-a-sonicwall

Thanks for your help Aaron.
0
 

Author Closing Comment

by:neothink
ID: 39963523
It turns out the SonicWall & SonicPoints don't play nice out of the box. You would think you could plug each of them into your LAN switches and have it supply wireless to your LAN but you would be mistaken. Here is the article I found that pointed me in the correct direction.

http://briandagan.com/fix-configuring-sonicpoint-aps-on-a-sonicwall
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Routing between two networks? 10 76
Wired Network vs Wireless 12 66
Setup another VLAN on Fortigate 3 30
Guest Wireless in a Business Environment 6 96
I eventually solved a perplexing problem setting up telnet for a new switch.  I installed a new Cisco WS-03560X-24P switch connected to an existing Cisco 4506 running a WS-X4013-10GE Sup II-Plus. After configuring vlans and trunking,  I could no…
Need WiFi? Often, there are perfectly good networks that don't have WiFi capability - and there's a need to add it.  - Perhaps you have an Ethernet port into a network but no WiFi nearby. - Perhaps you have a powerline extender and no WiFi at the…
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question