?
Solved

"Find" tool malfunction in FMPro 8.5

Posted on 2014-03-20
8
Medium Priority
?
221 Views
Last Modified: 2014-03-21
Good Afternoon,

  I have a database that I created in FMPro 8.5 Advanced.  In it I am using 4 finds which all seemed to be functioning correctly.  Because of how the person who is entering data was putting in the information, I changed how one of the drop downs lists each item in its list.  Since I have done that I am unable to do any finds for that list with the exception of (2) of the items in the drop down.  All of the characters are an exact match, and I have tried to delete the drop down list and recreate it, and type character by character in the find.  Nothing working.  Box pops up saying that I need to Modify my Search.  

  Any ideas?
0
Comment
Question by:bobrossi56
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 25

Expert Comment

by:Will Loving
ID: 39943915
Well, it's kind of a long shot, but I would check the field type and see if it's set correctly, presumably to Text. If it's set to number,  you might not get what you expect when you do a Find.
0
 
LVL 6

Expert Comment

by:slinkygn
ID: 39944045
What do you mean when you say you changed "how one of the drop downs lists each item in its list?"  What in particular did you change?
0
 
LVL 5

Expert Comment

by:Peter Harris
ID: 39944070
I would put a second copy of the same field on the layout (or on a test layout) and format without a pop-up or anything, just as editable text.

This will help you to see exactly what is in the field on each record.

Remember the default searching in FileMaker is from the start of each word (without using wildcards etc.) For example If the text in the field is TheWidget then searching for Widget will not work.

It may also help to go click in the (plain editable) field and choose Insert > From Index... which will list all the things that have been entered in all the records. This may show you that some entries are slightly different to others perhaps.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:bobrossi56
ID: 39945175
To explain better, I changed the the actual word that was input.  In other words I initially setup the field as Mill #1, Mill#2, etc.  Once the user started entering data I noticed he was using fuller names of mills such as Bonding Mill #1, Rolling Mill #2, etc.  All I did was redefine what was in the Value List.  

  I have tried both other answers to no avail.  I am still able to Find two different Values from the list, but none of the others.  I did notice some entries slightly different by inserting From Index, but even those entered correctly still come up with "Modify Search Results".
0
 
LVL 25

Accepted Solution

by:
Will Loving earned 2000 total points
ID: 39945238
The "Modify Search Results" simply recreates your most recent Find entries so that you can modify them for refining your search. Try performing Finds are shorter versions of the names, such as just "Rolling" or just "Bonding".  It may give yo more than one result but it might help narrow down the issue.

Are you entering your search criteria directly or in quotes? Putting quotes around it restricts the Find the string within the quotes. If you are using quotes and not typing it correctly it may not find the values. Be aware too that the # symbol has a specific meaning in FileMaker's search operators. If this field is going to be searched on a lot you might want to consider avoiding use of the # symbol. (You can use the "Replace" function to replace all instances of a specific value with something else, e.g. Replace all instances of "Bonding Mill #1" with "Bonding Mill 1"

Try a search for all records with any value by using the ampersand character *  See if the number of records with values is correct and that you can actually see all the values the user has entered or look at the records in a List or Table view that contains the search field to see if there is anything unusual about the entries.

Finally, if you're still having problems, post an example file with some fake data in it. I'm guessing if I can see the file I'm know exactly what is going on in short order.
0
 
LVL 6

Expert Comment

by:slinkygn
ID: 39945261
Do you see your old entries when you use Insert-> From Index? (Mill #1, Mill #2, etc.)  If you change the values in the value list, that won't change the old data - you have to replace those yourself. If you see the old ones in Insert->From Index that means you still have records using the old list items.

If this isn't your problem, you may have a corrupted index. Try this: go into Define Database, and find and click on the field that contains the mill data we're talking about and click on Options. In the Storage tab, change Indexing to "None." Then OK your way all the way back out to the main file (I generally tell people to then close and reopen the file, just to make absolutely sure they're out), and then go back into that Options page in Define Database and turn the index back on.
0
 

Author Closing Comment

by:bobrossi56
ID: 39945441
The # symbol was the exact problem.  Once we started doing finds without the # symbol everything was found cleanly.  Thank you very much for the solution.  I will be making a note to get rid of the # symbol throughout the database.
0
 
LVL 6

Expert Comment

by:slinkygn
ID: 39945541
If getting rid of all of them is a problem, remember that you can simply surround the find criteria with double quotes, e.g.:
"Bonding Mill #1"
instead of:
Bonding Mill #1
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Pop up windows can be a useful feature of any Filemaker database.  Though best used sparingly, they can be employed in a multitude of different ways, for example;  as a splash screen at login, during scripted processes to control user input, as pick…
Problem: You have a hosted FileMaker database and users are tired of having to use Open Remote or Open Recent to access the database. They say, "can't you just give us something to double-click on rather than have to go through those dialogs?" An…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question