Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1714
  • Last Modified:

Remote Desktop connection issues - Windows 7

I have a couple workstations on my internal domain where I can not establish a remote desktop connection.  When I try to connect to these workstations, I get a "Remote Desk can't connect to the remote computer for one of these reasons:" error.

This is what I have done to try to resolve the issue:
1) Verified that the remote user does have permissions to connect to the workstation
2) Turned off the firewall (we are using F-Secure)
3) Stopped all the F-Secure services
4) Tried to telnet the port "3389", no connection should be established

So it appears that port "3389" is still being blocked somehow.  What is the best way to figure out what is blocking that port on the desktop?
0
shrimpfork
Asked:
shrimpfork
  • 7
  • 5
  • 2
  • +2
2 Solutions
 
arekkusu82Commented:
Some questions.
Can you ping the machine (by name and/or ip address)?
Can you ping your machine from the one your are trying to connect to?

You can check what ports are open with CurrPorts. Sometimes, disabling the firewall completely requires that you restart the machine as well. I havenoticed this at leat with the Windows Firewall.
0
 
Santosh GuptaCommented:
Hi,

Did you checked windows 7 firewall ?
0
 
shrimpforkAuthor Commented:
@ arekkusu82:  Yes, I can ping each machine from the other.  I checked the port on the machine that I am trying to connect to using "netstat -ano" and I do not see where port 3389 is listening.  I am not using windows firewall.  F-Secure has an option to allow all connections, which I have also tried.

@ Santosh Gupta:  I am not using windows firewall.  But yes when I went into the windows firewall setting, the Remote Desktop is selected as an allowed program in the domain.
0
Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

 
Santosh GuptaCommented:
Hi,

Which AntiVirus you are using ??
0
 
shrimpforkAuthor Commented:
F-Secure PSB Workstation Security
0
 
Santosh GuptaCommented:
Hi,

Use the TCPView to check that which port is being used by which process/program.
http://technet.microsoft.com/en-us/sysinternals/bb897437.aspx
0
 
arekkusu82Commented:
Can you completely disable F-Secure to rule out is not blocking the incoming traffic.

I have Remote Services running on my machine and I can see this under CurrPorts:

System      1800      TCP      3389      ms-wbt-server      0.0.0.0                  0.0.0.0            Listening                                    N/A            CryptSvc, Dnscache, LanmanWorkstation, NlaSvc, TermService            21/03/2014 1:30:02 p.m.                        
System      1800      TCP      3389      ms-wbt-server      ::                  ::            Listening                                    N/A            CryptSvc, Dnscache, LanmanWorkstation, NlaSvc, TermService            21/03/2014 1:30:02 p.m.
0
 
ranadastidarCommented:
try to use teamviewer
0
 
shrimpforkAuthor Commented:
Using TCPView, port 3389 is not listed on the computer that I am trying to connect to.
0
 
Santosh GuptaCommented:
Please check if "remote desktop services security filter driver" is disabled.

To check whether this enabled or disabled,
open device manager and show hidden devices. if it is not enable it, if it is already enabled, disable and re-enable it.

if unable to enable it, uninstall it and reboot the server.
0
 
shrimpforkAuthor Commented:
"Remote Desktop Services Security Filter Driver" is not listed in the devices.  (I compared the list it to a computer that is working.)  So now what?
0
 
shrimpforkAuthor Commented:
So I removed Microsoft Update KB2667402 and the remote desktop is now working.  What is KB2667402 for and do I need it?
0
 
Santosh GuptaCommented:
Hi,

As per Microsoft, This security update resolves two privately reported vulnerabilities in the Remote Desktop Protocol. The more severe of these vulnerabilities could allow remote code execution if an attacker sends a sequence of specially crafted RDP packets to an affected system. By default, the Remote Desktop Protocol (RDP) is not enabled on any Windows operating system. Systems that do not have RDP enabled are not at risk

http://technet.microsoft.com/en-us/security/bulletin/ms12-020

if you dont have puble/internet facing system then you do not need this update.
0
 
LeeTutorretiredCommented:
I've requested that this question be deleted for the following reason:

Not enough information to confirm an answer.
0
 
shrimpforkAuthor Commented:
There is a solution to this question.  I discovered it myself as it was posted.  I just forgot to close the questions.  Please cancel this close request so that I can properly assign points.
0
 
shrimpforkAuthor Commented:
I found the solution while searching the web.  The second part of the points, confirmed that I did not need the KB update for my environment.
0

Featured Post

Put Machine Learning to Work--Protect Your Clients

Machine learning means Smarter Cybersecurity™ Solutions.
As technology continues to advance, managing and analyzing massive data sets just can’t be accomplished by humans alone. It requires huge amounts of memory and storage, as well as the high-speed power of the cloud.

  • 7
  • 5
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now