Solved

Error while opening exchange powershell in exchange 2010 Sp3

Posted on 2014-03-21
6
584 Views
Last Modified: 2014-03-26
Getting following error, while opening exchange powershell.

Connecting to remote server failed with the following error message : The WinRM client sent
 a request to an HTTP server and got a response saying the requested HTTP URL was not available. This is usually return
ed by a HTTP server that does not support the WS-Management protocol. For more information, see the about_Remote_Troubl
eshooting Help topic.
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
   eption
    + FullyQualifiedErrorId : PSSessionOpenFailed


Tried stuff
1. Re-install WinRM add-in
2. Ran WinRM QuickConfig
3. Restarted IIS
4. Rebooted machine.


But no luck, all other exchange tasks are working fine.
0
Comment
Question by:Krishna Patil
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 9

Expert Comment

by:Mahesh Sharma
ID: 39944730
Try below steps:

1.Open IIS Manager, and then navigate to Default Web Site.
2.Right-click Default Web Site, and then click Edit Bindings.
3.If a binding exists for HTTP, clear the host name value.
4.If no binding exists for HTTP, create a new binding that has no host name and a value of All Unassigned for the IP address.
5.Restart IIS.
0
 
LVL 3

Author Comment

by:Krishna Patil
ID: 39944797
Also tried EMTSHOOTER.PS1 scripts. BUT no luck
0
 
LVL 9

Expert Comment

by:Mahesh Sharma
ID: 39944814
What's the output of EMTSHOOTER.ps1 script?
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 
LVL 3

Author Comment

by:Krishna Patil
ID: 39944833
[Servername.domain.com] Connecting to remote server failed with the following error message : The WinRM client sent
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExcep
    + FullyQualifiedErrorId : PSSessionOpenFailed
The Exchange Management Troubleshooter successfully completed connecting to:

Servername.domain.com

Failed to connect to any Exchange Server in the current site.

Problem found:

Looking for error...

These are the possible causes for this error:

1. The default http binding has been removed from the Default Web Site. Exchange Powershell needs http to be configured
so that the IP Address is "All Unassigned", the Port is "80", and the Host Name is "".  A common scenario for changing t
his is if you are running multiple web sites, and attempting to set up a redirect to https://mail.company.com/owa by req
uiring SSL on the Default Web Site, and creating another web site to do the redirect back to the SSL-enabled website. Re
mote PowerShell requires port 80 to be available on the Default Web Site for all Internet Addresses. If you want to set
up an automatic redirect to /owa and redirect http requests to https, you should follow the instructions located at:

http://technet.microsoft.com/en-us/library/aa998359(EXCHG.80).aspx

and follow the directions under the section:
"For a Configuration in Which SSL is required on the Default Web Site or on the OWA Virtual Directory in IIS 7.0."

2. The http binding on the Default Web Site has been modified, and the Hostname field configured. To correct this issue,
 you need to clear out the Hostname field under the port 80 bindings on the Default Web Site.

After each error is resolved, close this window and re-run the tool to check for additional problems.
0
 
LVL 3

Accepted Solution

by:
Krishna Patil earned 0 total points
ID: 39944863
Issue got autoresolved after correcting host file entries for IPs
0
 
LVL 3

Author Closing Comment

by:Krishna Patil
ID: 39955480
Issue got autoresolved after correcting host file entries for IPs
0

Featured Post

MS Dynamics Made Instantly Simpler

Make Your Microsoft Dynamics Investment Count  & Drastically Decrease Training Time by Providing Intuitive Step-By-Step WalkThru Tutorials.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article explains how to install and use the NTBackup utility that comes with Windows Server.
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question