Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

XML in body converted to Attachment in Exchange 2010

Posted on 2014-03-21
14
525 Views
Last Modified: 2014-05-29
Hi - I've just migrated a mailbox from Exchange 2003 to Exchange 2010 and emails which contain XML in the body of the message are saved as XML attachments in exchange 2010.

Is there a way to turn this off or change the default group policy?

We receive a large number of emails from difference sources so its not possible to make a change to the emails.
0
Comment
Question by:Iron-Mike
14 Comments
 
LVL 5

Expert Comment

by:arjunvyavahare
ID: 39945017
This same is happening from Exchange 2010 OWA?

Regards,
Arjun
0
 

Author Comment

by:Iron-Mike
ID: 39945024
We don't use OWA as there is an application which monitors the email box and strips the XML contained within the body of an email and saves it to a file.
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 39945137
Did you just answer your own question there?  What application are you referring to?
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:Iron-Mike
ID: 39945144
No I was responding to the previous post. I just need to know how to allow exchange 2010 to accept emails with XML in the body as it is currently saving stripping out the XML in the body and saving it as an attachment.
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 39945195
And he asked if you were to look at an email using OWA, does it show the XML as being stripped out?

We're trying to figure out if it is being stripped out by the transport, the server, or the client.
0
 

Author Comment

by:Iron-Mike
ID: 39945265
Sorry, we are looking at the email from outlook 2003 client. But it worked when the mailbox was stored on the Exchange 2003 server
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 39945560
Okay, so lets keep rolling here with the information...  You used to have Exchange 2003, now you have exchange 2010.  Clients are using Outlook 2003.  XML files used to come through on Exchange 2003 no problem. With exchange 2010, those xml files are being converted to an attachment to the message.

Now: What are the origins of these xml files?  When those files are sent via email, how does the message look using OWA.  Is it already converted to an attachment there?  When the message is sent, is the sent message show as an attachment or in the body of the email?
0
 
LVL 2

Expert Comment

by:allen_rich
ID: 39949678
0
 

Author Comment

by:Iron-Mike
ID: 39949864
Thanks for your posts. In response to jrhelgeson question, it appears as an attachment in web mail as well.

We have hundreds or applications sending in this format so any change at the senders end will be very difficult to make.  So the email is sent with the xml in the body, it then reaches the exchange 2010 server and the body message is blank and the XML saved as an attachment in web mail and in the outlook client we use to monitor the email.

It work perfectly in exchange 2003 so must be a security update that surely could be changed somewhere in the configuration?
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 39950349
Are these messages coming in from internal IP addresses, or do they come from devices across the internet?
0
 

Author Comment

by:Iron-Mike
ID: 39950360
They are coming in from devices across the internet
0
 
LVL 15

Accepted Solution

by:
jrhelgeson earned 500 total points
ID: 39950891
The answer is going to be in creating a proper transport rule.  You'll need to tweak the rules and settings, but this should get you started in the right direction - if not solve it outright.

Create Transport Rule as follows:
MANAGING MIME TYPE
1) Within Exchange System Manager, select | Organization Configuration | Hub Transport | Transport Rules Tab
2) Right-click and select "New Transport Rule"
3) Select the conditions “from users that are inside or outside the organization” and ‘when the message header contains specific words”.
4) Select the action '”set header with value”.
5) Create the new transport rule.

To verify if the transport rule is working, you have to enable pipeline tracking on the HUB transport server. Now you can send a new message with xml to see if the transport rule changes the Content-Type.
0
 

Author Comment

by:Iron-Mike
ID: 39950977
Many thanks, I'm fairly new to exchange 2010....how do you enable pipeline tracking and what's it for?
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 39951059
Here is a link that does a pretty good job outlining "Pipeline Tracing" it and its uses:
http://howexchangeworks.com/2011/06/troubleshooting-transport-using.html 

Note: I incorrectly said "Tracking" in my previous comment - the proper word is "Tracing"

Also: When you create the rule, you select the conditions “from users that are inside or outside the organization” - but the rule will show "inside the organization".  Click on the text in the rule "inside the organization" and you'll be able to choose "outside the organization" from the drop-down menu.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
how to add IIS SMTP to handle application/Scanner relays into office 365.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

789 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question