Solved

Exchange 2013 & Outlook 2010 - Multiple Email Domain Account - Prompts for password for secondary domain

Posted on 2014-03-22
17
28 Views
Last Modified: 2016-01-16
Hello,
I have an issue with our Outlook 2010 clients that when connecting to our exchange 2013 server which hosts 2 domains (mail.domain1.com, mail.domain2.com)

All the SRV auto discover records in DNS point to mail.domain1.com to setup outlook (since we just have 1 mail server)


If a user has has both email accounts setup in their outlook 2010 they we always continuously be prompted for password when initially logging into Outlook for the secondary domain (mail.domain2.com)

Any suggestions if this issue can be overcome would be great.
0
Comment
Question by:ntmyflt
  • 5
  • 5
  • 5
17 Comments
 
LVL 6

Expert Comment

by:rick81
Comment Utility
if its prompting for the 2nd account details make sure you have them correct.
type in the details like

username - domain\username  (domain is the internal domain)
password -  whatever the password is.

if you can get this to authenticate then tick the box that says remember password.  if you dont see that option download SP2 for office 2010 and install.  it will then give that option in outlook 2010 once installed.
0
 

Author Comment

by:ntmyflt
Comment Utility
Hi Rick, thanks for your reply, I can assure you that the password is correct and that I've checked the "remember password" box.

Here's the scenario:

The user logs into the terminal with domain\username

Click on the outlook icon and his outlook profile has 2 accounts associated with it

user@domain.com
user@domain2.com (this is an actual active directory domain and exchange account as well)

So in a sense when the user is logging into their Outlook they're accessing their secondary active domain domain email account (user@domain2.com) from the primary account (user@domain.com).

I've tried both ways to authenticated when being prompted by Outlook:
user@domain2.dom  --> UPN
domain\user  

I hope this helps.

Thanks,
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
Comment Utility
Does the user have permissions on the second account? With one mail server, having two active accounts rarely makes sense. What I usually do here is give the primary WINDOWS account Full Mailbox and Send As permissions to the second account, then make the second account a shared mailbox. No login required.

Simon.
0
 
LVL 6

Expert Comment

by:rick81
Comment Utility
What Simon has suggested is a better way to set this up.
Give the main account full access to the secondary account.  full access and send access.  then add the second account into outlook as an additional mailbox.

under account settings, account settings > double click on the email account > more settings > advanced tab > add > type in the second mailbox or select from browse, etc.  Ok, next, finish.

http://technet.microsoft.com/en-us/library/bb676551%28v=exchg.141%29.aspx
0
 
LVL 63

Assisted Solution

by:Simon Butler (Sembee)
Simon Butler (Sembee) earned 500 total points
Comment Utility
"under account settings, account settings > double click on the email account > more settings > advanced tab > add > type in the second mailbox or select from browse, etc.  Ok, next, finish."

The better option is to not use that method at all, but instead with Outlook 2010 add the second mailbox as an additional ACCOUNT. That way you get notifications, rules etc for the second account as well as the first.
Adding it as an additional mailbox in Outlook does not give you notifications or rules access.

Simon.
0
 
LVL 6

Expert Comment

by:rick81
Comment Utility
isnt that what ntmyflt is trying to achieve originally.  having both accounts setup in outlook 2010?

'If a user has has both email accounts setup in their outlook 2010 they we always continuously be prompted for password'
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
Comment Utility
Correct - but if you grant the permissions to the second account using the first, then you don't get authentication prompts.

I have six accounts in my Outlook, five of them "Shared" accounts, none generate a prompt, all setup as I have outlined.

Simon.
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 

Author Comment

by:ntmyflt
Comment Utility
Hi Simon,
Thanks for your suggestion, the one thing that I find though when you set it up like that is that the user needs to remember to change the "from" box before sending an email even when clicking on the other inbox and trying to compose it.
Seems like a small thing but employees will forget to do it at times, is there a way to make the from to change properly depending on the inbox your in? similar to when you setup 2 actual separate mail accounts?
0
 
LVL 63

Assisted Solution

by:Simon Butler (Sembee)
Simon Butler (Sembee) earned 500 total points
Comment Utility
On my Outlook, if I am in the inbox for account 2 and hit new email, then the from field is populated automatically. Similarly if I reply to a message I don't have to change the from field at all. That is with the additional ACCOUNT method, not the additional MAILBOX method.

Simon.
0
 

Author Comment

by:ntmyflt
Comment Utility
Hi Simon,
Correct yes using the additional account method is exactly the way we have it setup now.

The issue though is that it doesn't seem to want to remember the password for that second account. This is happening from a Windows 2008 R2 RDS server, if I try to replicate the issue from my local workstation which is Windows 8 pro and running the exact same version and build of Outlook I don't get the issue. The password is remembered each and every time.

The error message I receive when attempting to add that secondary account in Outlook on the RDS server is:
"The name cannot be resolved. The name cannot be matched to a name in the address list"
The settings that pop-up are the following:
Microsoft Exchange Server:
c85d3635-d387-487a-af27-aadb39081f3d@<second-domain.com>

Mailbox:
=SMTP:username@second-domain.com

If I change the Microsoft Exchange Server settings to our internal exchange server name:
exchange01 I'm still returned the exact same message as above: "The Name cannot be resolved..."

If instead I place our domain controller (dc01) dns name into the Microsoft Exchange Server box it then gives me a pop-up box where I'm prompted to put in the credentials for user@second-domain.com and at that point it authenticates properly and populates the Microsoft Exchange Server box with: c85d3635-d387-487a-af27-aadb39081f3d@second-domain.com and detects and adds the secondary account to the Outlook account.

So it all looks good but as when I go to open outlook I am then prompted for that second account password again.. as soon as I enter it I can get into outlook and both accounts work beautifully and independent of one another.. it's just that it won't remember the account.
And now having done further testing it seems to be happening only on this RDS server which everyone logs into and not local workstations.


Here's the version of my Outlook if it makes a difference:
Outlook 2010 x32 (14.0.7116.5000) -- same thing as with my workstation
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
Comment Utility
"The issue though is that it doesn't seem to want to remember the password for that second account"

If you had set it up as I had outlined, including the permission changes, then the password for the second account WOULD NOT MATTER.

You grant the permissions to the primary WINDOWS account to allow access to the additional accounts.

The password prompt would be something else completely, most likely related to Autodiscover, which would appear to be the case here as the autodiscover result is coming back wrong. If Autodiscover doesn't work properly, then you get authentication prompts. They aren't an authentication error, that is simply because Outlook doesn't know what else to do.

Simon.
0
 
LVL 6

Expert Comment

by:rick81
Comment Utility
Your RDS server is joined to your domain?
0
 

Author Comment

by:ntmyflt
Comment Utility
Hi Simon,
If it were an autodiscover issue I would think it wouldn't work properly on my workstation which is on the same domain?

Hi Rick, yes the RDS server is joined to the domain as well

Thanks guys,
0
 
LVL 6

Expert Comment

by:rick81
Comment Utility
if you havent already download and install office 2010 sp2

http://support.microsoft.com/kb/2687455
0
 

Author Comment

by:ntmyflt
Comment Utility
Hi Rick,
MS Office on this computer does have SP2 already on it.

Thanks,
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Check out this infographic on what you need to make a good email signature that will work perfectly for your organization.
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now