Solved

How to stop Outlook from trying to configure with a user

Posted on 2014-03-24
15
1,317 Views
Last Modified: 2014-07-07
Hello.

We are having problems after migrating customers from on premise exchange servers to office365.

The on premise servers are sbs and are kept in as local servers, just not running exchange anymore.

Everything works fine except one thing, we can't get the local outlook clients to stop trying to configure themselves automatically.

When you create a new outlook profile, on the first part the server autopopulates name and email address (and after that other stuff). Is there a way to prevent this?
We can't get outlook clients to stop populating themselves with that information directly from the server.

How do we prevent this?

Autodiscover is removed, everything from the app pool the all the exchange commands for that. We can't find anything in the local dns that does not point correctly to the office 365 info.

Do you have any ideas?
0
Comment
Question by:joebilek
  • 7
  • 4
  • 2
  • +1
15 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
Comment Utility
Have you actually removed Exchange from the servers?
Internally, Autodiscover doesn't use DNS records, it queries the domain directly. Therefore if the server is still there, then the information is still being published to the domain and the clients will still find it.

Simon.
0
 
LVL 38

Expert Comment

by:Vasil Michev (MVP)
Comment Utility
As Simon mentioned, Outlook will first hit the SCP endpoint, but you can work around this by adjusting some registry settings:

http://support.microsoft.com/kb/2212902

If you only want to remove the auto-populate for the username, that's controlled via GPO and the Office ADM(x) files:

user config -> administrative templates -> Outlook -> Account Settings -> Exchange -> Automatically configure profile based on Active Directory Primary SMTP address
0
 
LVL 1

Author Comment

by:joebilek
Comment Utility
Thanks guys.

It's an SBS and it will remain in production.
What do i do to make sure there's none of that internal autodiscover nonsense left?
Is it even possible if it's an SBS?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
Comment Utility
Forget that it is an SBS Server. That has nothing to do with it.
Has Exchange been removed?

Simon.
0
 
LVL 1

Author Comment

by:joebilek
Comment Utility
Vasil Michev:

Thank you. But that policy is not set for the domain (checkec wht the Group Policy Results wizard just in case). But they do auto populate like that.
0
 
LVL 1

Author Comment

by:joebilek
Comment Utility
Simon:

What do you mean by removed exactly?
Are we talking about closing down services or are we talking about ininstalling it from add/remove programs?

The services are disabled, but nothing is uninstalled.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
Comment Utility
Disabling the services is not enough. By removing, I mean removing, so there is no Exchange on the server at all. If you don't remove it then the domain information used by Outlook is still there and will get in the way.

If you are doing integration with Office365 and the on premise server, then remove everything but the management tools.

Simon.
0
Promote certifications in your email signature

Has your company recently won an award or achieved a certification? They'll no doubt want to show it off. Email signature images used to promote certifications & awards can instantly establish credibility with a recipient and provide you with numerous benefits.

 
LVL 38

Expert Comment

by:Adam Brown
Comment Utility
The domain information won't get in the way if you configure an Internal DNS zone for your public Domain Name on the SBS server that has an autodiscover record pointing to autodiscover.outlook.com. If you shut down the auto-populate in Outlook through GPO as recommended above, you can then configure users with their public email domain address (user@company.com rather than user@company.local) without Outlook attempting to communicate with AD.

Also, what version of SBS are you working with? 2010 and 2011 don't work well with Exchange removed (and it isn't supported by MS to do so). 2003 can handle it, though.
1
 
LVL 1

Author Comment

by:joebilek
Comment Utility
Hello acbrown2010:

We already have the dns setup just as you say.
And the GPO previously mentioned does not exist and never did. So that's not what's doing the auto-populate thing.

So that does not work at all.
They all use user@company.com, but the problem is still there..

Sbs 2008 in this case.
0
 
LVL 38

Expert Comment

by:Adam Brown
Comment Utility
Sorry, the didn't look at the GPO thing he mentioned. You would need to download the Administrative Templates for Whichever version of office you are using and add them to the policydefinitions folder in C:\windows or the SYSVOL if you've created a central policy store. The ADMX files for Office 2010 are here: http://www.microsoft.com/en-us/download/details.aspx?id=18968

Once you have the templates added to your group policy, you can go to User Configuration\Policies\Administrative Templates\Microsoft Outlook <version>\Account Settings\Exchange and set "Automatically Configure profile based on active directory primary smtp address" to Disabled.  That should stop Outlook from auto-creating the profile for you and let you put in the appropriate information as needed.
0
 
LVL 38

Expert Comment

by:Vasil Michev (MVP)
Comment Utility
It seems that joebilek is actually referring to the server settings, though his initial post was a bit misleading.

joebilek, run the 'Test email autoconfiguration' wizard in Outlook and post the results here (to launch it, hold the CTRL key and right-click on Outlook's icon in the tray, select Test email autoconfiguration, enter the username and password and clear the two 'GuesSmart' checkboxes). This will show us where exactly is Outlook obtaining the server settings from, and if indeed it's from the local Exchange server, you can use the workaround I provided above (http://support.microsoft.com/kb/2212902).

Another option is that those settings are populated via GPO, under the following keys:

user config -> administrative templates -> Outlook -> Account Settings -> Exchange -> RCP/HTTP Connection Flags
RPC Proxy Authentication settings
RCP Proxy server name
Only Connect if proxy server...
0
 
LVL 1

Author Comment

by:joebilek
Comment Utility
Hello, i realize i might have been a bit unclear to what my problem is.

The users are all in a windows domain hosted on their sbs server.
Until recently they had their mail on the sbs exchange.

We have migrated all mail to office 365, but they still use their sbs for everything else. Like a DC, DNS, File server etc.

The problem is that when a user without a mail profile on their local outlook start outlook it tries to autoconfigure itself creating a mail profile pointing to their old exchange server.
Even though we have the office 365 stuff setup in the local dns (like autodiscover etc) we still cannot use that if we do not change dns servers temporarily to google (for example).
As long as the sbs is the dns server for the clients, they will autopopulate outlook with the old information.
If a client is already configured correctly using the mentioned workaround. And it goes back to using the sbs as their dns (as they must) they will start getting login boxes and error messages regarding server certififaces that's expiring (the ones from the sbs).

So we just want this to stop.
We want the sbs to stop doing stuff the users outlook.

But i can't seem to find how. That's the problem.

So far i can't find anything is this thread that would work to fix this. Except maybe uninstalling using add/remove programs.
Does anyone know for sure if that's the key to success?
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
Comment Utility
If you are not going to use Exchange on the server, then remove it.
It isn't really possible to simply disable Exchange - it is too heavily integrated in to the domain to do that. As you have seen, Outlook still expects it to be there.

As Exchange is still present on the domain, the client never even gets as far as doing an Autodiscover using DNS records because that is always second to a query in to the domain for Autodiscover.

Simon.
0
 
LVL 1

Author Comment

by:joebilek
Comment Utility
Thank you.
Will try that as soon as i get a go ahead to do that.
Will reply when it's done.
0
 
LVL 1

Author Closing Comment

by:joebilek
Comment Utility
Removing Exchange is one way of solving the problem, another seems to be but we are not sure to setting the CAS settings using Powershell to null.
0

Featured Post

Are your corporate email signatures appalling?

Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

Join & Write a Comment

Synchronize a new Active Directory domain with an existing Office 365 tenant
Find out what Office 365 Transport Rules are, how they work and their limitations managing Office 365 signatures.
Microsoft Office Picture Manager has a Picture Shortcuts pane that shows a list with the Recently Browsed folders. While creating my video Micro Tutorial here at Experts Exchange showing How to Install Microsoft Office Picture Manager in Office 2013…
This video discusses moving either the default database or any database to a new volume.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now