Solved

Remote desktop Folder redirection to local computer's desktop

Posted on 2014-03-24
13
1,683 Views
Last Modified: 2014-04-20
I have two domains I am working with. domain A and domain B. On domain A I use remote desktop to connect to applications located on domain 2.

 I want to be able to redirect the remote desktop sessions,  desktop folder back to my computers desktop located in domain 1. I have tried folder redirection with no success using group policies. I tried \\tsclient\C\Users\%username%\Desktop\Remote_Docs\

I am using Server 2008 R2 and Windows 7 Clients

Please advice on what I can do to make this happen thanks.
0
Comment
Question by:h11
  • 7
  • 6
13 Comments
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 39951478
What errors do you get in the event logs when you try and map resources?  Is it denied by group policy or does it error out due to permissions?  Also, are they sharing the same forest, different domains?  Or different forests?  How are the trusts established?  Are they working?

If you're trying to map user folders out to \\tsclient\...  through group policy, I'm not sure how that would even work.  In theory it should...  Are you even able browse out to your \\tsclient\ folder when you connect in remotely?
0
 
LVL 2

Author Comment

by:h11
ID: 39952595
no errors they are in different forests, no errors from GP. No trusts because we are not allowed to create them.

We log into one forest with a CAC and the other we log in with username and password only as a RDP client. tsclient does not resolve when running from a run command. I was reading a forum and this is what they said to do to get it to work.
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 39953560
Do you have drive mapping enabled in your RDP client?  
See graphic below:

RDP Client Settings
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 
LVL 2

Author Comment

by:h11
ID: 39953581
yes I do have drive mapping enabled and if I do a \\tsclient\c\%username%\desktop I am able to cannect to my local desktop that I am using to RDP to my server.
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 39953659
So the problem is that you're just not able to push that out via Group Policy from the remote domain? Even though you can map it once the RDP is established.

Theoretically, this should work... How/where is the group policy being applied?  It is a user policy setting you're trying to change, but is the policy being applied to a users container, computer container, are you using Group Policy filtering?
0
 
LVL 2

Author Comment

by:h11
ID: 39953681
it is applied from a ou user. I believe the issue is the gp is applied and then the mapped drives so it does not see the network drive at that time.

I have a work around for this by setting a gp policy on log off to copy the rdp desktop to the local desktop. This works
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 39953822
But it isn't a network drive, you are providing a network path within the group policy. Right? In the GPO, you specify the path: \\tsclient\C\Users\%username%\Desktop\Remote_Docs\

I suspect the GPO is failing due to the client computer not being a member of the domain, not being able to login or authenticate with the domain.

I think you'd need to apply the user policy to the OU that the computer is in, then enable loopback processing within that GPO that provides the path of \\tsclient\C\Users\%username%\Desktop\Remote_Docs\
Make sure it is not trying to set any permissions on that folder, as it will not have any rights to do so.

You can also create a security group called "TSClient Folder Redirection" and put the users into that group, then filter the GPO to only apply to that terminal server, and those terminal users in the security group.
0
 
LVL 2

Author Comment

by:h11
ID: 39954396
When I rdp in I am a client of that domain and I can connect to all local shares and my local c: drive. I have applied the the policy to the ou of all the term serv users. still does not work.
When I do a rsop.msc on the rdp session I do not see the gp for the folder redirection even though it assigned to that ou.

 If I redirect the folders to the rdp clients folders it works fine.  It does not want work with a tsclient network drive for some reason.
0
 
LVL 15

Expert Comment

by:jrhelgeson
ID: 39954588
What happens when you run GPUPDATE /FORCE from the terminal services session?
Have you enabled loopback processing on the policy?
0
 
LVL 2

Author Comment

by:h11
ID: 39954628
Still does not work. On the loopback policy do you mean check the enforce button on the gp? if so yes
0
 
LVL 15

Accepted Solution

by:
jrhelgeson earned 500 total points
ID: 39956045
No - Loopback processing is the method whereby USER settings within a GPO can be applied to a computer object/container, and have the user policy settings be applied upon login.  Loopback processing must be enabled within the computer section of the Group Policy Object.

To enable “Loopback processing Mode”
Using Group Policy Management Console, edit the GPO you desire, expand Computer Configuration\Policies\Administrative Templates\System\Group Policy,
and then double-click User Group Policy Loopback Processing Mode.

Then select the appropriate option (Replace or Merge).

In your situation, I would apply the GPO to the computer object, with loopback processing enabled and set to 'Replace' mode.

More on GPPO Loopback Processing:
http://social.technet.microsoft.com/wiki/contents/articles/2548.windows-server-understand-user-group-policy-loopback-processing-mode.aspx
0
 
LVL 2

Author Comment

by:h11
ID: 39974669
I have not been able to test this yet
0
 
LVL 2

Author Comment

by:h11
ID: 40011463
it seems to work thanks
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
WinSCP resume failed transfer 3 163
MDT 2013 offline media asks for User Credentials 2 90
Deleting Folders 5 82
VPN Shared folder Access 3 74
Goal:  To set up a secure SSH server for your home computer to make it accessible anywhere AND to use it as a port forwarding proxy. Steps 1.  WinSSHD version 5 is free for personal use.  So download and install it.  You can download it from the…
Introduction People like FTP.  It's a solid, stable, robust protocol for quickly transferring files between two hosts using TCP/IP.  In most cases it's much faster than SMB or CIFS, and certainly much easier to set up between organizations.  This…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question