Joombla installation issues with synology ds411+

I have my sinology setup to have virtual web hosting, I have a number of domains that no-ip forwards to my ds411+.

The synology is a bit weird as it has a joombla install package But it can only install off the web directory once.

So.. .   Volume1/web/joombla.

If I use the install package I can add extensions and plugins.

However, I need the form:
Volume1/Web/Sitename1/ (joombla unzipped here
Volume1/Web/Sitename2/ (joombla unzipped here

If I do that I can get to the site and start the install no problem.

I have the issue that this way joombla wont let me install any templates or extensions or plugins.

The attached shows the warnings.

I have tried many avenues but the synology forum and joombla forum have given no replies and the little I have tried around permissions has failed.

I did run a forum tool and that's attached too.

The config files has logs and tmp directories to the correct location.

I don't understand enough to sort out the php stuff which is what I am guessing this issue is.

Help would be appreciated.
joombla.PNG
forum-post.txt
PeterBaileyUkAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
fiboConnect With a Mentor Commented:
looks like your php has enabled, as recommended, the "safedir" option. and so joomla/php cannot open dirs outside of the authorized paths
See http://www.php.net/manual/en/ini.core.php#ini.open-basedir

To solve the issue, you might consider placing symbolic links within safedir which links invisibly outside of it
0
 
PeterBaileyUkAuthor Commented:
ok i looked at the synology control panel, see attached, my open dir is off now as you can see should it be on?

in that text box is:
/etc.defaults:/etc:/usr/syno/synoman:/tmp:/var/services/tmp:/var/services/web:/var/services/homes

I read the link but dont understand it properly
eeopendir1.PNG
0
 
PeterBaileyUkAuthor Commented:
Forgot I didnt get this either "To solve the issue, you might consider placing symbolic links within safedir which links invisibly outside of it" :(
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
fiboCommented:
Discussion about php safe_mode explains that there are restrictions to which directory and files every php program will be able to access: if not restricted, programs could access to the whole disk of the server, not only the web site as usually intended.
Of course, every time you place limits, you might stumble on them: correct action is to ensure to stay within, rather that removing limits.

In your case, you need to assume that all the files you want to accss are within the limits.

Since they are out of the limits, how to achieve that? I would test the effect of using a symbolic link (see the 2nd scenario at page http://man.cx/ln)
Thus you should place somewhere within the safedir directories some logical link ointing to your synology directories: these last ones would now be accessable "within" your safedir
0
 
PeterBaileyUkAuthor Commented:
so do I add the whole directory :/acousticlaptops or just the :/acousticlaptops/tmp and :/acousticlaptops/logs ?
0
 
PeterBaileyUkAuthor Commented:
I added :/acousticlaptops

and it installed the extension

I am assuming I can remove the dir once I have done installing plugins and extension
0
 
fiboCommented:
placing :/acousticlaptops should enable all its subdirs (check howvere that they have the correct accss rights)
0
 
PeterBaileyUkAuthor Commented:
yes that was what was confusing me as i checked the rights.
0
 
PeterBaileyUkAuthor Commented:
thx solved the open dir issue.
0
 
fiboCommented:
B-) Glad I could help. Thx for the grade and points!
0
All Courses

From novice to tech pro — start learning today.