Solved

Unable to download OAB - Exchange 2013 CU3

Posted on 2014-03-24
16
802 Views
Last Modified: 2014-04-07
Running Exchange 2013 CU3 with about 120 mailboxes on a Windows 2012 VM.

I cannot reach https://CAS/OAB - I get a 403 Forbidden error; when Outlook tries to download, I get an error saying 'a file was not found' with a generic error code.
I verified permissions on the OAB directory and Authenticated Users have the appropriate ones.
I think I can rule out generation problems as the XML file along with all the LZX data files seem to be generating properly.

Help!

Thanks.
0
Comment
Question by:Roy7
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
  • 2
16 Comments
 
LVL 35

Expert Comment

by:Seth Simmons
ID: 39956532
I get an error saying 'a file was not found' with a generic error code.

what is the error code?
0
 

Author Comment

by:Roy7
ID: 39956750
Hi Seth,

The error code is 0x8004010F. When googling this code, I couldn't find anything similar to my issue.
0
 
LVL 35

Expert Comment

by:Seth Simmons
ID: 39956806
is this everyone or just 1 user?
what version of outlook?
0
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

 

Author Comment

by:Roy7
ID: 39956880
All users, not just one. Outlook 2013.
0
 

Author Comment

by:Roy7
ID: 39960102
Anyone...?
0
 
LVL 21

Expert Comment

by:Jakob Digranes
ID: 39984535
Can Outlook in Online mode or users in webmail see all contacts?
Can you try to create a new offline address book and see if that one can be downloaded?
What authentication is the OAB virtual directory configured with?
Fresh install or migration?
Do you have any http redirects on virtual directory?
0
 

Author Comment

by:Roy7
ID: 39984560
Hi jakob_di, thank you for replying. Apologies if I haven't included enough info - didn't quite know what was relevant.

1. Yes, Outlook in online mode and OWA works fine and am able to see all contact and lists.
2. Already tried that. We only have one OAB, so I tried erasing it and recreating it - no go.
3. Default, Windows Authentication (SSL enabled - but tried disabling it also, didn't do anything).
4. Migration from Exchange 2010. The Exchange 2010 is already out of the picture (clean uninstall).
5. None.
0
 
LVL 21

Expert Comment

by:Jakob Digranes
ID: 39984575
No problem, just trying to get an overview :-)

get-oabVirtualDirectory | fl *auth*,URL
Any errors in application logs in event viewer?

Can you try "Test Email Autoconfiguration" and see if you get correct OAB url?
http://comtechsolution.blogspot.no/2012/07/how-to-test-outlook-connection-and-auto.html
0
 

Author Comment

by:Roy7
ID: 39984596
[PS] C:\Windows\system32>get-oabVirtualDirectory | fl *auth*,URL


BasicAuthentication           : False
WindowsAuthentication         : True
OAuthAuthentication           : False
InternalAuthenticationMethods : {WindowsIntegrated}
ExternalAuthenticationMethods : {WindowsIntegrated}


No errors in event viewer.
Now tried accessing from my Mac on Safari and Chrome, it asks for credentials, and after entered it just brings up a blank page. No errors.
0
 
LVL 21

Accepted Solution

by:
Jakob Digranes earned 500 total points
ID: 39984603
more or less correct that ...
note - I changed my reply aswell, added:
Can you try "Test Email Autoconfiguration" and see if you get correct OAB url?
http://comtechsolution.blogspot.no/2012/07/how-to-test-outlook-connection-and-auto.html
0
 

Author Comment

by:Roy7
ID: 39984630
Unbelievable... All this time how didn't I realize?
I bit embarrassing - but I don't care, it's finally working.

The OAB address showed in the outlook test wasn't correct.
I set the correct one, iis reset, and boom.

Thank you for heading me in the right direction, jakob_di!

Can't believe this dragged for so long.
0
 

Author Closing Comment

by:Roy7
ID: 39984631
not a solution per se, but definitely tipped me in the right direction.
0
 
LVL 21

Expert Comment

by:Jakob Digranes
ID: 39985059
jolly good .... :-)
0

Featured Post

Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question