Excel Crystal Report Numeric Column Conversion

I am using an Excel fie as datasource for Crystal Reports. In the Excel file is a column that contains Account Numbers that is mainly numbers but also have some cells with alpha values.  I formatted the cells / column as text value.  In Crystal Reports, I would use the Excel file ( DAO )  as datasource.  The Account Number column is somehow defined as Numbers
( when I add the field and browse data, the field is type : Number  and I only see numeric values ).  How do I get Crystal Reports to see this column as text and not number  ?
Only numbers are appearing on the report and the text values are being bypassed.
phiadminAsked:
Who is Participating?
 
BlueYonderCommented:
Add an apostrophe before all of the account numbers.  This will change the format to text and will import correctly.
0
 
vastoCommented:
The ODBC driver will check the first 7 lines and try to detect the type of the values. Add a non-numeric character ( for example a letter)  to the cells in the first row, which you want to be text and verify database in crystal reports. Once the database is verified you can remove the added letter and to restore the original value of the cell.
0
 
phiadminAuthor Commented:
I already knew about the apostrophe to convert numbers to text but was trying to around it since the already exist and did not want to manually convert each row.  Answer 2 regarding the ODBC driver provided an inside that I did not know.  I did convert the first few row by adding an alpha character but the then the crystal report ignore all the numeric rows.  I change the file values several times to try different options but ended up using a combination of both answers.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.