Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Exchange2010 autodiscover / external domain name problem

Posted on 2014-03-24
3
Medium Priority
?
896 Views
Last Modified: 2014-03-25
Hello,
I have autodiscover functioning however, the server address it pulls is actually our internal not the external. Outlook automatically sets the server address to "servername.mydomain.local"

I need to change this to "remote.mydomain,com"

I have done some research and changed the send and receive connectors to display remote.mydomain.com.
I (re) ran the 'sertup external domain for client access' wizard as well. I have a feeling it was ran previously using the internal domain name..
I have verified that the entries in - server configuration|client access are correct for internal and external domains. Reset IIS and still no changes.

I have also ran the following commands - but it still is not working properly.
__________________________
Set-ClientAccessServer -Identity servername -AutodiscoverServiceInternalUri https://remote.mydomain.com/autodiscover/autodiscover.xml

Set-WebServicesVirtualDirectory -Identity "servername\EWS (Default Web Site)" -InternalUrl https://remote.mydomain.com/ews/exchange.asmx

Set-OABVirtualDirectory -Identity "servername\oab (Default Web Site)" -InternalUrl https://remote.mydomain.com/oab
___________________________

how can I change the server address that Exchange is sending out??
I have DNS entries on my internal DNS server so, the same address can be used on both intranet and internet.

Please let me know if you need any additional information.

as a last resort (and hopefully I didn't screw anything up) I rant he reset virtual directory wizard and that seemed to work - as in it reset my previous settings to the internal name of the server. I will try that on all the default sites and than run the setup external domain name wizard. Hopefully that will work.

Thanks!
0
Comment
Question by:eric55344
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 12

Expert Comment

by:Md. Mojahid
ID: 39952329
You have to create DNS record like autodiscover.yourdomain.com. and need to be SAN sll certificate by authorized sll certificate provider.

http://technet.microsoft.com/en-us/library/bb201695(v=exchg.141).aspx
http://acbrownit.wordpress.com/2012/12/20/internal-dns-and-exchange-autodiscover/
0
 

Author Comment

by:eric55344
ID: 39952368
That's already been done...

I have a trusted security certificate that has my EXTERNAL domain name "remote.mydomain.com"
I have entries listed in my DNS server and they are all functioning.

My clients ARE able to set outlook up automatically so autodiscovery IS working ---HOWEVER, the auto setup put the exchange servers address as the INTERNAL domain name, not the external name...

This creates a couple problems.
1st - we do not want our internal server name or internal domain name to be public information.
2nd - the security certificate does not contain our internal domain name SO, we are getting an SSL error in outlook. I am aware that I can simply add the internal domain to the certificate BUT that does not resolve that fact that we do not want our internal information to be public.


FYI, resetting the virtual directories and resetting up the "external domain name wizard" had no effect.
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 2000 total points
ID: 39952764
Sorry to say, but the behaviour you are seeing is correct. The server address will always be the internal server's address, and you cannot change that.
While you can change the address used by the clients via an RPC CAS Array, that should be a host name that does NOT resolve externally for Outlook Anywhere to work correctly.

The SSL prompts that you are seeing is nothing to do with the name of the server being populated by Autodiscover, it will be elsewhere in Exchange. Furthermore there is no need to change the SSL certificate to include internal server names - in fact that isn't even an option any longer as from November 2015 internal names on SSL certificates will be blocked.

All you need to do is configure Exchange correctly for your external host name.
http://semb.ee/hostnames

However you will not be able to hide the server's real name or other internal name from the Outlook client, as that is how Exchange works.

Simon.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New style of hardware planning for Microsoft Exchange server.
As much as Microsoft wants to kill off PST file support, just as they tried to do with public folders, there are still times when it is useful or downright necessary to export Exchange mailboxes to PST files. Thankfully, it is still possible to e…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question