What version of the JDK should I be using with Spring Tool Suite 3.4.0?


I'm installing Spring Tool Suite (STS) 3.4.0 on my Windows 7 64 bit machine.

Which version of the JDK should I be using with this version?

I tried pointing to jdk 1.7.0_51 and got the following error message:

The chosen JDK has the wrong version (available: null required: 1.6.0 - 99.0.0). Should this JDK be used anyway?

What should I be using?

jxbmaSoftware ConsultantAsked:
Who is Participating?
Tej Pratap Shukla ~DexterConnect With a Mentor Server AdministratorCommented:
Hey there
Try using the latest jdk 7 version for Spring Tool Suite (STS) 3.4.0. You could just update your jdk version and check if it works or not

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.