?
Solved

Exchange 2010 - AutoReply does not work for Shared mailbox

Posted on 2014-03-25
4
Medium Priority
?
1,282 Views
Last Modified: 2014-05-20
Dear Experts,

There is a Shared mailbox set for AutoReply with Powershell command:

Set-MailboxAutoReplyConfiguration "stadmin@it.com" -AutoReplyState Scheduled -StartTime "3/24/2014" -EndTime "9/15/2099" -ExternalMessage "Test message" -InternalMessage "Test message"

but somehow it does not work (the strange is that there are other shared mailboxes and only this has issue), so no reply comes back for the test attempt.

Basically at this mailbox (however also at the working ones), there is Forward to address set on server side, also the 'Deliver message to both forwarding address and mailbox' is set.

Do you have idea where could be issue, did someone had similiar problem?

Best Regards,
Zsolt
0
Comment
Question by:csehz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 10

Expert Comment

by:Marshal Hubs
ID: 39952874
Create a new regular user with the exact email address as the one you want to use for the shared mailbox (if its already made, you may have to get rid of it, and contact support and have them get rid of it completely on the back end). Use Outlook on a computer and setup outlook for this new user. Make a rule for this new user to reply to every email that comes in with whatever rule allows this. Once the rule is setup test and make sure by sending 3 or 4 emails to that new account and see if you get the reply each time to the same email address. Once you know it is replying to every email you have to go into Exchange Power Shell. (its easy, don't let it scare you). Setup your login email to have full permissions to this mailbox by typing this command in. "Add-MailboxPermission newsharedemailbox@yourdomain.com -User youremail@yourdomain.com -AccessRights FullAccess -InheritanceType All" (without quotes)

Then you want to convert the maillbox to shared, and it will remember the rule you made when it was not shared, but it was a regular mailbox.  Type in   "Set-Mailbox "newsharedemailbox" -Type:Shared"  (without Quotes).  

To change other settings etc. also, you want to make sure you go in and add those that have to have read and send rights for the newly converted shared mailbox. There may be a few things I missed here, but you won't jack anything up, it will either work or not. If you call Support, they can walk you through this if you explain what you are doing. Good Luck!
0
 
LVL 1

Author Comment

by:csehz
ID: 39953088
Thanks for the answers.

Basically as stated at the beginning, this is not a question about how to set AutoReply for Shared mailboxes. That has been done through PowerShell and works fine for the mailboxes, but except one.

So the question would be rather what can cause that, so working for all but for one not. Reading on the internet for example mentioned switched on Rules, or exceeded limit of Junk mails on the mailbox.

That is anyway fact that command

Get-InboxRule -Mailbox stadmin@it.com | FL

brings switched on Rules for that mailbox. But being on server side out of scope to disable/remove that and before of anything would be worth to know whether Rule can be reason of not working AutoReply

Thanks,
0
 
LVL 42

Accepted Solution

by:
Vasil Michev (MVP) earned 1500 total points
ID: 39954348
Forwarding and and OOO dont mix well, so use a Transport rule instead. For the forwarding part that is, otherwise you will flood the senders with OOO replies.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes how to import an Outlook PST file to Office 365 using a third party product to avoid Microsoft's Azure command line tool, saving you time.
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…
Suggested Courses
Course of the Month8 days, 12 hours left to enroll

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question