• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5872
  • Last Modified:

ip address - 169.254.x.x vs 192.168.1.1

when the router is doing its job, the pc's connected have an ip of 192.168.x.x
but when i disconnect the router cable for some reason and plug in again, it switched back to 169.254.x.x what could be cause for this and how to avoid it? (it cant go online now)

thanks
0
25112
Asked:
25112
7 Solutions
 
vmaganCommented:
when you get a 169.254 address it is because the pc cannot reach the DHCP server. that 169.254 is an Apipa address which stands for Automatic private IP address.

Make sure that it can reach the DHCP server.

if the router cable is plugged in and try to restart your pc or do an Ipconfig /renew to try and request another IP from the DHCP server.

I hope that helps.
0
 
englanddgCommented:
Yep.  Exactly what @vmagan said.

APIPA is "Automatic Private IP Addressing".  Whenever you see a 169.254.x.x address, that's why.  It means you don't have a local static IP assignment (i.e. you told the client machine to use DHCP) and the computer, for whatever reason, cannot reach the DHCP server.
0
 
vmaganCommented:
maybe even try giving that machine a static IP address.
0
Granular recovery for Microsoft Exchange

With Veeam Explorer for Microsoft Exchange you can choose the Exchange Servers and restore points you’re interested in, and Veeam Explorer will present the contents of those mailbox stores for browsing, searching and exporting.

 
YorickosCommented:
Its not receiving an address from the router, you can try to avoid this by configuring an static ip address in the range of 192.168 x.x.
0
 
Santosh GuptaCommented:
increase the lease period time of DHCP client on router.
0
 
deviprasad_sCommented:
vmagans answer is correct ,and i would like to add one more sentence ,

any computer in the computer network need to have the address to talk to each other computer in the network ,for
that reason : address space is reserved.
169.254 is the apipa address which gets automatically.
192.168. is the private address space ,which we assign
through dhcp server .


hope this thing help , give points to vmagan. not me .

thank you
0
 
John HurstBusiness Consultant (Owner)Commented:
In addition to all the suggestions above:

1. In my experience, a router is best connected to the source (modem - as I expect you mean by router cable) via DHCP to the modem.

2. Ask your ISP to reset the modem and then prepare to plug in the router set for DHCP to the modem.
0
 
25112Author Commented:
thanks all.. what finally helped was to say  'no proxy' and then it resolved back to 192.168.. thanks again for all the options. it could have been any of the so many things :)  !
0
 
vmaganCommented:
I've never seen a breakdown like this before lol. What is the point of this breakdown?
0
 
John HurstBusiness Consultant (Owner)Commented:
@25112 - Thanks for the update and I was happy to help.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now